bad crash last Saturday - can someone here read logs and analyze ?

well today just wasn't my day.
I wanted to video some today of a lake near here that is soon to be refilled after the dam was replaced for the 2nd time. I preflighted my IRIS+ and even flew it around the yard some, it operated flawlessly. so i got ready and went to the lake. I put in my battery, waited for the IRIS+ to give the green light.
i took off, flew around the perimeter of the lake some, and then headed offshore ( no water yet, just the streams ) i get about half way over the lake and suddenly the drone looses total control wobbled around violently, fell and crashed upside down. badly damaged.

What could have caused it to suddenly go out of control.. someone please help..

the flight lasted less than 1 min.. i was in loiter mode. full charged batteries.

i'll post logs on here...

2018-01-20%2015-39-08.bin

2018-01-20%2015-39-08.log

Views: 306

Replies to This Discussion

Hi Ray

I saw the logs. Looks like for some reason, the main accelerometer ACC1 stoped working at line 94.06 and then the stabiization sistem stopped too (see the RATE),and started to osscilate. The second accelerometer ACC2 worked fine but the stabilization never recover.

sorry for your copter

Your copter  fly four year without a crash....  I crashed half of my fly days. XD

I don't spend time on DIYD anymore, normally I'm over on discuss or one of our other communication channels.

In any case, I wanted to let you know that Peter Barker and I have seen this and will look into it.  I've raised an issue here.

All you have to do is to go to the Missionplanner and to convert the log file to a google earth file. You got to go to the Telemetry Logs and there you can convert the files.

Dataflash logs can also do that job.

looks like it just got some bad oscillation. Maybe was riding on the edge for some time then'''' wooow instability. That's what I see.

Your drone indeed was not flying much. In the morning I viewed the trajectory of your flight in google earth.

Attachments:

Hi.

It's not needed to use google earth.

Mission planner on his Log analyzer can show the map and the drone trajectory side by side with the graph of the parameter you selected.

Then, double click on the graph on any point and it show the exact position of the aircraft. It's very useful.

what could have caused this and what can i do to prevent it from happening again ?



Mauricio García said:

Hi Ray

I saw the logs. Looks like for some reason, the main accelerometer ACC1 stoped working at line 94.06 and then the stabiization sistem stopped too (see the RATE),and started to osscilate. The second accelerometer ACC2 worked fine but the stabilization never recover.

sorry for your copter

Your copter  fly four year without a crash....  I crashed half of my fly days. XD

what is wooow instability ? - the unit oscillated as it went down.. there was none before hand, i keep my props in exc. condition and very balanced. i use a prop balancer, and i also spin then on a motor at different speeds..



Greg Fletcher said:

looks like it just got some bad oscillation. Maybe was riding on the edge for some time then'''' wooow instability. That's what I see.

You should also watch some videos on youtube on how to set the PIDs of your drone properly. Then the drone shold not oscillate in the air. Pixhawk should work.

I don't think you can prevent that. You don't know what generate this malfunction.

You have to do an accelerometer calibration to see if they are working normally.

Maybe you have to load the last firmware update.

i tried the latest FW earlier , few weeks ago, but it would not take,,it would show BAD BRD TYPE .. i was unable to correct, so i reverted back to my old version of FW,, and i recalibrated everything as well. 

i flew the drone earlier at the house for over 10 min and it flew just fine as always..  i don't think i had a PID issue..

my drone is a IRIS+ FW v3.5.4

I don't thik it's a PID config issue too.

Ray said:

i tried the latest FW earlier , few weeks ago, but it would not take,,it would show BAD BRD TYPE .. i was unable to correct, so i reverted back to my old version of FW,, and i recalibrated everything as well. 

i flew the drone earlier at the house for over 10 min and it flew just fine as always..  i don't think i had a PID issue..

my drone is a IRIS+ FW v3.5.4

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service