How to modify the Iris+ firmware: eclipse errors and more

Hi,

I'm studying Aerospace engineering and currently I'm working on my master thesis. The final purpose of the project is to modify the firmware of the Iris+ drone, property of the University, in order to make it capable of carrying on new sensors.
To begin I have followed this video-guide: https://www.youtube.com/watch?v=k4L91tU4eHE
So I have installed the toolchain and dowloaded the software and right now I have the "px4" folder on my pc. I have also opened eclipse and started a new project from existing file choosing the folder "firmware" and it appeared on the left of the eclipse workbench.
Now I have some doubt and some questions:
1) This "firmware" folder appear to me like a general firmware, useful for many types of different drones. Is it the best idea to work on it in order to modify the code for the university drone or does exist a way to work specifically on the firmware of the Iris+?
2) When I open with eclipse one of the many .cpp file present inside the firmware main folder, such as the file firmware/src/drivers/led/led.cpp, eclipse find a lot of errors... So, since I have not touched anything but just dowloaded the firmware using the toolchain, how is it possible that files are filled with so many errors? Should not be everything clean and perfect?
I'm really desperate, so I will be really really grateful for any help!!!

 

Views: 177

Replies to This Discussion

Hey Mario. This would be a much better question to ask over in the Arducopter group. Most of the developers hang out in that group. Another option would be to go directly to the developers Google group here:

https://groups.google.com/forum/m/#!forum/drones-discuss

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service