Hello everyone:

Yesterday, what it seemed like a nice day to fly, it became the end to my IRIS+. I just started flying over a wheat field and suddenly the IRIS+ stopped responding telemetry commands, raised up itselft for about 50 meters, then flew away and went side until it crashed, like if a motor had stopped working.

The results: all the four legs got crashed, the chasis is all with scratches, the front red leds didn't turn on anymore and the GoPro Hero3+ housing scratches too. Fortunately the Gimbal was not installed.

I'm feeling pretty dissapointed now on the IRIS+ since I spent so much money on it. Today sent an email to Help department at 3DRobotics hoping for an explanation of what happened and looking forward for some kind of warranty.

Here is the video and the photo showing how the IRIS+ ended up so I wondering if you guys could notice something wrong on this attempt to fly.


Log files: https://www.dropbox.com/s/1nzuiixs0lba4ju/QUADROTOR.zip?dl=0

Views: 9665

Replies to This Discussion

Hi Quauhtli,
I'm sorry you had such a bad experience. Thank you for including the logs, we will review it and get back to you with an explanation of what happened.

same destiny for my IRIS+ ...i have read about a lot of similar crashes and in similar circumstances this last week unfortunately 

get flight logs from sd card inside your iris+ and send BIN files to 3DR as soon as possible, they will know what really happened. mine was compass failure :(

What flight mode were you flying in?

Based on the logs;

Nothing can prepare a pilot like this happening.  If you would have set Alt Hold you might have saved it.

I think there was a note to upgrade the firmware on IRIS+.  It looks like you experienced the worst case of that.

You should have noticed something during the first flight as things were off in that one.  It should have crashed then.

The second flight things were way off and you saw the results.  Alt Hold might have straighten the copter out so that you could have landed it safely.  Loiter, RTL, Auto were not working anymore.

Well it looks like a fun time putting it back together as it looks like it should go back together just like new.  Your confidence not so much.  I would make sure you put the latest firmware on that copter before you take it anywhere.

The copter is a dream to fly otherwise.



I had a similar experience on my first day as well. Watch the video, at point 1:30, and watch my IRIS+ just flip. This was the first of two crashes. The second, the Hulk-Smash, I was at about 150ft and it did the same. I lost the two rear legs and the props only, as the ground was soft... ha! It's actually pretty easy to repair, and I had purchased extra parts.

Now I have 4 spare sets of legs and 10 sets of props. LOL . I think one just has to accept that this is sometimes "experimental" and a learning experience, and anticipate a failure or two. As I have flown, I think more and more about contingency, and how I would react when something goes wrong. I've enjoyed it actually, with the occasional "oops!"

I sent my logs to support, but they said they could not find anything. I'm still learning how to analyze that data.


Here, this should give you a laugh... when I unboxed it, I wanted to hover it. Well, I think I had it in loiter mode... so it shot to the ceiling... I was flipping switches and everything... it eventually cam down, and took out my plant. :)

Glad to hear that! Appretiate your willingness to help :)

I was flying in LTR mode

Thanks for your comments, Michael. As you said, Alt Hold might have save it, but as I'm novice on this, on that moment I completely forgot that mode, just tried to activate the RTL mode but it didnt worked as you recalled.

Soon as I repaired (already purchased the 4 legs), I'm going to install the latest firmware as you suggest.

Sorry to read that, it feels so bad seeing your copter crashing. Fortunately I can replace the legs and the propels, as you did, but not my confidence. Anyway, soon as i repair it, I will try it again!

I haven't seen the log file yet but I am having issues with a front mounted gopro like he was using. This may or may not be the culprit but others should know about it. My gopro is a 3+ Black Edition.

My Iris is an original Iris upgraded to Iris+ and is running 3.2. I have been running many tests to validate 3.2 since I was running 3.1.4 before the upgrade.

One of my tests was to fly and tune with a front mounted gopro. When I attempted that the copter would randomly move in horizontal directions at a very rapid pace in loiter mode. I was able to save it each time by quickly switching to stabilize mode. It seemed to only happen when the gopro was in record mode so I decided to do some bench testing to verify. This is how I did it.

1) take the props off the Iris

2) place the copter outdoors with a clear view for optimal GPS signal

3) Start up Mission Planner and zoom in on the map location so that you can watch the signal float meaning that once you have a good hdop you will see the unfiltered GPS location moving around slightly. With an HDOP less than 2 it shows to be floating around by about 2 to 4 meters.

4) Attach the gopro to the front and start recording.

when I perform this test after the recording gopro is attached I see the position of the GPS in Mission Planner suddenly shift by 20 to 100 meters. It gets pretty radical. Turn off the gopro and the problem goes away. The same exact test performed with the gopro on the gimbal yields no negative results. I performed each test at least 3 times for verification. Bottom line is : I don't fly with a front mounted gopro until the problem is solved.

One difference between my Iris and a stock one is that I have my GPS on a mast. The mast is mounted to the top board and protrudes a couple inches through the top cover. My theory is that when the gopro is recording, it is interfering with the GPS. The compass stays solid and is never affected.

The GPS and compass cables were not properly twisted like they should be so I did that and seems to slightly alleviate the issue but sudden position shifts are still there. My problems could be only because of the mast but it's definitely a show stopper. If you don't have enough flight experience to switch to a non-GPS mode and save it you are gonna crash.

I doubt seriously this has anything to do with 3.2 but I used to fly with a front mounted gopro(seldom though) before the upgrade and never noticed anything like this.

I also arm the Iris during these tests sometime and simulate a takeoff in stab mode by increasing the throttle and lifting the Iris up onto a platform at 1.5 meters off the ground. It then thinks it's hovering at 1.5 meters. I just do this so that it's armed and flying to be more of a simulation for the test.

A front mounted gopro is very close to the GPS. Just something to think about. I have verified the problem 100% on mine. I am going to try some shielding next to see how much difference it makes.

I was having the same issues with my Iris, when I would switch to loiter or RTL, it would go crazy and try to commit suicide.  All 3 times I was able to flip to Stabilize and save it from crashing.  I tried calibrating the compass and accelerometer but it kept doing it.  I ended up taking apart the top housing and discovered one of the 2 leads from the Telem Radio was touching the GPS unit.  When I re-taped both leads away from the GPS, recalibrated the compass and accelerometer, the quadcopter now flies fine. 


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service