been having this issue for a while, however just upgraded to 3.2 and it is still there.

the readings after calibration are 190-115-680

Honestly, I have no idea what these numbers mean, except that the last number is the problem. 

My questions are:

1.  Can I simply ignore the compass check during the prearm check and fly the iris anyway? If so, what do I risk?

2.  What is causing it? I am not actually sure where the compass is on my upgraded IRIS.  Is it actually in the Pixhawk?  If it is, could moving the PixHawk (as recommended from 3dr) be causing the issue. I noticed after I moved the PIXHAWK it is now sitting right next to a medal screw that holds one of the arms.

Thanks.

Views: 6803

Replies to This Discussion

You must have some magnet interference coming from some where.  With 3.2 there are now two compasses so send us a log of your current setup to see what the other compass is at.

 

Is seems to run fine when i ignore it during the lrearm check. Any danger in doing this?

Compass health is important to the IRIS. It lets the vehicle know, basically, which direction is which.

If you were to open the top of the IRIS you would see the external antenna attached to the upper shell with the cable running to the PixHawk. Click here--> Compass location & install 

Be sure that the connections are correct from the antenna to the PixHawk.

If you were to disable/bypass the compass check, the IRIS would fly somewhat erratically/towel bowl because it has no "sense" of direction. North is North but if the IRIS thinks North is West or any other direction other then North it will cause issues in flight.

Click here --> Prearm safety check

Become familiar with Mission Planner and how to read/understand all the info in the program, it is extremely valuable and can help you solve most, if not all issues down the road.

 

Todd H

 

Hi, can you please advice me with arducopter 3.2 compass calibration?

I did compass calibration today and I was unable to get bellow recommended 250 value for second compass. I have two questions:

  1. Are values in table bellow useable?
  2. If not, how can I identify which compass is which? (e.g. Compass 1 is Pixhawk internal, compass 2 is external or is there some other logic?)

Thanks, Tomas

@Tomas, all fine. You won´t get the internal MAG (your Compass 2) below these offsets.

External MAG (your Compass 1) values are good.

Luckywise PX doesn´t use the the internal MAG. Good for nothing..If there would be a failover function (there is none @recent AC), IRIS would start TBE right away after switching over ;-)

Hi, thanks a lot .)

Btw. In meantime I get burned under pile of failure messages. Do you have any idea, if it is possible to test Pixhawk HW health?

http://ardupilot.com/forum/viewtopic.php?f=100&t=11164

i find same issue myself.., im not very versed on these forums but i was told to come ask a question here. i have an iris+  i just did latest 3.2.1 update so i did a compas calibration as well again i must have done it 10 times already . first off when done i click ok and some mag numbers come up  such as 9-120-11  these numbers are just off my head not realistic then i click ok and another set of 3 numbers pops up   one of those numbers is of about 543  now i understand that none of these numbers should be above 250 if im reading that right?  what makes this more confusing is i go update a apm 2.6 and do comp cal on that as well ( now this is a wing platform this time..... and i only get one set of mag  numbers  xx-xx-xx  . i dont know if thats a good thing or because its a 2.6 or because its a total different platform.  so confused on whats right and wrong. Screenshot%202015-02-21%2021.49.28.pngScreenshot%202015-02-21%2021.49.35.png  these are off my iris+ 

I'm not trying to hijack this post, but I think my issues are similar. 

Here are the settings after running compassmot: The bottom one is particularly scary. 

COMPASS_MOT_X,0.9829782
COMPASS_MOT_Y,0.6877003
COMPASS_MOT_Z,-2.037029
COMPASS_MOTCT,2
COMPASS_OFS_X,-123.0526
COMPASS_OFS_Y,-6.80735
COMPASS_OFS_Z,-20.00145
COMPASS_OFS2_X,121.0526
COMPASS_OFS2_Y,-208.9413
COMPASS_OFS2_Z,-410.3608

Mission Planner says the limit is 400. Am I learning that mag 2 settings are not important when the 3DR external GPS/compass is used?

I flew with similar numbers and it was ugly. got a "high mag failure" and accel failure, which I believe the latter is due the the former. Having said that, the compassmot runs never got higher than 35% and that was at about 80% throttle.

 

Hi,

I have the same issue. Is any solution around ? I noticed that only offset for Z axis is too high.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service