Hello,

I gave my IRIS a test today and noticed an annoying gimbal vibrations which reduce video quality. This happens even when motors are off. During flight vibrations go off for some time but then suddenly reappear.

Here is how it looks like: https://www.youtube.com/watch?v=p3JBmRg3hRo

What is a recommended steps to follow in order to diagnose and fix the problem.

Thank you,

Roman

Views: 1855

Replies to This Discussion

2 things you can try. First, go through the setup and ensure that the Tarot is level when Iris is level. And that the tilt motor is set correct. The reason is vibrating is is trying to find level 2. Go into the motor parameters and try to reduce or increase the motor parameters. I believe they are 60 for roll and 35 tilt. Factory. Yoy can play with those numbers in small amounts to see if that helps your problem

It might be power settings of tilt motor.

Check this pretty amazing video about tarot gimbal settings, https://www.youtube.com/watch?v=BwogodUlGAI

I had this issue when I got my IRIS back in February and had to go through the Gimbal setup to fix it.

So much for ready to fly.

 

That's unfortunately a known issues. Check out this post on how to fix it:

https://www.cloud-surfer.net/2014/07/11/get-rid-of-jello-with-the-t...

Hope that helps!

Hello,

I followed the instructions.

Before updating motor parameters gimbal was working.

Then I clicked a button to write motor parameters to flash. Now when I reconnect the battery, the gimbal displays blinking blue LED and do not stabilize the camera anymore. At the same time I can see correct camera position in gimbal update application, can connect to it and load/write all parameters.

Afterwards I attempted to follow your instructions here http://diydrones.com/forum/topics/tarot-2d-gimbal-ignores-controlle... but it have not fixed the problem.

Please advise what can be done.

Thank you,

Roman

You need to update both the motor and gimbal firmware as well, scroll to the bottom http://copter.ardupilot.com/wiki/common-tarot-gimbal/ It's 2 differnet processes in the software, and requires you to move the cable.

I updated the gimbal & motor firmware as well.

Any other ideas?

I had to change the Gimbal setting for Tilt "Total Gain" from 95 to 80 to get it to stop twitching.

I followed this video to get mine setup.

https://www.youtube.com/watch?v=UA73zBJrsmw&feature=player_deta...

 

After experimenting a bit more I figured out that reason of gimbal not working are wrong motor configuration.

Currently I configured following settings (loaded from gopro.bmc which comes with 1.5 firmware update, except for tilting motor power):

Polar Num: 14

Rolling motor power: 60

Tilting motor power: 25

Are these correct parameters or where can I find the default motor configuration?

My Tilt motor power is 35. Have not seen any doc with the default numbers on them.

It's the other configuration that seems to make the most difference.

 

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service