I have a Pixhawk 2.4.8 which is acting weird. When I simply plug into any USB port to power it up, it just beeps non stop.

I believe the firmware is corrupted.

Mission Planner will not connect to it so I can flash the firmware.

Is there any other program that I can use to flash the firmware? Also, what is the method?

Any help will be highly appreciated.
-------------------------------------------------------------------------------------------------------------------------

Update: Feb 11, 2018

So what I have learned that not all USB cable have all 4 wires wired by the manufacturer. They wire some USB cables where only voltage and ground wires are connected at both ends and it is to save a penny or two on mass production. Mostly the USB cables that come with cell phones as cell phone charging cables.

So if you have PixHawk connectivity issues with Mission planner or any other Ground Control Software, first check your USB cable and see if all 4 wires are wired.

Views: 448

Replies to This Discussion

Did this Pixhawk ever work properly?

Nope...Acting like this almost from day one I think. It was sitting on my shelf for some time.

Have you tried many many diffrent usb leads? I had to try 5 till I found one that stopped it from play games with my head. Also delete GS software and reinstall. Failing that try diffrent PC.
Otherwise you may have a really techy looking paper weight. I havent done it but you could try reset eprom theres a couple of videos on YT.

Hi,

How do you delete GS software? I did erase the SIM card log files. I have tried many USB cables. It's not a cable issue as other Pixhawk I have do work fine.

I have not seen any video on Pixhawk on youtube. I have seen few on APM though.

By the way why the new Mission planner software asks you if your board is Linux or not? Then asks Bebop2 or something and then asks you a series of questions which I have never seen before when you connect pixhawk to MP.

Gus said:

Have you tried many many diffrent usb leads? I had to try 5 till I found one that stopped it from play games with my head. Also delete GS software and reinstall. Failing that try diffrent PC.
Otherwise you may have a really techy looking paper weight. I havent done it but you could try reset eprom theres a couple of videos on YT.

GS software (Ground Station/Ground Control Station) is Mission Planner, qGround Control, APM Planner 2, etc.

Mission planner is asking all of those questions because it cannot detect the board.  You get the same behavior if you try to install firmware with nothing connected to a USB port.

I'm thinking the Pixhawk is toast... 

@Clifton & Gus - Apparently the main culprit was ....tah dah the USB cable!!!

So here is what I have learned. A number of USB cables that are made by cell phone companies do not wire all USB wires. means they wire only voltage and ground and its to just charge the phone....dah! cheap Bas....

After trying another high-quality USB cable, all problems went away. PixHawk is acting like a good boy.


Thanks everyone for your help!

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service