I am able to arm the Pixhawk both through telemetry and transmitter - the diode is solid green and pre arm check is successful. Unfortunately motors do not respond to throttle and do not spin at all.

Things I tried:

 - I have calibrated my RC and ensured that throttle is not reversed. Pixhawk is interpreting signals correctly.

- I have performed ESC calibration by connecting each ESC directly to the receiver PWM (I did not use pixhawk all at once calibration because for some reason it did not work for me). 

 - I have connected the motors directly to the receivers PWM and motor responded correctly.

 - I tried Motor Test feature in Mission Planner, but motors did not respond to any throttle level. 

- I noted that Pixhawk does not beep after safety button press  (button turns solid red tough as expected).

I have no idea how to proceed. Do you have any suggestions?

Views: 5031

Replies to This Discussion

I guess APM version 3.2.1. Motor test failure is enough to exclude RC and other high-leve problems; try however motor test with full throttle (no props). Try esc calibration from radio command.

Is there power on your output bus?

I think the clue is in 'pixhawk all in one calibration did not work for me' is a telling point.

My setup is using powered ESC's and all of the 5v leads are cut short. Depending on your power setup you may not have enough power for a decent signal to the ESC's

I tried  full throttle with props :) Fortunately did not work. I am not sure what you mean by esc calibration from radio command. I have calibrated them by connecting to the receivers throttle channel.

Lol, I think I know what's your problem :) signal pin on the pixhawk is on the bottom row, check if you plugged your ESCs correctly. One of the people I built a copter for did the same mistake during maintnance, took me 2hour drive trip to figure that one out :D 

Thank you. I am not using 5V power leads. I have only GPS and 3DR telemetry connected to pixhawk which is connected to the pixhawk supply module. I will test the output signal with oscilloscope tomorrow.

Thank you for your reply. I checked it and even tried both ways to make sure, did not work. Also motors don't beep while connected to signal output so there must be some kind of zero throttle signal there.

ESC should beep at power on even if there is no PWM.  Are you sure they're getting power?

ESC beeps when there is no PWM but does not beep when there is a signal. It does not beep when I connect it to Pixhawk signal output so it means it must be getting some kind of signal from pixhawk. It beeps though when I disconnect it from Pixhawks PWM output. 

Two things to check.  #1: Have you provided power to the servo rail?  I believe one of the esc's needs to have the 5v output or a bec connected to the servo rail.  Read the wicki section on power options.

#2: have you checked that your radio has the throttle on ch 3?  This is not alwase the default, My Frysky transmitter needed me to change this in the transmitter setup.  Made me crazy when I could not do the ESC calibration with the radio!

Thank you. #1 Did not provide power to the servo rail. Changed it but still does not work.

 #2 Yes it is on ch3. 

Hi Tomek, since you have almost checked all the possible causes, my wild guess is to increase the capacity of each ESC. Say, from 30A to 40A (or 50 A). Hope it helps.

1) Does all of your ESCs have a built in BEC? If they do, make sure to disconnect the positive wire and only leave the signal and ground wires connected. You must only have one BEC connected the output rail at all times.

2) Have you checked the log files, for any warnings or error messages?

3) Make sure all motor wires are soldered.

4) Check all the connectors to/from the FC and make sure, the polarity is not reversed.

5) I don't think, getting a high rated ESC will make much of a different. In terms of getting the motors to spin, unless the ESC are faulty which is rare but could happen.

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service