Hello,
I’m going to setup the Pixhawk now, but I continue to receive errors of "Bad Accel Health" or “inconsistent compass”. I'm doing the setup indoor.
I already updated the Firmware (with Craft and Theory build for the telemetry cable, but the issue was the same before this flashing), and I also already re-calibrated the accels, but the issue is still present.
Do you have any idea about what could be the problem? Could it be a hardware problem?
Thanks.

Views: 1633

Replies to This Discussion

Hi

Its probably just because you are in doors, take it outside and all will be well once its got a proper lock.

Paul

Thanks Paul. I will try it as soon as it stops raining.

There are many things I'm going to assume you have checked out.  Such as keeping metal objects (and your cell phone) away from compass and the Pixhawk, along with location and orientation of the GPS/compass puck, double check you have the GPS/compass connectors in the correct ports, etc, etc.    Are you getting "error compass variance....bad AHRS" along with the "bad accel health" and/or "inconsistent compass"??  If so, there's plenty to read up on in DIY Dones and Github.com.  But, before going down those rabbit holes......let's try "kiss" first.....as I wish I had before purchasing 3 Pixhawks and spending a month's worth of time.  What I ended up doing is repeating those 2 calibrations, accel and compass calibration ignoring all the audibles.  On Mission Planner screen do you get "calibration successful"?  Repeat those two calibrations until the audibles go away.  I eliminated all unnecessary items and started with the very basics connected to the Pixhawk on a block of wood.  Just the arming switch, buzzer and compass/GPS puck and provided power through the USB.  But even then, I was getting the error audibles.....on three brand new Pixhawks!!!  Ignore the audibles and push your way through the calibrations.  Granted, I would get the "radio calibration" warnings until I connected the receiver.  Then I repeated the compass and accel calibrations.....4 pr 5 times until things got "quiet"......no more screaming (from me) and no more, "error compass variance.....bad AHRS".  I have follwed through with the rest of the "build" and calibrations, and have flown her without issues using telemetry radios with Droidplanner and Tower apps (which have audible warnings) on a ground station to "monitor" systems.    So far, so good.  Hope this helps. 

Thanks Martin,

I will double check again everything, despite I'm sure the wiring is OK. The strange thing is that the Mission Planner reports the calibration is successful, the system can continue to be setup (I'm doing the setup of Taranis, lights strobes, Connex, failsafe lading gear, simple mode switch etc.) so let's see...

"The strange thing is that the Mission Planner reports the calibration is successful".

Yes, that's right, and that's why I suggest ignoring the audibles and continue forward with working through the list of calibrations.  That's what I DIDN"T do for so long.  I just felt stuck!!  I spent hours on the phone with 3D Robotics and even had them convinced it was a (new) out-of-box "defective" Pixhawk.  Yes, they sent me a new one (for free) before I had even returned the "bad" one.  But, same problem with the replacement one they sent me.  I thought I was creating the problem....damaging the Pixhawk.... by using clone components such as a power module for 6s batteries and the Ublox M8N GPS/compass puck.  So I went back to the very basics....all 3DR components.....connecting one at a time.  But when I saw I still had the same problem....now on my 3rd brand new Pixhawk.....and I noticed on MP, "calibration successful"....is when I started to ignore the audibles and just keep going.

what firmware version are you running ? How cold is outside and how far is the buzzer from the pixhawk. These are important questions to this issue. 

I setup 3 Pixhawk's indoor. All three were working great but eventually one started receiving the same message as yours. Turned out to be a hardware issue. The only real way to determine that is by a process of elimination and it sounds like you already did that.

FW APM:Copter V3.3.3 (31b4e166)

The buzzer is mounted underneath the upper part of the central chassis, about 14 cm. (5.5 inches) from the center of the Pixhawk.

Thats enough distance.

Two things i would try ALL you guys here who have this issue.

1. Turn off one of the IMUs and use one then see if the issue persists with 1 IMU or with 2 only. Also that way you eliminate which IMU is causing this.

2. Short the connector that plugs into the battery (Obviously with battery not connected !) for 10 sec. See if that resolves the issue so you can arm.  

Also you can try to fly with one IMU disabled and examine logs for performance difference. 

If you skip arming checks with this error and you fly in stabilize in a safe environment i would compare the logs between IMUs. Any variance. 

"what firmware version are you running ? How cold is outside and how far is the buzzer from the pixhawk. These are important questions to this issue."

I'd have to check to confirm.....but 3.3.3 sounds right. (If you want a definitive answer on this one, let me know) 

My buzzer location.  Hmm.  Hadn't really thought of that.  It's 5 inches from the center of Pixhawk and 11 inches from GPS/compass puck. 

Not sure if the temperature is an issue since I'm indoors for all the "configuring".  I do believe strongly in placing the rotorcraft outside, without the battery, to acclimate to ambient temperature and keep the battery warm, indoors, until I'm ready to boot everything up.  It can get pretty cold in Rochester, NY.

temp is a huge factor with the LSM IMU. 

Also how good are your offset values after compass calibration ? 

Try to arm indoor. Also shorting the connector that plugs to the battery has always worked for me but that is just a work around. 

There could be different factors causing this issue you guys need to work on isolating this. Whether its a HW issue with specific sensor or even a solder issue. {(which was not my case, but some guys have reported that it was a know issue on a batch of pixhawks)

@ MArtin your problem sounds like temp related since you leave the pixhawk outside before you fly it can affect the IMU to the point where it wont arm. Try to short the connector, or try to arm indoors with pixhawk being indoors for more than 10 min to warm up. If that works then bleeding the circuit by shorting will always work. That has been my workaround. To completely fix this issue see this post.

http://diydrones.com/forum/topics/solution-proposal-for-pixhawk-imu...

You guys need to research more. 

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service