Pixhawk RC Not Active Please Help, Won't Recognize RC Signal, Motor Spins Connected Direct to X8R

Hello again,

As I've yet to get much a response on previous post regarding a pixhawk which has the error code "Radio control not active", however it is most certainly active. as I can connect a motor to the 3 pin slot on my X8R and can sing the motor effectively.

Not to sound negative, but I'm really at my wits end with this pixhawk and its trouble some lack of response for an rc signal. I have this particular pixhawk in my X8 I require for mapping in the near future and it simply refuses to recognize an rc signal.  I have tested my frsky ppm encoder with no avail n'or will my 3dr ppm encoder. It did work previous to this with both the frsky sbus-ppm encoder as well as the 3dr ppm encoder.

I travelled with the auto pilot and upon attempting flight back in December after flashing the latest firmware at the time, it then would no longer recognize a signal? Its kinda disappointing considering my other pixhawks have worked perfectly out of box with the same exact setup without the need for any encoders but simply direct from sbus. 

I would hate to have it just sit on a shelf after the amount that Ive invested into getting it to work (ppm encoders, plus cost of all electronics such as gps ect...) and it hasn't ever worked properly. 

If any one would have advice on how to maybe test what may be occurring that would cause the pixhawk not to pick up a signal would be very very much appreciated, or perhaps anyone who may know how to trouble shoot the autopilot themselves (maybe an individuals in the toronto area?), as I require this particular drone in order to complete my research and would not want to spend to much more.

Thanks in advance for any advice, suggestions or feedback it is very appreciated!

Craig P. 

Views: 3985

Replies to This Discussion

Are you plugged into sbus on the x8r and rc on pixhawk?

Hi Paul thanks for your response,

I am connect from the X8R sbus to the pixhawk RC, 

I have the exact same setup on my Y6b, and everything recognizes no problem,

This pixhawk since I bought it has refused to accept direct sbus from an X8R, and when I originally contacted 3DR several times and they claimed they couldn't confirm if it should work so I was sold the encoder and it did after months of continuously re syncing in any way possible and implementing a 3dr ppm encoder it work (june 2014), so after some time I decided to attempt to switch out the ppm encoder for a frisky sbus to ppm encoder and it worked also without requiring any resyncing ect...Then when travelling home for Christmas break and opening APM planner i received a notification to updated firmware so I did and ever since it refuse to work, forcing me to buy a whole new autopilot as it was by then to late to contact 3dr once again and attempt to have it replaced.

I believe its one of the first production batches as it has a PX4 1GB Autopilot SD card and from my understanding they were faulty and my new autopilot has a different brand (more speed I believe but could be wrong).

So I'm not sure how to check this as directly connect a esc/motor to the 3 pin slot on the X8R I can control the motor with throttle no problem? And if it works on my Y6B setup which is identical, why not for the X8? I just wish there was a was to test what it happening like maybe with a multi meter opening up the autopilot casing to see if it a hardware issue within the pixhawk?

Thanks again,

Craig P.

 

so you have the xr8 s-bus plug into s-bus on the pixhawk ?

Hi Fred, 

I actually have the X8R sbus to pixhawk "RC" as it should be and how it works on my Y6b. I've tried to implement both the Frisky sbus to ppm encoder as well as a 3dr ppm encoder and neither work at the moment, although both did before...its almost as if the firmware update I did back in december fried the pixhawk which doesn't make much sense cause I can't see how that could be so?

Craig P.

Hi Graig,
Is the X8R receiver in the correct mode to send the S-BUS signal?
For a Futaba receiver you need to put the receiver in a specific mode to be able to send s-bus signal out, otherwise it will be an PWM signal.

And I guess you power the receiver from the PixHawk using the power module ?
And you are sure, you do have connection over all wires ( could be missing the ground between both, if you power the receiver from another power source?

Just a few thoughts...
Erik

Hi Erik, thanks for the response,

Everything worked prior to updating firmware back in December (2014), but only with either a ppm encoder or sbus to ppm converter. I have another pixhawk and it works with the same exact setup but does not require any encoders or converters. 

I will double check again, but I have the same exact setup running my Y6 (I'm actually simply swapping out XJT modules, since I have 2 XJT modules and 2 X8Rs, so XJT-X8R Y6 and XJT-X8R X8).

Issue is the pixhawk on the X8 does not recognize a signal? I would really like to know how I can physically or through software test to see if there is a hardware issue in the pixhawk (something wasnt soldered correctly or anything really) or if there is a diagnostics i can run within APM Planner (I use mac) in order to determine that may the x8r is sending the wrong pulse latency or something of that nature?

I am powering the X8r of the pixhawk and I'm powering the pixhawk off the power module.

It did work before without altering anything, I simply drove home for the holidays, and it asked if i wanted to update firmware so I did then now it refuses to work again.

So perhaps this pixhawk is faulty and may be sensitive to certain firmware versions? I'm at a loss at this point and beginning to think I may never find a solution.

I really wish they would offer better trouble shooting guides, or at the very least some minimal form of actual hardware support, as I have yet to find any reason or solution besides to recheck my connections, when the same exact connection worked prior to firmware updating, and I would assume plugging in a usb cable to update the pixhawk shouldn't cause connections to become loose considering the amount of force that is applied during its normal functions.

Thanks again,

Craig P.

Hi Graig,

By my knowledge there isn't anything like troubleshooting software. On the other hand I can't believe that a firmware update can brake the S-BUS. Then it must be a hardware issue, possible in the connector to the PIxhawk PCB. Have a look if the soldering is clean there.
You may have a situation of an cold solder connection, which may be fixed by re soldering the connector at the side of the S-BUS connector.

Could be pure coincidence that it happened around the same time you upgraded the firmware...

Good luck

Erik

Thanks Eric,

The reason I think that its not only a hardware issue is that the pixhawk did the same thing prior to the addition of either a encoder or a converter, which should not be required as its not with my other pixhawk. And even then it took several re sync attempts even to even get it going like that with an encoder or converter. The reason I say firmware is cause I literal travelled 4 hours with it in the passenger seat and it did not move once, then brought it in a house programmed it and then tried to fly it, so I didn't do any real movement since it last worked.

I have in fact opened then pixhawk up and found the connections to be great with regards to the pins connecting to the board itself, however I could have been mistaken. 

I mentioned a potential hardware test as I'm wondering if maybe the processor within the pixhawk is perhaps functioning at half its potential capabilities thus firmware updates are to much for the broken pixhawk to handle or perhaps there is another part to the board which is preventing proper functionality, incompatible sd card (to low speeds) and other potential issues (faulty resistors ect..). It would for sure be beneficial to incorporate a method to run a diagnostic to make sure the chipsets are still running at optimal function and other functions such as sd card.

I'd hate to toss the thing (pixhawk) in the trash and look for a new one but I fear it may come down to that, since I seem to be waisting time I don't have, and not getting much productivity out it. 

I wish that we had individuals who fixed pixhawks here in Canada, as I would definitely be willing to pay for a repair if possible.

Thanks again,

Craig P.

 

"Then when travelling home for Christmas break and opening APM planner i received a notification to updated firmware so I did and ever since it refuse to work, forcing me to buy a whole new autopilot as it was by then to late to contact 3dr once again and attempt to have it replaced."

Which Firmware version ?

Have you tried rolling back the APM Copter version to the one that worked before?

Hi JoeBob, thanks for the reply,

to be honest I'm not positive which firmware version it was, but I do know around the time it was in use (may-june 2014), and I did try to look for this version in the archives but I'm not sure which is which (amp or pixhawk, stable or beta)? So I didn't get to far, although I did try two of them with no luck. 

I know my X8R and XJT are synced correctly and functioning because I get solid green lights on both and when connecting an esc directly into the 3 channel of the X8R the throttle controls the esc, so it would seem to be on the pixhawk end of things (not recognizing type signal, or just won't detect the signal at all?).

When it worked it was in my Y6 but once it stopped working I picked up a secondary pixhawk and stuck the new pixhawk in my Y6 and this one (old one) in my X8 but I don't think that really has much to do with it as its simply a frame type. 

Thanks again,

Craig P.

Connect to Mission planner.  Find out your version of ArduCopter.  ( It's under Flight Data / Messages)

Install an ArduPlane software, which blanks your Copter firmware, then load a previous version of ArduCopter. (Initial Setup / Install FIrmware / 'Pick previous firmware' in the bottom right corner)

Keep your props on top,

JoeBob

Thanks JoeBob, I'll give that a try.

I normally format the sd card itself, but I have flashed back to arduplane then to arducopter before. The original sd card (px4 autopilot 1gb) that came with it I had read that they weren't as good as they could be but I can't be certain, but perhaps that could causing the pixhawk to function improperly?

Do you know if its the same in APM Planner as it is in mission planner? I've never actually used mission planner itself, only APM Planner, but I know they do have some differences between them (map caching etc...).

Craig P.

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service