Setting throttle failsafe with EZUHF and Taranis Please help.

Hi everybody.

I'm desperate and can someone please help. I'm trying to set the Failsafe on my Pixhawk so that when my Taranis loses the connection or gets turned off the RTL jumps in. I'm using a EZUHF RX. I've done just about everything I can think of to get it to work but no luck. I'm worried the answere is obvious but my brain now is mush and I probably can't see the wood for the trees.

As it stands now, my min throttle is 1117, my max is 1873. My FS Pwm is 1049 and when I turn off the Taranis the Initial setup / Failsafe / Channel 3 (throttle channel) reads 993. At this stage the RTL or Land should jump in but I get no reaction at all. It just stays in Stabilise mode.

Again, please help. I don't have much hair left.

Views: 2060

Replies to This Discussion

The key is to have the RX send 'no pulses' when there is no TX signal. That's something that has to be set up with the RX. I don't know if that receiver can do that or not you'll have to read the manual. Usually they can be set in on of two fashions. One is to set all channels to a preset state defined by you if TX is lost. That sound good but has issues I won't try to explain for fear I only confuse the issue. ha The other is to send no pulses. In other words to set channel 3 to zero pwm which then the pixhawk see's as below your FS setting and then goes in to FS.

Looks like that RX doesn't do no pulses.

Here's what might work. Do the set up as explained except use your throttle trim on your TX to go as low as it can go and set the RX FS to that. So long as that is lower than your FS pwm you have set up in mission planner it 'should' set the controller to RTL or Land as you selected. I'd test my great idea about 3 feet off the ground a long ways away from obstacles. One thing to note is that when the Pixhawk regains TX it will stay in FS until you toggle your mode switch. This is a good thing because if it went into RTL then back into auto out of sight it could continue going back and forth without you knowing until the battery dies. 

Richard, thank you so much for replying so quickly.

Now this is embarrassing, Last night I was up till about 1 am trying all sorts of things to make this work, and finally went to bed in disgust after failing yet again. This morning I got straight on to diydrones to post this message. Then I looked at a few more forums to see if I could find out any more on the subject.Then switched on the TX and QAV540 and tried it again to see if I could see anything else that I didn't pick up on and guess what? It worked. I didn't change anything or do anything different. But it worked. So anyway, thank you for the time you made to help me, and I do appreciate the effort.

Great!!! I know what you mean about something like this driving you nuts!! lol Glad it worked out!

Hey btw Phil what kind of range do you get with that? You installed a UHF module in the back of your Taranis right? Do you need a separate FPV transmitter on the craft too? Started reading the pdf manual. cool stuff. 

Hi Richard

The EZUHF and FPV are two totally different systems. If you want to use FPV (first person view) then yes you would need a FPV camera and a VTX like the TS58500 with a clover antenna. The EZUHF is strictly for the control of the Multi Rotor. The best range that I know of is 80 KMs, but that was on a plane. The range for a VTX if using FPV is only about 1 - 3 KMs. I'm using the EZUHF for reliability of connection  not distance, as the lower frequency penetrates objects far better than normal 2.5G.

Yes, I have the module in the back of the Taranis.

So the set up is to sort of make sure your control of the craft probably exceeds the fpv range not the other way around? The throttle fs sure is a nice ace in the hole if all else fails! 

Thx for the imfo

Yes exactly. I want the control of the UAV to be the last possible thing to fail. I intend to go down fighting if I have to. And yes, if all else fails, I'll flip it into RTL or it will do it itself now. Of course I still have the geofence up my sleeve if I need it.

I have a issue with this also. But my problem is. When my throttle is in its lowest posistion its 991ppm. When I turn it off or go full trim down I cant get it to go any lower. So I can setup a throttle failsafe? Any ideas? I have temporaily been using a get around where I set my failsafe at the throttle low posistion. Then add and keep a little trim up so that it doesnt kick into failsafe everytime I pull back on the throttle. But the only problem is this messes up all of my center stick settings and all. 

Hi Justin.

Happy that you can't achieve it with full trim.. Imagine trimming in flight?

- Sub trim in your radio will normally let you go lower and servo extend as well. 

- When you are as low as possible store this value in your receiver, as failsafe, and then power the receiver down.

- Bring back your Transmitter throttle value to a normal value (you mentioned 991 uS).

That should work.



Throttle FS needs to be set up with your RX. You need to look up the directions for your RX and see if it has the option to do 'no pulses' on lost TX. Some do some don't. What this does is send zero ppm if it losses signal which then the pixhawk or APM see's that triggers the throttle FS in the pixhawk or APM if you have this turned on. This set up is better in many ways to the RX simply going to set default channel outputs [ some RX only have this option ] as there can be several unintended problems with this way of going about it. 
The bottom of my throttle is 991. Won't go any lower. With sub trim or throttle time. The only thing I can do is go up. My range is 991-1996. What I ended up doing, running a 9xr pro, ezuhf, and openg TX BTW, is going into offsets and raising all of my channels to 1000ppm. So my range is 1000-1996. Then I did a radio recalibration with my pixhawk and my center stick settings are all setup now. Is this what people usually have to do?


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service