Setting throttle failsafe with EZUHF and Taranis Please help.

Hi everybody.

I'm desperate and can someone please help. I'm trying to set the Failsafe on my Pixhawk so that when my Taranis loses the connection or gets turned off the RTL jumps in. I'm using a EZUHF RX. I've done just about everything I can think of to get it to work but no luck. I'm worried the answere is obvious but my brain now is mush and I probably can't see the wood for the trees.

As it stands now, my min throttle is 1117, my max is 1873. My FS Pwm is 1049 and when I turn off the Taranis the Initial setup / Failsafe / Channel 3 (throttle channel) reads 993. At this stage the RTL or Land should jump in but I get no reaction at all. It just stays in Stabilise mode.

Again, please help. I don't have much hair left.

Views: 2051

Replies to This Discussion

I looked at the manual and that ezuhf can't / doesn't do no pulse aka zero ppm. I am wondering however if you simply shut off your TX then reprogramed the ezuhf to use those channel positions [which would be zero ppm because it's off] so then that would get the result you want... a really low ppm? 

Otherwise I get where your going I think. So you raise your radio's lowest ppm do the pixhawk radio calibration then got back to the higher setting but... I don't think it would fly right unless you re-centeted all your sticks centers?? gees man I have a Taranis yours is similar that sounds like about 1.5 million menu button presses!! LOL there must be a better way. Just for the heck of it try resetting the FS like I mentioned above [ with your TX off ] and least that's easy to try I would think. Then again it might not work if it doesn't see any TX signal. 

You can't set a faisafe without the TX being on. The min ppm is 991. Across all channels. Never seen anything lower. On my external EZuhf or my JR Module EZuhf. Just the way it is. I set the fail safe first, then adjusted all the channels to 1000. Then i did a radio calibration so my center on the sticks are working correctly now. And I set it up on my laptop so I didn't have to press any buttons. Just a few mouse clicks. ;-)

Yea TX off won't work... bummer. 

Yea I really should I install that companion software!!! 

I'm tearing my hair out here. I also have a Taranis with OpenTX 2.1 and EZUHF. I can't get the pwm values below 999! I've tried extended trim, offset, everything I can think of.

How can I tell the receiver to send out a lower PWM on Throttle?

Look in the documentation for your RX and look for a way for it to 'don't send pulse' or 'send no pulse' then you turn throttle FS on in MP to a number 10 or so below what your lowest throttle setting is when your TX is on. Is this what you mean? Some RX's don't have that option. Maybe your EZUHF doesn't do that. 

Thanks for replying. No such option on EzUHF though. I've set my throttle trigger to 1002 uf, set failsafe on trasmitter and used throttle trim to take the throttle higher, to 1020. This works but it will mean the plane will failsafe if I ever touch the throttle trim again..

Well as long as you do the calibration for all your channels in MP with the throttle trim up a bit then I guess that should work just fine. You shouldn't need to trim it lower right? As long as bringing the throttle stick all the way down shuts off the motors you would never need to touch the trim right? I think that's what Justin was getting at above. 

Yes, just odd that I can't trim the throttle below 1000 uf. I just feel uneasy doing it this way.

Let me know how it works out it would be good to post here for reference. Thanks

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service