I have been trying to get my digital airspeed sensor to work and while doing some research I came across this post that claims that the "I2C2" port on the PX2.1 does not work:

http://discuss.ardupilot.org/t/pixhawk-2-1-with-maxbotic-i2cxl-maxs...

The proposed solution is to connect the device on I2C1 (on the GPS1 port). Has anyone else encountered this issue ?

Views: 941

Replies to This Discussion

Yes, I was just trying to setup one of the new MS5525 Airspeed sensors on I2C - 2 and it won't work. I'll have to make up a special cable to try it on I2C -1. Someone suggested making a cable to use the I2C bus from GPS-2 connector

The same article I linked suggest that using the I2C from GPS port2 will not work either...

(...)

Thank for this, i have this issue on my pixhawk2 and i can't use lidar on the second I2C port.

Is the I2C port of the second GPS is the same as the first GPS ?
So perhaps we can use it without cut the first GPS cable ?

i need to test...

(...)  tested, that doesn't work..."

Simon, try changing the I2C bus from 1 to 0 in the parameter config file, I just did that and the airspeed seems to be working

Edit: But Altitude isn't

cant find the parameter: I'm searching in the "full parameter list" ..  what is the mavelink name for the parameter you are talking about or do I need to change this through some other mechanism?

DougB said:

Simon, try changing the I2C bus from 1 to 0 in the parameter config file, I just did that and the airspeed seems to be working

Its ARSPD_BUS

It's not in the list ??!!??

1). I just confirmed that GPS2 uses I2C-2

2). I'm running arduplane 3.8.0rc5

1 - I suppose that means that the "I2C2" port on the carrier board is in fact I2C3 ?

2 - I'm on 3.7.1..   will update  oups..

DougB said:

1). I just confirmed that GPS2 uses I2C-2

2). I'm running arduplane 3.8.0rc5

I've updated the FW to 3.8.0 beta5 and I can now see the ARSPD_BUS parameter but The "Enable" option is blacked out for airspeed whatever bus number I put.. also, The current sensor does not work properly with this version.. It seems like the current is multiplied by +- 1000.

I was just looking at the Libraries and the airspeed library has the driver for the MS5525 airspeed sensor but the Baro library doesn't have a driver for the MS5525. It's been a very long time since I was working with the development but I think that is why I'm seeing airspeed but no altitude.

I haven't looked at voltage and current since I just upgraded yesterday in hopes that the airspeed sensor would work

I'm using the eagletree v3 sensor BTW

I now have it working. I was under the incorrect assumption that the aispeed sensor static port was also providing barometric altitude data to the Pixhawk. But, the instructions say to set the ARSPD_BUS = 1, I can only make it work on ARSPB_BUS = 0 rather than what the instructions say. This is on a Pixhawk 2.1

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service