Information

PIXHAWK

Problems, Hints, experience, comments on the new PIXHAWK

Members: 1123
Latest Activity: Sep 6

Discussion Forum

Python Code for Servo Motor Switch (PWM) on Pixhawk

Started by Govinda Baweja. Last reply by Bonnie Aug 12. 4 Replies

Hello friends,I want to run a python scrip on onboard companion computer to trigger the servo motor switch which is connected to pixhawk.Any ideas on how can I do it?Thanx.Continue

Tags: motor, servo, python, pixhawk

Drone project

Started by Ohad Azulay. Last reply by Annabe763 Jun 28. 3 Replies

HI all, We are a group of 3 students for Mechatronic Engineering.We are now working on a final year project.our project is an amphibious drone that will be able to fly and also to enter the water and…Continue

SB_0000002 Critical service bulletin for Cubes Purchased between January 2019 to present. DO NOT FLY

Started by iSkyMaster. Last reply by Philip Apr 27. 6 Replies

It has come to our attention, that there is an anomaly with sensor readings on some recent cubes. This notification will be modified multiple times a day!!! Please check often.…Continue

Tutorial: Build Autonomous Drone - Using SLAM In GPS Denied Environment For Position Estimation

Started by Nina Rong Apr 15. 0 Replies

I have been posting a series of tutorials on how to build an autonomous drone. This time I am writing about…Continue

Tags: tutorial

Comment Wall

Comment

You need to be a member of PIXHAWK to add comments!

Comment by Larry A Amati on February 8, 2015 at 6:31am

I just want to let you guys know,I purchased my Pixhawk from 3Drrobotics because

of the excellent customer service and support.You will not get that from the chinese

clones.Just sayin.

Comment by Larry A Amati on February 8, 2015 at 6:27am

Im using Pixhawk via Sbus on my aeroquad drone.Works flawlessly with the PID's

in stock settings.Also I'm using a taranis radio in D16 mode.

Comment by Tommy Larsen on November 27, 2014 at 12:28am

Maybe you should create a sub-thread for this discussion?

Comment by Tim Wilkin on November 26, 2014 at 3:31pm

Did you try forcing a firmware upload/update onto the PX4IO? For the FMU/IO stack this was achieved by holding down the arming button while powering up and keep holding it through several sequences of musical chimes. If when they integrated the IO and FMU boards into one they kept the software framework in the HAL, this may still work to reset the IO portion of the board. I'm sure one of the HAL devs could clarify this though.


Moderator
Comment by David Anders on November 26, 2014 at 5:01am

Thanks Tim, a few cards were tried but no luck. There was an error message on the card that stated PX4IO board not found. So I'm suspecting a hardware failure but would like to know the cause.

Comment by Tim Wilkin on November 26, 2014 at 3:03am

Two things to try if you believe it to be an SD card fault: 1) format the SD card in a PC first (this will usually get rid of any corruptions in the file table); and/or 2) jiggle it after inserting and make sure its bedded down against the pins. I know this sounds stupid, but I had this problem last week. I tried for 3 straight hours to get two different SD cards to work and then I finally got to the point of checking if it was seating properly... and found that even when it's all the way in, it doesn't actually make good contact between the pins.


Moderator
Comment by David Anders on November 26, 2014 at 2:28am

Thanks Wy, have tried multiple SD cards but to no avail. \:

Comment by WY Chen on November 26, 2014 at 1:58am
Have you checked the SD card? That may be caused by corrupted file system on the SD card. I ran into similar and fixed it by ejecting and inserting the SD card again, last time.

HTH

Moderator
Comment by David Anders on November 26, 2014 at 12:33am

Hey all,

Has anyone come across the following reaction when powering up a Pixhawk?

Essentially, a solid red main LED and music.  It's not in the standard LED characteristics.

20141126_165840_001.mp4

Edit: This is a brand new Pixhawk, was tested and was working.  Running Rover 2.47.  Also, attached file is not corrupt, but will need to be played in something like VLC.

Edit: There is also a repetitive ticking sound coming from the buzzer.

Thanks,

David.

Comment by Klaus Heinrich on July 4, 2014 at 1:32am

successful test flight with the new KX 8 and a Pixhawk control, camera Sony HDR 810 and much Zoooom :)  first flight video Big KX 8

Football sunny greetings from Germany, ciao Klaus

 

Members (1123)

 
 
 

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service