Information

PIXHAWK

Problems, Hints, experience, comments on the new PIXHAWK

Members: 1102
Latest Activity: Dec 1

Discussion Forum

Python Code for Servo Motor Switch (PWM) on Pixhawk

Started by Govinda Baweja. Last reply by Govinda Baweja Sep 20. 2 Replies

Hello friends,I want to run a python scrip on onboard companion computer to trigger the servo motor switch which is connected to pixhawk.Any ideas on how can I do it?Thanx.Continue

Tags: motor, servo, python, pixhawk

LiDAR for Pixhawk "or" for dummies?

Started by iSkyMaster. Last reply by iSkyMaster Sep 19. 36 Replies

Last Updated: Sep 19th, 2018 - I will be updating my original post as people correct me and I learn new things. Well, I am next off to monkey around with LIDAR technology and interestingly there is…Continue

PIXHAWK armed but motors do not spin

Started by Tomek Kowal. Last reply by Subhanjan Saha Sep 17. 17 Replies

I am able to arm the Pixhawk both through telemetry and transmitter - the diode is solid green and pre arm check is successful. Unfortunately motors do not respond to throttle and do not spin at…Continue

Tags: armed, spin, esc, motors, pixhawk

Pixhawk servo has no response in FBWA

Started by Stanley Anak Suab Sep 14. 0 Replies

Just recently I built a FX61 powered by a Pixhawk. I have built many but this time I just couldnt understand why the servo not functioning/moving as it should be in FBWA mode only the motor spins…Continue

Comment Wall

Comment

You need to be a member of PIXHAWK to add comments!

Comment by WY Chen on November 26, 2014 at 1:58am
Have you checked the SD card? That may be caused by corrupted file system on the SD card. I ran into similar and fixed it by ejecting and inserting the SD card again, last time.

HTH

Moderator
Comment by David Anders on November 26, 2014 at 12:33am

Hey all,

Has anyone come across the following reaction when powering up a Pixhawk?

Essentially, a solid red main LED and music.  It's not in the standard LED characteristics.

20141126_165840_001.mp4

Edit: This is a brand new Pixhawk, was tested and was working.  Running Rover 2.47.  Also, attached file is not corrupt, but will need to be played in something like VLC.

Edit: There is also a repetitive ticking sound coming from the buzzer.

Thanks,

David.

Comment by Klaus Heinrich on July 4, 2014 at 1:32am

successful test flight with the new KX 8 and a Pixhawk control, camera Sony HDR 810 and much Zoooom :)  first flight video Big KX 8

Football sunny greetings from Germany, ciao Klaus

 

Members (1103)

 
 
 
Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service