I am testing and trying out UgCS 2.9 on my mac before i purchase a professional license. had 2.8 and it worked fine. when i installed the update now it will not work with either the 2.8 or 2.9 software anyone else using this software on mac computers? I included a screen shot with the error code ocationaly comes up as not finding local host

Views: 281

Attachments:

Replies to This Discussion

Hi Brucey,

It seems that after update there is some problem with UGCS Server. You could first try to manually start it by pointing Your mouse on UGCS Server item under Service manager and then clicking Start. Now if that was successful just click Retry in UGCS Client.

If that does not help, please find Your log file here: Macintosh HD/Users/MD Brucey/Library/Logs/UGCS/server/ucs.log

And please either send it with the problem description to support@ugcs.com or post it here.

Good luck! Artūrs

Same problem after 2.10 upgrade on OSx 10.12.2

The service manager fails during startup due to a fatal SQL error and therefore ugcs client cannot start.  I have opened a support ticket about this.

Log attached:

2016-12-22 10:49:55,711 INFO [main] com.ugcs.ucs.Server - Server startup...
2016-12-22 10:49:56,641 INFO [main] com.ugcs.ucs.Server - http proxies: [DIRECT]
2016-12-22 10:49:56,641 INFO [main] com.ugcs.ucs.Server - https proxies: [DIRECT]
2016-12-22 10:49:56,641 INFO [main] com.ugcs.ucs.Server - ftp proxies: [DIRECT]
2016-12-22 10:49:56,641 INFO [main] com.ugcs.ucs.Server - socket proxies: [DIRECT]
2016-12-22 10:49:56,654 INFO [main] com.ugcs.messaging.mina.MinaAcceptor - Initializing acceptor {max I/O threads: 1, max task threads: 1}
2016-12-22 10:49:56,736 INFO [main] com.ugcs.ucs.profiler.ProfilerServer - Profiler server started at 0.0.0.0/0.0.0.0:7075
2016-12-22 10:49:56,764 ERROR [main] com.j256.ormlite.db.SqliteDatabaseType - WARNING: you seem to not be using the Xerial SQLite driver. See ORMLite docs on SQLite: http://ormlite.com/docs/sqlite
2016-12-22 10:49:57,018 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Database version: 2.7.0 (requires update to version 2.10.1123)
2016-12-22 10:49:57,103 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Reading statements from [ZIP] 2.8.a.zip
2016-12-22 10:49:57,105 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Extracting archive entry 2.8.a.sql
2016-12-22 10:49:57,228 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Reading statements from [SQL] 2.8.b.sql
2016-12-22 10:49:57,230 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Reading statements from [SQL] 2.8.c.sql
2016-12-22 10:49:57,231 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Reading statements from [SQL] 2.8.d.sql
2016-12-22 10:49:57,232 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Applying 173 update statements (version 2.9.0)...
2016-12-22 10:49:57,256 ERROR [main] com.ugcs.ucs.repository.impl.OrmLiteStatementExecutor - SQL >>> INSERT OR REPLACE INTO CommandArgumentDefinition ("id", "order", "name", "description", "type", "mandatory", "unit", "defaultValue", "validationRegex", "command_id") VALUES ((SELECT "id" FROM CommandArgumentDefinition WHERE "name" = 'transponderMode' AND "command_id" = (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), 0, 'transponderMode', 'command.arg.transponderMode', 1, 0, 0, NULL, NULL, (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), ((SELECT "id" FROM CommandArgumentDefinition WHERE "name" = 'identState' AND "command_id" = (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), 1, 'identState', 'command.arg.identState', 1, 0, 0, NULL, NULL, (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), ((SELECT "id" FROM CommandArgumentDefinition WHERE "name" = 'squawkCode' AND "command_id" = (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), 2, 'squawkCode', 'command.arg.squawkCode', 1, 0, 0, NULL, NULL, (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating'))
2016-12-22 10:49:57,258 ERROR [main] com.ugcs.ucs.Bootstrap - Error
com.ugcs.ucs.service.UcsException: Database update failed
at com.ugcs.ucs.service.impl.SystemServiceImpl.updateDatabase(SystemServiceImpl.java:235)
at com.ugcs.ucs.Server.start(Server.java:95)
at com.ugcs.ucs.Bootstrap.mainImpl(Bootstrap.java:33)
at com.ugcs.ucs.Bootstrap.main(Bootstrap.java:14)
Caused by: java.lang.RuntimeException: java.sql.SQLException: [SQLITE_CONSTRAINT] Abort due to constraint violation (NOT NULL constraint failed: CommandArgumentDefinition.command_id)
at com.ugcs.ucs.repository.impl.OrmLiteStatementExecutor.executeTransactional(OrmLiteStatementExecutor.java:32)
at com.ugcs.ucs.repository.impl.OrmLiteStatementExecutor.executeTransactional(OrmLiteStatementExecutor.java:22)
at com.ugcs.ucs.service.impl.SystemServiceImpl.updateDatabase(SystemServiceImpl.java:227)
... 3 more
Caused by: java.sql.SQLException: [SQLITE_CONSTRAINT] Abort due to constraint violation (NOT NULL constraint failed: CommandArgumentDefinition.command_id)
at org.sqlite.core.DB.newSQLException(DB.java:890)
at org.sqlite.core.DB.newSQLException(DB.java:901)
at org.sqlite.core.DB.execute(DB.java:810)
at org.sqlite.jdbc3.JDBC3PreparedStatement.execute(JDBC3PreparedStatement.java:50)
at com.j256.ormlite.jdbc.JdbcCompiledStatement.runExecute(JdbcCompiledStatement.java:62)
at com.ugcs.ucs.repository.impl.SqlStatement.execute(SqlStatement.java:32)
at com.ugcs.ucs.repository.impl.OrmLiteStatementExecutor.executeTransactionalImpl(OrmLiteStatementExecutor.java:53)
at com.ugcs.ucs.repository.impl.OrmLiteStatementExecutor.executeTransactional(OrmLiteStatementExecutor.java:30)
... 5 more
2016-12-22 10:49:57,272 INFO [Thread-0] com.ugcs.ucs.Server - Server shutdown...
2016-12-22 10:49:57,287 INFO [Thread-0] com.ugcs.ucs.ThreadPools - Executor service created [threads=1]: elevation_cache_cleanup
2016-12-22 10:49:57,288 INFO [Thread-0] com.ugcs.ucs.ThreadPools - Executor service created [threads=1]: background_elevation_loading
2016-12-22 10:49:57,695 INFO [Thread-0] com.ugcs.messaging.mina.MinaConnector - Initializing connector {max I/O threads: 8, max task threads: 32}
2016-12-22 10:49:57,702 INFO [Thread-0] com.ugcs.messaging.mina.MinaConnector - Initializing connector {max I/O threads: 8, max task threads: 32}
2016-12-22 10:49:57,707 INFO [Thread-0] com.ugcs.ucs.Server - Shutting down asynchronous telemetry collectors.
2016-12-22 10:51:50,099 INFO [main] com.ugcs.ucs.Server - Server startup...
2016-12-22 10:51:50,824 INFO [main] com.ugcs.ucs.Server - http proxies: [DIRECT]
2016-12-22 10:51:50,825 INFO [main] com.ugcs.ucs.Server - https proxies: [DIRECT]
2016-12-22 10:51:50,825 INFO [main] com.ugcs.ucs.Server - ftp proxies: [DIRECT]
2016-12-22 10:51:50,825 INFO [main] com.ugcs.ucs.Server - socket proxies: [DIRECT]
2016-12-22 10:51:50,840 INFO [main] com.ugcs.messaging.mina.MinaAcceptor - Initializing acceptor {max I/O threads: 1, max task threads: 1}
2016-12-22 10:51:50,937 INFO [main] com.ugcs.ucs.profiler.ProfilerServer - Profiler server started at 0.0.0.0/0.0.0.0:7075
2016-12-22 10:51:50,971 ERROR [main] com.j256.ormlite.db.SqliteDatabaseType - WARNING: you seem to not be using the Xerial SQLite driver. See ORMLite docs on SQLite: http://ormlite.com/docs/sqlite
2016-12-22 10:51:51,269 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Database version: 2.7.0 (requires update to version 2.10.1123)
2016-12-22 10:51:51,352 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Reading statements from [ZIP] 2.8.a.zip
2016-12-22 10:51:51,353 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Extracting archive entry 2.8.a.sql
2016-12-22 10:51:51,479 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Reading statements from [SQL] 2.8.b.sql
2016-12-22 10:51:51,481 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Reading statements from [SQL] 2.8.c.sql
2016-12-22 10:51:51,482 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Reading statements from [SQL] 2.8.d.sql
2016-12-22 10:51:51,483 INFO [main] com.ugcs.ucs.service.impl.SystemServiceImpl - Applying 173 update statements (version 2.9.0)...
2016-12-22 10:51:51,508 ERROR [main] com.ugcs.ucs.repository.impl.OrmLiteStatementExecutor - SQL >>> INSERT OR REPLACE INTO CommandArgumentDefinition ("id", "order", "name", "description", "type", "mandatory", "unit", "defaultValue", "validationRegex", "command_id") VALUES ((SELECT "id" FROM CommandArgumentDefinition WHERE "name" = 'transponderMode' AND "command_id" = (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), 0, 'transponderMode', 'command.arg.transponderMode', 1, 0, 0, NULL, NULL, (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), ((SELECT "id" FROM CommandArgumentDefinition WHERE "name" = 'identState' AND "command_id" = (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), 1, 'identState', 'command.arg.identState', 1, 0, 0, NULL, NULL, (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), ((SELECT "id" FROM CommandArgumentDefinition WHERE "name" = 'squawkCode' AND "command_id" = (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating')), 2, 'squawkCode', 'command.arg.squawkCode', 1, 0, 0, NULL, NULL, (SELECT "id" FROM CommandDefinition WHERE "code" = 'AdsbOperating'))
2016-12-22 10:51:51,510 ERROR [main] com.ugcs.ucs.Bootstrap - Error
com.ugcs.ucs.service.UcsException: Database update failed

etc.... etc....

From the help desk (thanks Anton)

This is an upgrade from a previous version

>>please remove all ugcs version from Application folder, find with Finder all ugcs folders at your Home folder and remove >>them too. Then you need to make a fresh install of new 2.10 version.

The issue was the installer not cleaning out previous versions.  Might be worth updating the install docs & scripts.

 

Thank you I will probably have several questions as Progress I am In the process of setting up a simple custom control system using UGcS to streamline my professional operations using the free version for now. I will probably have tons of questions in the future such as setting up a Joystick making the UGCS actively update the RTH point Etc. But when i get ready for some of that i will be buying the proper professional portions and may just put in a request for a custom module done through support

Brucey,

Did You manage to solve the starting issue also by deleting all the previous version files and doing a clean install?

Yes I did. now i am working on hardware and software. May keep notes on this next phase and do a blog post of what i am doing.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service