Hi all. I am using a DJI Phantom 4 Pro (with the latest firmware update) and am having trouble connecting the P4P to several android devices that have UGCS for DJI installed on them. 

I have tried unsuccessfully connecting to a Lenovo TB-8504F  tablet (Android Version 7.1.1) and a Samsung Galaxy S9 (Android Version 9) following the steps outlined here: https://www.ugcs.com/files/manuals/mv.v.2.17/ugcs-for-dji-user-manu...


I have tried every USB connection type for both devices, to no avail. Has anyone had this problem before and been able to find a solution?


Jason Schilling

Natural Resources Biologist

Public Utility District No. 1 of Douglas County

Views: 106

Replies to This Discussion

Hi Jason

In case you haven't tried, have you used a USB 3.0 cable to connect your Android device to the DJI controller?



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service