I am trying to fly a mission on a Coal Surface mine using a DJI Inspire 1 Pro. The area I am trying to fly used to be a valley that they have converted into a Impoundment and fill area. The elevation change is roughly about 80 feet from the surface model in UGCS. I have added a new surface model and made sure the elevation Z order was reflecting the new surface model.


I did notice that when I turn the drone on while setting on the ground it reads an AGL of -20 feet. I selected my update takeoff point altitude and selected the button to read the elevation from the current surface model and it updated it everything looked correct my AGL was reading 0 ft.


However, as soon as I select upload mission to vehicle my Agl changed backed to -20 feet and gave me the error Altitude too high when trying to execute the mission. Like it ignored the update takeoff point altitude.

Any suggestion?

Views: 1024

Replies to This Discussion

Hi Michael, 

I think one of the problems here is that, every time you arm the drone it sends its current takeoff point to UgCS.

In order to better understand your problem, please, send us (support@ugcs.com) all log files from your android device.

But, maybe, you also can try next: 1. arm the drone and perform takeoff to some altitude, like 2 - 3 meters, 2. change takeoff point in UgCS, 3. upload the mission.

And one more thing, I'm recommending to everybody, test your missions using built in DJI simulator before going for real flights (launch simulator mode in UgCS for DJI mobile applcation).

I have a support ticket in and I have added the log files. I will try the other suggestion as well.

Ok, I see it. But do you use recent UgCS 2.10 and UgCS for DJI 2.3.211? 

As from logs I can see that your mobile app is 2.2.95. 

Anyway, I will check generated mission...

These logs are from UGCS 2.9. I tried UGCS 2.10 on another laptop but UGCS 2.10 would not connect to my drone for some reason.

The UgCS 2.9 update 1 works with android app. 2.2.95

The UgCS 2.10 is compatible with android app 2.3.211 - please, visit GooglePlay and update your app. 

I am running android version 5.0 because there is a bug in android 6.0. In 5.0 when I plug the controller into tablet via data cable It comes up and ask which program do I want to use? UGCS or DJI Go and asks one time only or always. In Android 6.0 when I plug the controller in the message comes up asking which app to use but it flashes up and off the screen very quickly not allowing me to choose. Also, does not have option to select one time only. Will UGCS 2.3.211 work on Android 5.0?

Yes, it should work. We are supporting Android 4.4.2+

Ok was the app fixed to se older versions? Because when we went back to android 5.0 about 6 months ago the updated UGCS app would not work with android 6.0. I had to have UGCS support send me the app I am using now because it no longer was on Google Play?

Any ideas on the altitude too high issue? I am wondering if you select update takeoff altitude and upload the mission why it does not keep the updated takeoff altitude? Because on this site I am trying to fly if I go down to the impoundment area I get an AGL of around -70 feet. It seems to me if you update the takeoff altitude that should override the actual elevation position when you upload to vehicle, if not what is the purpose of he update takeoff altitude?

The same problem occurs here. I did some flights last week and everything worked fine.

Today I tried a new mission and this problem appeared.

I'm using UgCS 2.10.1058, Android 5 with App 2.3.211 and Phantom 3 Advanced.

After skype conference with Michael, we have found a way to avoid such problems. The idea is to have first waypoint as close as possible to current drone location. Even if you are using only an area scan, please, add this one extra waypoint in the mission begining.   

Has a solution been found for this problem, as we're having the same difficulty.

I've noticed the issue with updating the Take off Altitude then having it revert back when we upload the mission. Our takeoff altitude discrepancy has only ever been 1 to 4 m so we usually ignore it.

The big problem is the Altitude too high error message when we try to launch the mission as this stops the mission from starting. We don't get any error messages when creating or uploading.

Any help would be appreciated.




Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service