Is anyone having issues with exporting telemetry and geo-tagging photos since the last update (2.13(401)).

I'm using a M600 PRO, A3, LB2. the missions work perfectly and everything else is super stable, as always, but when I try to export the telemetry it will says it "converting telemetry" indefinitely 9/10 times. I have to restart the laptop completely several times before it will finally export. I did not have these issues with the previous version, I haven't tried rolling back because I don't want to loose all my old telemetry data. It seems to be worse and more unstable if there isn't a internet connection, not sure if that is a real pattern but it seems to be almost impossible to export it or geo-tag in the field but will work 50/50 when I get back home and are connected to the WiFi.

I have tried this on 2 different laptops, both running 2.13 and have similar results. I will say that my non-field and quite powerful laptop has a higher success rate so not sure if it's simply a 'grunt power' issue. I rarely ever get the track log drawn in the telemetry player now as well. If they ever do appear then the telemetry will normally export but I have had it sitting for hours on the telemetry player before to see if it needs time to load and still it doesn't come up.

I need to be able to geo-reference photos in the field immediately, so this is quite a big problem for me. Any help or suggestions would be great.



Views: 273

Replies to This Discussion

Hello Robert,

I am sorry for the inconvienence. Are you completely sure that with previous (UgCS 2.12) it was better (both telemetry export and flight line drawing)? Would it be possible for you to send us some example telemetry export for investigation? (

Could you maybe try to reduce the timeline (zoom in) to a shorter peridod of time, both for exporting and line drawing? That should really speed up the process.

Kind regards,


Hi Artus,

Thanks for the prompt reply. Yes I am completely sure its more unstable in this version. I never had to reboot my computer multiple times to get it to work before. I have zoomed right in to help it load but it will still crash and/or not draw lines. When I try to geo-tag it will take ages (possible 60 seconds) then give me the "could not find co-ordinates for "Image 1"" and then will keep working but wont process anymore images or give anymore errors. The program doesnt crash, it just keeps working with no progress. If it does work it takes only seconds to process many many images. If it does stall when exporting telemetry or geo-tagging it wont shut down properly and/or will give me the "haven't finished saving, may loose some data" warning message.

I can't upload one here as they are all too big (usually between 10-20mb's for the day) I'll email it to support.

Hi Artus.

I have exactly the same problem.
I've even tried the latest version and I do not see any improvement. I have also tried to install version 2.12 but it does not accept the telemetry of version 2.13.
Do you have any news about it?


We have concluded that the A3 flight controller (used in M600) sends very large amounts of telemetry data every second (slightly more than other our supported flight controllers) and therefore the telemetry data is slowing down UgCS and your PCs.

We have registered this issue and our developers will treat this with high priority to fix it in next version.

For now I can only suggest to export smaller chunks of Telemetry (zoom in, so that you see shorter time interval when exporting).


Great to hear, glad it wasn't just me having the problem or doing something silly. Looking forward to the update.



© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service