Hey all, when I upload my DSM (or DTM) that I made with Pix4d it is set approximately 52 meters below the SRTM elevation source (it looks like a big bowl in the ground). I am trying to match the sources so I can plan missions that could extend from my DSM area into the SRTM area.  I have tried changing settings in Pix4d such as the Geoid Height above WGS 84 (+52m) I have also tried other vertical coordinate systems. Every time I try and upload the DSM made with other settings besides the default I get "an unexpected error occurred" message and the upload fails when I try to upload the DSM in UGCS.  Any suggestions on the proper way to set up Pix4d to output the DSM and DTM so it matches the SRTM? Thanks!

Views: 248

Replies to This Discussion

Hey Luke, can you please share your DSM with support@ugcs.com to reproduce the problem? Also please let us now the UgCS version.


Alexei Yankelevich

Alexei, I sent the information to support@ugcs.com. Did you receive it? Thanks, Luke 

Hi Luke,

we received your email, our engineers are still working on it.

Luke said:

Alexei, I sent the information to support@ugcs.com. Did you receive it? Thanks, Luke 

Thanks Alexey!

Dear Luke ,

Thank you for reaching out to us. Please accept my apology for not answering sooner.

We have analysed these files.

This issue was registered.

It will be fixed in one of the nearest versions of UgCS.

Best regards,
Anna Moshkova

SPH Engineering
Video tutorials: www.youtube.com/ugcstv
Latest news: www.facebook.com/SPHEngineering


After looking at the first file you sent It does look that all you need is to add altitude offset to match the default terrain.

Unfortunately I cannot guide you through pix4d settings as I do not have experience with it and trial version does not allow to export DTM. From what I see it should be "Select Output Coordinate System"/"Geoid Height Above WGS 84". The exact value most likely should be determined experimentally.

I can recommend to check the generated file with gdalinfo tool and verify that tiff does include the correct transformation in exif data. Basically, any valid coordinate system is supported by UgCS.

The second geotiff file you uploaded was in BigTiff format which is not currently supported by UgCS. Also, it did not have a valid transformation defined. I agree that the error message should be more informative and we will work on that.

Thank you for your input,



© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service