I have UgCS One (2.13.537) and created a route. The first 2 waypoints did not have a change yaw command, then the next 3 waypoints had a change yaw command, and then the following waypoints had no change yaw command. The turn types were all 'Bank Turn'. 

I ran in simulated mode and the simulated quadcopter performed as I expected: It did not stop. At the 3 waypoints where I specified a yaw it turned to that direction while continuing to travel waypoint to waypoint, and then resumed turning to the next waypoint. Awesome.

Then when I ran the route with my quadcopter, which uses a DJI Naza M V2 it stopped at each of the 3 waypoints where I specified a change yaw command, turned to the yaw direction, then turned back to the direction of travel and continued to the next waypoint. 

How do I make it keep the yaw turn as it's traveling through the waypoints where I specified a change yaw without stopping?

Views: 125

Replies to This Discussion

Hi Tom, unfortunately there is no way. Naza-M v2 in automatic mode flies with nose pointing to the next waypoint. The same for A2.

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service