I am trying to test and become familiar with UGCS before buying it, but I'm running into a few issues. 

I tried to install the most current version of UGCS 2.7, but this version does not work with ArduCOPTER 3.2.1 (arduCopter 3.2.1 is the most current firmware version I can install on my older 3DR Y6 APM 2.6 board). so I uninstalled UGCS 2.7 and installed UGCS 2.6. 

During the installation I received the following message just before the end of the installation:

UGCS fails to connect to the server and I the following message appears. 

Any help would be greatly appreciated. 

Views: 997

Replies to This Discussion

Hi, when you had UgCS 2.7 installed, did you try connecting it to your APM? It is backwards compatible, you should have no problems using UgCS 2.7 with ArduCopter 3.2.1. 

Yes I did and it connected but it would fail to load my routes. I posted here: http://diydrones.com/group/ugcs/forum/topics/route-untitled-route-u... and I was told that UgCS 2.7 would not work with ArduCopter 3.2.1.

Thank you for the quick response.

Ok, I see. I'm sorry you're having this problem with the installation, my colleague Artūrs will contact you tomorrow.

In the mean while, what I can suggest you try is uninstall UgCS again, see if the UgCS folder under Program Files is deleted, then download UgCS 2.6 again and try to install it. In case it is still not working, you could also try UgCS 2.5.

Feel free to contact me through e-mail at any time: kristaps.brass@ugcs.com

I tried all those things and cleaned out the registry, but still get the same errors.

Thank you,

Ok, any chance you have another computer with you you could try it on?

Hi Flying Buddha,

Could You please uninstall and install again, just make sure to chose "Yes" when asked if to Remove user data.

If that does not help, we can send You a patch to use UgCS 2.7 with previous APM 3.2.1 firmware.

Regarding the error during installation, You could try to install the component manually it is Visual C++ Redistributable Packages for Visual Studio 2013, You can get it here: https://www.microsoft.com/en-us/download/details.aspx?id=40784

Please let me know Your decision, maybe e-mail me arturs.kalis@ugcs.com

That would be best, so I can later send You the patch if necessary.

Regards,

Artūrs

It seems that Flying Buddha has fixed the issue by installing UgCS on a different laptop.

Unfortunately since we do not develop the VIsual C++ components ourselves and this is developed by Microsoft, we can not guarantee that the components will work on all machines hassle free.

Artūrs

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service