I'm currently working on getting a Phantom 2 Vision Plus functioning properly with UgCS.  I have been following all of the information available out there that I can find, but am still at a loss.

  • I have installed UgCS Version 2.9 Update 1, which as I understand it is the last compatible version for the Phantom 2 Vision Plus SDK.
  • The Phantom, P2V+ Android app, and UgCS client are all connected (insofar as the battery, signal strength, GPS strength, etc. are all displaying throughout).
  • I can build and upload a route to the Phantom without any errors popping up in the UgCS client.
  • When I do the upload, the P2V+ app indicates that the upload was complete and that the Phantom is now running in auto mode.

However, the Phantom just sits on the ground (UgCS lists it as "Disarmed" and "Auto mode") and never takes off.  I've also tried using the Click & Go functionality, both from a landed state and while hovering some distance off of the ground; I get a similar notification from the P2V+ app (upload complete) but the Phantom does not move.

Any help or advice would be appreciated!  We're currently using UgCS Open, but I need to demonstrate that UgCS is a "functional" program before I can get my boss to approve purchasing a paid version and a more up-to-date UAS.

Views: 82

Replies to This Discussion

Hi Hayden,

So far you have done everything right, getting the correct UgCS and Android App.

Just when you like to fly a Auto route or use Click & Go funciton,

First take off the Phantom 2V+ manually (using remote) and only then upload route and engage Auto Mode.

I hope this solves your problem!

Artūrs

Hi Artūrs, no luck.  I did as you said; manually put the Phantom in a hover about 30 ft above me, then clicked "Upload" and "Auto Mode".  It stayed in its hover location without moving.  I tried Click & Go as well with the same results.

Artūrs said:

Hi Hayden,

So far you have done everything right, getting the correct UgCS and Android App.

Just when you like to fly a Auto route or use Click & Go funciton,

First take off the Phantom 2V+ manually (using remote) and only then upload route and engage Auto Mode.

I hope this solves your problem!

Artūrs

So you were able to connect to the drone without issues, you see it on UgCS Desktop app and can upload the route without errors, but after engaging "Auto Mode" nothing happens?

It might be that you have to be in GPS flight mode when doing the "Auto Mode"

That seems to have done the trick.  I activated NAZA-M and GPS flight mode, and it immediately responded to the Auto Mode route.  Thank you so much!

One follow-up question; will UgCS control the camera automatically when using the Photogrammetry tool, or do I need to set the photograph frequency manually from within the UgCS app?  The first option would definitely be preferable, but I can't seem to figure it out.

For the Phantom 2 V+ only camera by time option is possible to use with Photogrammetry tool. Please refer to this manual:

https://www.ugcs.com/files/manuals/v2.11/UgCS_connecting_Phantom_2_...

And the general User manual of your UgCS version. Basically you need to make sure, that the camera trigger frequency is not higher than supported by the drone.

Perfect.  Thank you so much!

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service