Great deal on a 3 axis gimbal with Alexmos controller

Just had to tell all of you about this $59.95 three axis gimbal deal on EBay:

This seemed like a great deal and looks to be identical to DYS Gimbal on Hobbyking which is $200.00.

I got one and quality appears excellent though I haven't tried to use it yet (I will probably get another.) 

I'm planning on converting to a Storm 32 for a laser rangefinder scanner.

Apparently DSLRPros has moved on and is wholesaling them out.

http://www.ebay.com/itm/DSLRPros-3-Axis-Gimbal-for-the-GoPro-3-3-an...

I get nothing from anybody for this, but if you want a real 3 axis gimbal, this is the best deal you'll ever see.

Heres a link to the manual for the DYS: http://www.getfpv.com/media/wysiwyg/documentation/3AxisbrushlessGim...

Heres a link to the Basecam (Alexmos) Home page: http://www.basecamelectronics.com/

And a link to download the appropriate 8bit Alexmos Gui: http://www.basecamelectronics.com/files/SimpleBGC_GUI_2_40b7.zip

And a link to download the Alexmos manual PDF file: http://www.basecamelectronics.com/files/v10/SimpleBGC_manual_2_4_en...

(This does include the Alexmos 3rd axis expansion board.

Best regards to you all,

Gary

Views: 5801

Comment by Dan Murray on July 21, 2015 at 12:33pm

Mike?

Comment by Gary McCray on July 24, 2015 at 5:06pm

FYI update,

I finally had a chance to plug in and test my DSLRPros / DYS gimbal at least as far as basic stabilization with the following result.

No additional firmware programming or testing has yet taken place on my Gimbal.

With laser rangefinder attached to the Camera tray and counterbalanced for roll and pitch, when the 7.4 volt power was applied the laser rangefinder immediately leveled to horizontal and level in roll.

When the chassis was pitched and rolled the rangefinder remained level.

When the chassis was yawed, the camera remained stable and followed the yaw with a short < 2 second lag (which is what I would expect of yaw stabilization).

I think this is a good opening test for the rangefinder and if it doesn't do this I think it is safe to assume something is wrong.

And Dan, from the results you have reported above, it seems pretty likely (to me at least) there is something wrong with your Gimbal.

You will need to have a GoPro or weight simulating the GoPro in the camera mount pod so that you can achieve good static balance.

I used a 7.4 volt battery but note that on the DYS web site that their 3 Axis Gimbal is listed to work with anything from 7.4 to 25 volts.

If anyone can do so I would greatly appreciate clarification of the input voltage range of this DSLRPros version - Mike Perhaps???

Obviously 7.4 volts will work and is safe for testing, but I suspect that 11 volts (3 cell or higher might achieve faster tracking) if it is OK.

Best Regards,

Gary

Comment by Dan Murray on July 25, 2015 at 1:26pm

Hey Gary,

Thanks for your message. Actually, DSLRPros felt the gimbal was bad too and sent me a new IMU and processor. I just replaced it today, and things are significantly better, but not fixed.

Now, it only seems to freak out in the yaw direction. I fired up the software and disabled the yaw-follow and it works like a normal 3 axis gimbal, holding the camera in one spot exactly. The problem is, that doesn't work great either - I need the yaw to "track" or at least stay pointing forward, not hold heading. The instant I turn the yaw follow back on it just starts randomly spinning back and forth again.

Will have to keep messing around I guess..

Comment by Gary McCray on July 25, 2015 at 5:16pm

Hi Dan,

Just a quick thought, I have read that when you power the board from the USB it doesn't power the 3rd (yaw) axis ESC (although on mine Yaw does work to a degree, sort of, somewhat, not very well but it's trying).

I am using a 7.4 volt battery and with direct battery power Yaw follow actually works pretty much as it's supposed to when powered.

I have now updated my firmware (required to use the GUI I downloaded from Basecam) and now the Alexmos boards clearly need recalibration and reinitialization.

It is stable but if you move the base of the gimbal to fast or far it can lose sync.

But at least it now comes up and shows a green LED solid connection rather than a (green LED blinking) error.

I am going to follow the initial setup instructions linked to at the DYS Manual PDF link I posted originally and see if that helps:

http://www.getfpv.com/media/wysiwyg/documentation/3AxisbrushlessGim...

I do think that actually getting yaw to work is dependent on using the battery for power not the USB.

Comment by Gary McCray on July 25, 2015 at 6:53pm

Hi Dan Further Work with results as followed.

Input recommended starting settings from DYS Gimbal PDF page 9 of 9

I set PIDs, Power, Invert pitch and yaw as shown and changed from 14 poles to 22 poles and unchecked skip gyro calibration at startup and wrote it.

Still problems and not right and yaw definitely not right so please see below, actually got things working pretty well.

First you need to do setup with both battery and USB connected (I am using a 7.4 volt battery so not sure about bigger ones).

OK

Num Poles = 14

Roll P 13, I .2, D 17, power 110, +0, not invert

Pitch P 12, I .11, D 9, power 100, +25, not invert

Yaw P 18, I .23, D 17 power 130 +25 INVERT

Try this, it seems to be working pretty well for me now doing setup with battery and USB connected.

Auto Motor Configuration doesn't work worth ####.

But I set power and invert values based on actual behavior until achieved apparent decent operation.

At least it's a place to start.

Pretty clear these are 14 pole motors though by looking at spread from auto (13, 15 and 16)  and not 22 pole motors as mentioned in the DYS PDF manual.

Actually looking to be working pretty well now - including default yaw behavior.

Best Regards,

Gary

Comment by Chris on July 26, 2015 at 1:03pm
Hey Gary thanks for all the info, I was trying with this setup for a while before I got anything to work, it would hold in place but twitch every second or two. It doesn't work on USB for me but I figured that, USB only pulls 5V and maybe 1-2 amps max. Even on USB 3.0 it's not enough, I plugged mine into a 3S 1300 and tied it to one of thos scorpion camera mounts just for testing until I can get it working, I had no luck at all until I blanked all settings to 0 and increased them one by one using a tutorial I found but lost now. But I got it working pretty well as a handheld but it was locked in one direction that is set when you boot it and if you move it too fast or jerk it at all it freaks out and spins like 180 almost.

Not content on th locked angle I went to setup it for a follow mode where when I yaw turned the handle it would follow the yaw, that worked pretty well but it was a bit slow, if i turned about 45 degrees it would take maybe 30 seconds to catch up and then it wouldn't stop once it got that spot it just kept spinning.

I then bought a sainsmart joystick and Hooked it up to help simulate using my Tx to yaw and pitch the camera but once I set I all up it would pitch but not yaw, and if I flipped the wires it would yaw and not pitch, that's as far as I got because I noticed the motors getting really hot and I shut it down in fear of burning out the motors, I haven't got a chance to get back to it but I believe my settings for power were 200 with +- 10 so I should probably pull it back and try your settings. I'll boot up my desktop and check what my settings were so I can post them

- Chris
Comment by Chris on July 26, 2015 at 1:08pm
This is my last settings I believe worked, I need to verify but it's the last screen shot I had in my pile
http://i.imgur.com/OMZ9dPS.jpg
Comment by Euan Ramsay on July 26, 2015 at 1:09pm

I get a very, very slow drift in yaw on mine. I had to bump power to 160, and Yaw D rate to 20. Apart from that...I just need a window to go test time.

Comment by Euan Ramsay on July 26, 2015 at 1:19pm

Chris, did you not have to set AXIS RIGHT to -Y, so pitch was listed correctly?

Comment by Chris on July 26, 2015 at 1:31pm
I have it setup upside down right now for testing here is a quick video I took, this was before messing with yaw follow or the joystick
http://youtu.be/oorI04MOG30

Comment

You need to be a member of DIY Drones to add comments!

Join DIY Drones

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service