[This home page has moved. It's now here]

Views: 142855

Comments are closed for this blog post


Developer
Comment by Jordi Muñoz on July 29, 2009 at 8:16pm
Maybe is the binary protocol. I do have em406 so i will try it again. In mean time do me a favor, try the firwamre code name SparkFun Winner:
ArduPilot21.zip

This is the version that only works in EM406 and was working like a charm. But maybe the 2.2 version has the binary protocol damaged and i don't realize it because i always use uBlox (no way i will come back, only this time for you).
Comment by David Low on July 29, 2009 at 8:44pm
@Peter
I flew Ardu 2.2.3 successfully with AXN cloudfly since last weekend.
With EM406 (in SiRF), XYZ sensor from Diydrones, Ardu Shield...
Now it can do RTL and waypoint.
However, my ardupilot doesn't work with throttle control, I skip it and have it controlled manually.
Peter, pls let me know what other info u need :)
Comment by David Low on July 29, 2009 at 9:10pm
Still, I have to disconnect xbee when I power up ardupilot board else it will corrupt the modem setting.
And I reset the board after every calibration at field, and no trim in transmitter.
Comment by fefenin on July 30, 2009 at 1:07am
Chris,

my GPS is this one:


i hacked it to get a serial port that it don't have + change the firmware so the green led doesn't light any more,

don't worry every thing is working perfect!!

in fact this is this GPS inside + a chip for bluetooth and few things to charge the battery:
http://www.leadtek.com.tw/eng/gps/overview.asp?lineid=8&pronameid=310

sorry for my english i thaught it was clear

Peter, "Bravo" for all you're setup sound like you're very organized, i wish that i could have learn rc things with aguys like you... (there is nobody here around ;( )


Jordi, it is importat do know that the thing happens with NEMA protocol cause when i tried it was with locosys and it does like Peter said.

i'l also try you sparkfun code in SIRF mode now that i can

thank for your help
Comment by fefenin on July 30, 2009 at 2:40am
sorry the first link won't work , here is the adresse:
http://www.commentcamarche.net/guide/735577-x-loc-xl-266
Comment by fefenin on July 30, 2009 at 9:27am
hi, everyone,

i went for a flight so, heer is the report:

it was very hot and windy here,

first i tryed the I_can_fly version without GPS (Fly By Wire) and gain set to 8 for both pitch and roll:

it works GREAT!!! very stable and manual control works, i'll just have to put even a little more gain at roll only
and pitch was inverted???????

Jordi is it normal seens you can't configure it stabilisation is ok : nose down = up elevator ; nose up = down elevator
but the manual control is inverted!! i guess i'll figure out alone how to change that but i wanted to ask if it is normal??

after that i tryed the same version but with GPS (NEMA) and it did the strange bearing thing

so i decided to mount on the plane the SIRF hacked GPS with the same version but sadly i couldn't have a lock cause the 5V from shield GPS port wasn't giving enaugh power (need 5V 88mA)
i fixed that right now by pluging the 5V from GPS on the receiver , now i have a stable and quick lock!

i tried the FLY BY WIRE with the version 2.2.3 as well and it worked the same as the I can fly version

after that i wanted to try out the 2.1 spark fun soft but seens it works with SIRF only and my GPS wasn't working i couldn't try it

i have to rebuild the landing gear that broke again!

and fix the storie of the inverted manual control for pitch in FBW mode
Comment by David Low on July 30, 2009 at 10:44am
@fefenin
i have the same problem when i do fly-by-wire.
in my case, both my rudder and elevator control are inverted.
btw, in my easystar.h, i set both the Pitch and Roll as 1, so it can work with my rc set-up.
Jordi, is it the reason the controls are inverted during fly-by-wire?
Comment by fefenin on July 30, 2009 at 10:52am
thank for the tip david!
tell me if you find the meaning of that please.

i was amazed how the fly by wire worked great today!
looks like it is more stable than the FMA copilot CPD04 ,perhaps because of the Zsensor??

i was thinking that it would be good to mix a little bit the rudder with the ailerons to fly better against the wind.
i can do easily a third part mixer (pic 12F bases) that could do the trick just to see if it's better in high wind!!

it already works great in medium wind but maibe later improvement...

Developer
Comment by Jordi Muñoz on July 30, 2009 at 4:56pm
One questions at a time please for each person!!! You confuse me. Also i have a mental disorder that i can only answer the first question of every email,post (diagnosed by Chris Anderson).

The only reason why you have inverted fly by wire is that your controls are inverted than mine... So you really enjoy fly by wire, hee? Please concentrate in the navigation.

TO change the polarity go to this line located in AMAIN:
pulse_servos(PID_roll(PID_error(((float)read_Ch1()*FLY_BY_WIRE_GAIN_ROLL), roll_trim+get_roll()),roll_abs,t_dt),PID_pitch(PID_error(((float)read_Ch2()*FLY_BY_WIRE_GAIN_PITCH), pitch_trim+get_pitch()),t_dt));

and change the read_Ch1 and 2 and add a negative sign:
pulse_servos(PID_roll(PID_error(((float)-read_Ch1()*FLY_BY_WIRE_GAIN_ROLL), roll_trim+get_roll()),roll_abs,t_dt),PID_pitch(PID_error(((float)-read_Ch2()*FLY_BY_WIRE_GAIN_PITCH), pitch_trim+get_pitch()),t_dt));

Developer
Comment by Jordi Muñoz on July 30, 2009 at 5:21pm
This is the old homepage of ardupilot, lets transfer this conversation to here please:
http://diydrones.com/profiles/blog/show?id=705844%3ABlogPost%3A85428

I will never answer questions here. I will also ask Chris to close the comments here.

Thanks!

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service