I've been having some problems intermittently with RF interference when flying my Nexstar EP. I always thought it was just some local interference which kicked on and off for whatever reason and that I needed to just do a range test before each flight.
However, just today I decided to try a range test with & without Ardupilot installed. With Ardupilot I could only go about 200 feet away before i started getting pretty significant twitching of the servos. Without Ardupilot everything was still rock solid at 200+ feet. So it looks like the jumble of wires I had inside before won't work... are there any special precautions I can take besides just organizing wires and keeping Ardupilot as far from the receiver as possible? Is it important to keep Ardupilot away from the ESC as well? Does anyone have any home-made RF shield ideas?

I also want to thank Chris & Jordi for making Ardupilot - not only a great autopilot but a really great place for beginners to start learning.

Views: 503


3D Robotics
Comment by Chris Anderson on April 10, 2009 at 4:37pm
Start by twisting all your wires so the magnetic fields cancel out, and keep all RF emitters (like Xbee or video) as far away as possible from any RF receiver.
Comment by Roy Stevens on April 12, 2009 at 3:14pm
Thanks for the suggestion, Chris. I tried twisting up all the servo wires I could and keeping everything far apart (nothing transmitting inside, yet). Unfortunately I'm still getting heavy twitching. What's more is that it depends heavily on the orientation of the plane with respect to the controller.
I'm really surprised no one else seems to be having the same problem as everything is rock solid when i remove Ardupilot. I'm starting to think an upgraded receiver could fix the problem. I'm using a Futaba which came stock with my Nexstar right now. Can anyone else say if they've had the same problems with Futaba (R168DF, to be exact) receivers or does anyone have any recommendations for reliable brands?
I'm getting down to the wire here with the due date for my project so I'm starting to get a little nervous! Thanks again!

Moderator
Comment by Sgt Ric on April 12, 2009 at 5:32pm
This type of interference is a big issue in FPV circles. and led me to switch to Futaba 2.4 Ghz FAAST system.

I had tried wrapping the servo wires 3 times around magnet donuts and using commercial chokes that we use in the PC world to cut down of RF interference in phone/fax lines and such.

BIG help, but in the end, there was just too much twitching, mostly due to the video signal next to servo wires, so I moved away from 72 mhz.
.
Point is, try some ferrite rings and keeping servo lines short and away from any other signal emitters, like video TX..

3D Robotics
Comment by Chris Anderson on April 12, 2009 at 5:34pm
We've never encountered that in any Futaba, 72Mhz or 2.4Ghz.

When your'e doing the range test, is the Tx antenna down? If so, 200ft is probably okay.
Comment by Bryan Cuervo on April 12, 2009 at 5:55pm
Jeff and Roy,
We encountered the same problems with our Futaba 9C and PPM Rx. Rock solid untill ArduPilot was put in the loop. Everything would start twitching when I moved 40 ft away with the Tx antenna down. Tried rerouting wires, replacing antennas, shielding ArduPilot. Nothing worked. Finally switched to JR with an PCM Rx. Also have a set up with a Spectrum 2.4 GHz that also works fine.
Comment by Roy Stevens on April 17, 2009 at 12:33pm
Thanks for your help, everyone. In an effort to avoid spending much more money, we got ahold of a ferrite ring & used it on the wires coming in/out of arudipilot. That helped a bit but the thing that really did the trick was completely wrapping ardupilot & the Rx in tin foil. That will have to do until we can get a better looking faraday cage in there. Thanks again for your help, everyone. Great day for flying today in NE Ohio!
Comment by John on July 15, 2009 at 7:56pm
I'd like to say that although my first couple of boards (v1) from sparkfun were missing caps and one had damaged LED's, I have had limited success worth far more than the cost of ten of theses boards, and I am very impressed with the progress of this pioneering work- bravo Jordi and Chris.

I have noticed tow principal situations in which the ardupilot is sensitive to exterior noise:
One: two of my boards will hang (mode light stops blinking when loaded with latest code) (v2) (video coming shortly) unless pressure is applied to the back of the board with a finger or if the ctrl wire is left floating and handled by a person.

Two: In a noisy FM environment. I recently had similar noisy results as described by Roy using a Hitec Optic 7 and stock 72 MHz RX, only I wasn't but a few feet away. The only servos connected directly to the Ardupilot 328p (2) began jittering heavily and unpredictably, so I had to scrub the fly by wire. Servos are twisted and several inches from the servos. Also, when testing the controls, i notice servo "cross talk", i.e. the rudder servo jitters when pulsing the elevator servo. They are next to one another and wires are routed together, but the 'cross talk' disappears when the ardupilot is removed. Im not sure if the logic level is being affected or if there are ripples on the power rails. I am hoping an optoisolator will do the trick. Anyone yet experienced cross talk with an FM/ardupilot setup?
Comment by Steven McAdam on July 8, 2014 at 5:28am

Last post 2009, however, I have had similar issues.  Anyone ever found a solution to interference between APM/Pixhawk and 72mhz?  I can only go about 10 ft with the antenna down until I began to lose signal.

Comment

You need to be a member of DIY Drones to add comments!

Join DIY Drones

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service