This is my first attempt at building an ArduCopter. I started with franticly searching the web for parts. I had no idea what I was looking for, but I was looking. Between DIY Drones and AeroQuad, I was able to come up with a list. I have a little background with the arduino. But nothing like this. Mostly would work with LEDs, LCD screens, and Temp sensors.

Ok on with the build. Here are some pictures of what I have so far.

I have a thousand questions, that I don’t even know I need to ask yet.

Thanks to all on this site....

Views: 631

Comment by Scott Quartochi on July 25, 2010 at 5:36am
Thsi is what I get from APM_ADC_Test
2047,2025,2457,1673,1679,1679,1578,2843

Developer
Comment by Jani Hirvinen on July 25, 2010 at 6:18am
well Z-accel is never at zero when quad stays on table :)

It should show around 460 when at level. Why? Answer is rather simple. It's due earth gravity. Accell measures gravity changes and when It is level and not moving x/y axis are at zero but due earth is pulling us towards it's center with aproximate force of 1G. Accell what we use on OilPan shows 460 at 1G. This walue changes a bit on different locations. Best way to find it is to calibrate x/y to zero and then told you quad 90 degrees. And you should see 460ish value on your X or Y axis depends on which way you tilted IMU.

So after that you can make Z calibration correctly :)
Comment by Scott Quartochi on July 25, 2010 at 6:27am
You guys are the best!!!! I just asked the same question in the forum. I am so glad nothing is broken. Thanks for taken the time to explain this to me. I understand you are working hard on other things also. But you made me feel much better about my project.
Comment by Scott Quartochi on August 5, 2010 at 5:42pm
Ok, I have completed the calibration of my ESC’s. I just went around unplugging all but one ESC, apply power, arm motor, quickly plug in a second ESC (power and sig) unplug the original one. I left in (just to power the APM) and increase the throttle to full, calibrated them all.
Now that I have got that done, I thought it was time to do some testing. So I tied it to a 20lb dumb bell in the middle of my living room. Armed the motors and slowly applied power. It seems like the back motor is stronger than the rest, I even calibrated that one again.
I am using an old 72MHz Futaba T6XH. So I only have one extra channel. I am wondering if I have it in the right mode.

Comment

You need to be a member of DIY Drones to add comments!

Join DIY Drones

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service