I'm constantly loading and testing code and the power setup of the 2560 can be a bit of a pain. Mainly, the radio does not receive power because the Servo rails are only powered via a Lipo, which can be very dangerous. I never do anything but fly with a Lipo connected and I certainly don't connect one indoors. I'm just paranoid that way.

 

This hack will power the radio half of the servo rail with 5V from the APM's USB connection. The idea is to spilt the 5V rail into two halves. If you use an X-Acto knife you can easily cut the trace connecting both sides. I cut the ground rail in half as well, then used some solder to repair the bridge. Then I connected the 5v from the APM to the input side as indicated below. Now I can power the radio with the USB.

 


Views: 8355

Comment by Nafru on February 15, 2012 at 11:55am

This should be implemented for the next revision of the hardware as a built in.
just saying.

Nice job!

Comment by John Campen on April 13, 2012 at 10:27pm

Jason I had the Shottky diode on my APM damaged so Ive worked out what I think might be a temporary hack I can use until I get a new diode. Can you please take a look and let me know if you see any problems with this hack? It seem to work so far, but Ive not yet flown using it with all the gear hooked up. http://www.diydrones.com/forum/topics/missing-apm-board-component-d...

Comment by Axel Knauer on April 22, 2012 at 11:34pm

Thank you for this hack. I wish I had come across it earlier. Some weeks ago I was helping a friend in setting up his hexacopter. For a final tweak I had the board connected via USB. When plugging in the lipo it went into a soft reboot and started all motors. The result were numerous cuts to my hands and face, requiring 30 stitches. I was very fortunate not to lose an eye or receive worse injuries.

Removing the props was a very time-consuming procedure on that particular machine, and subsequently skipped for a short tweak.


3D Robotics
Comment by Chris Anderson on April 23, 2012 at 7:39am

This is the way APM 2 works. For those using APM 1, please note the warnings and advice about removing the signal cable when plugging in a LiPo, which are throughout the manual:

Comment by Søren Kuula on July 10, 2012 at 1:50am

Hi,

I tried it and it resulted in a loss of GPS in the field. There was only like 4.35V at the uBlox, which might have been too little. Had to undo it again.

What I think we should really have for safety against unintended motor starts is a hardware or software kill of all PWM out signals. OK there are BLC that will give up listening after some time without signal, I know..

Comment

You need to be a member of DIY Drones to add comments!

Join DIY Drones

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service