Luis Picó's Comments

Comment Wall (8 comments)

At 8:13pm on December 31, 2011, Juan Gomez said…

Hola Luis,

Ya le un vistazo al tutorial que me mencionaste! Esta genial. gracias.
Ayer estuve un rato, trabajando en mi código del DCM. Por falta de tiempo solo le hice algunos ajustes basando me en el Tutorial, no tuve tiempo para  verificar todo el código, en fin.
Tengo una duda, Luis: En la Matriz DCM, la diagonal de UNOS, ¿Siempre deben conservar estos valores? 
"Corri mi código, sin ningún movimiento en la IMU la matriz DCM, permanecía como la matriz Identidad, pero cuando giraba la IMU, la matriz me reportaba la rotación pero conforme pasaba el tiempo, los unos empezaban a decrementar, esto es correcto?  "
Si es necesario podría grabar un video, para que observes el comportamiento. Ademas, este domingo estaré verificando el código detalladamente.

Saludos.

 

At 12:28pm on January 1, 2012, Luis Picó said…

FELIZ AÑO!!!

Sí, es normal. La Matriz DCM tiene que tener modulo 1 en cada fila, y es lo que haces con la renormalización. Se inicia con una matriz unidad porque es la matriz más simple que cumple con los criterios de DCM, con el tiempo, efectivamente, la matriz se va tornando en lago muy distinto, no hay problema en eso.

At 9:25pm on January 3, 2012, Juan Gomez said…

FELIZ AÑO, LUIS!!

Gracias por resolverme esa duda.
Buenas noticas, Funciona mi codigo del DCM! =D
Pero ahora me surge una duda, basandome en el codigo de RAZOR AHRS, para corregir el error en el angulo Yaw. Hay momento "si dejo inmovil la IMU por un rato"en que el angulo Yaw que reporta la matriz DCM el angulo deriva mucho. Pero si muevo constantemente el angulo Yaw se corrige.
Este es la seccion de codigo, en si:

Tu usas el mismo codigo para corregir la desviacion del angulo Yaw?
Saludos.
 

At 11:38am on January 5, 2012, Luis Picó said…

Sí, ese código DCM debería de funcionar perfectamente. Por otro lado, lo que me comentas suena bastante raro... Yo lo que solía hacer, es quitar el giro del DCM, y ponerlo a cero (el vector del giro). Y entonces ver si los correctores, tanto el acelerómetro como el magnetómetro corregían bien y como debían. Mira así si el magnetómetro está funcionando bien.

Nunca me he encontrado con lo que me comentas... ¿Puede ser que tengas metales cerca y lo esté magnetizando??

At 11:44am on January 5, 2012, Juan Gomez said…

Ok luis, Este dia me dedicare a resolver este problema. Luego te digo como me fue.
Gracias.

 

At 9:38am on September 27, 2012, Juan Gomez said…

Hola Luis,

Como has estado? ya ha pasado mucho tiempo sin saber de tu proyecto!
Ya terminaste tu vehículo? 
Te comento que yo estoy a punto de terminar el mio. pero aun un ligero problema con la estabilidad del vehículo, pero al menos es capaz de volar por su cuenta.

Sin duda me gustaría saber noticias tuyas.
Saludos

At 2:37pm on March 19, 2013, Albert Miralles said…

Hola! Solucionasteis el tema de la deriva? A mi me pasa lo mismo. ¿Donde localizo el codigo que comentais "At 9:25pm on January 3, 2012, Juan Gomez said…"? Saludos

At 4:08pm on March 19, 2013, Luis Picó said…

Hola,

Si mal no recuerdo, era código de arducopter. Pero yo bebí de diversas fuentes.

Un saludo

You need to be a member of DIY Drones to add comments!

Join DIY Drones

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service