guys im struggling to get my apm 2.5 quad in the air,

 

ive so fair diagnosed that the esc's wont arm and theres no output to them through the apm, have tested with other esc's and cli but nothing, ripping my hair out its been 4 days of testing and still nothing,

 

my auto calibration wont initialize and ive manually set each esc, used 2 different recivers and still nothing.

 

 

Views: 3531

Reply to This

Replies to This Discussion

Jimmy I am having the same problem with the same board. I have had no problems flashing and setting it up or even with the flight modes. Just can't get the damn thing to arm. I'm working on my second tri. What the heck are pid's? And did you just power the esc and then plug them into the apm?

http://www.hobbypartz.com/proton30aair.html
Those are the esc I'm using.

When you say it won't arm, do you mean the APM won't go through it's arming cycle (flashing LEDs, then a solid one when it's armed), or that once it's armed the motors don't turn? If it's the former, the problem is probably on your RC side. If it's the latter, it's your ESCs.

I have the same problem with a flying wing and a hk esc, the motor doesn't  turn, when moving the stick, the motor beeps

btoh( motor and esc) worked the day before, but now I solved the problem with my elevon and the motor doesn't turn:(

thanks guys for the super fast reply

chris- the red light blinks and i cant get it to arm(stay solid) but i can get my esc to auto calibrate.

Drone - mission planner shows everything is pointing in the right direction but i have moved the stick in all corners.

I'm still kinda of a noob but when i hook up my kk2 board everything works.

http://www.youtube.com/watch?v=5QacnAgQmQw&feature=youtu.be

And you're sure you're in Stabilize mode? (Not one of the auto modes. For safety's sake it won't arm in auto modes. This is one difference between a full UAV and a basic RC copter.)

Yeah Chris for trouble shooting i changed all flight modes to stabilize. can the board be armed with just being hooked up to the usb? or does it need the esc? if so will it arm with just one or does everything need to hooked up and ready to fly ?

You can arm it while it's hooked up to the USB. If you've gone through the RC calibration and all was normal, the only thing I can think of is that one of your RC channels is reversed. It's really unusual for someone to have this sort of trouble with arming. Remind me again what RC gear you're using?

I GOT IT!!!!!!! my er9x is jacked up. I armed it but moving the right stick up and to the right. so I guess I will start working on the problem tomorrow. Thanks Chris and everyone else for your help.

Good! That just means your throttle is reversed. Reverse it from the Tx.

hey my 9x is setup with the rudder on the right side. isnt that wrong ?  throttle and rudder be on the left side right?

steve my esc's are hobbyking SS series, ive used them many times on many different quads and many different boards, 

first time this has ever happened, the APM arms correctly but i do not have the second "BEEP" from my esc's, 

my solution -- my apm is powered by a bec on the input slot number 8

1- disconnect all power connected to the apm, 

2-plug in the lipo to power your esc's (they will go into signal state where they are looking for the signal to arm, they should beep continusouly an dslowly)

3 - plug in the power to the apm at which point the esc's will arm,

4 - arm your APM by selecting your programmed arm function, 

the esc's will now power and turn your motors, easy BUTTTTT!!!!! REMEMBER TO MANUALLY CALIBRATE EACH ESC INDIVIDUALLY THROUGH YOUR RX

also my problem was my waypoints had not auto loaded into MP and everytime i reconnect i am finding all my settings are reset any suggestions? i always power up and have a 30m waypoint

your method didn't solve my problem ( no turning motor) with ss serie esc

when unplugging the esc from the apm and connecting with a lipo, no beeps

than connecting to the apm, on beep:(

I really need help so I can fly:(

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service