I took my quad out this morning to try various flight modes.  Alt hold was perfect (more or less without sonar), but when i swapped back to stablise I lost all throttle control and it went off on its own.  I could still control the direction, but that was all. 

With the throttle, it would not respond even with full throttle.  I managed to get it back to where I was and attempted to land - but nothing.  It did come back down near the ground, even landing but I couldn't cut the motors.  I had to flick between the different modes to get the motors to stop.

I'm pulling the video together now.  However, looking at the logs and google earth, it appears to have gone through many modes [some of which weren't programmed].  I'm still going through the logs, but it would be great if someone else could have a look and let me know what they think. 

 

 

Views: 267

Attachments:

Reply to This

Replies to This Discussion

Sounds like your CH3 channel became disconnected. Check your wiring?

Yes, everything was rock solid. \:

Update:  I've attached the video to demonstrate the action and the fight to then bring it to the ground.

23 December 2012

 

There is also this video from a week ago - no changes to configuration have occured.

16 December 2012

 

Did you check and make sure GeoFence is not turned on?

Hi Richard, I haven't started using that yet.  Question though, when you're flying, then export your logs and look in google earth, do you see modes that you haven't used?  Ie, if you're only flying in stablise, is that all you see in google earth?

My log only shows flight modes I've used. The reason I stated the Geo Fence was I started using it and forgot about it and had a hard time landing and stopping my Hex.

Hi David

I haven't checked your log yet as I am not on my computer at this, however, if you check into my posts, you will see that I have had an experience with my hexa (apm2.5) where the motors wouldn't shut down. You can see in the log some strange behaviour at the end of the flight, where I had to switch modes to get the motors to shut down. The thottle output was not responding to my stick input. While in flight at about 1 meter, it quickly pitched back and acted strangely as if it had switched modes.

I will check your log as soon as I get a chance. 

Cheers, Steve

Thanks Steve.  Any light you could shed on this would be great.  The thing is, it wasn't MEANT to be landing.  It was meant to be in STABILISE mode. 

I haven't ruled out that it's a transmitter problem, but it's the first time that it's done this - all other flights have been fine.

Hi again David

Yes, I wasn't trying to land either until that sudden change in attitude and the minimal throttle response.

I knew something was wrong so I cranked down the throttle, but it still wanted to fly. It actually felt like it was in Alt Hold, but I was in stabilize.  Not a very comforting feeling. I am glad it wasn't higher. 

I am curious to see your log file. Can you keep me updated if you find anything?

Steve

Ahh, I see.  It was a very worrying feeling I have to say.  Especially when it's flying quickly and down towards a building/bus. \:  Not sure if you saw the video near the end there.

The log was attached to my original post up top if you're interested.  I'm just going through my settings again now and will go for a fly in a couple of hours.  I will only have stabilise and alt.hold for flight modes and I just want to see what's happening. 

I'll let you know how it flys this time.

Just out of interest.  When you import your info into google eaerth, does it come up with all sorts of modes when you're flying, even if (and only if) you've been flying in stabilise?

 

David, the smart people here can take a look at your log and determine what mode the quad was in when you were having your problems.  I had a very strange crash about 2 month ago where someone looked at the log and told me I was flying while in RTL... I didn't even have that mode set in the configuration. Ultimately I never did get an answer how the quad changed flight modes.   Hopefully you do as if that is the cause its important to know.

If you are curious see this thread.. there are some similarities.

http://diydrones.com/forum/topics/that-sickening-helpless-feeling?p...

Hi John and others, it appears [if I can read the logs right] that I was indeed flying in RTL.  What I don't get though is that I read that you can only arm the quad in stablise?

I doubled checked my config and yes, it was possible to be flying in RTL mode as I had my configuration flipped, but that's how it would have been armed too.

But would this explain the google earth differences too?  I swapped modes twice.  Once from stablise [or what I thought was stablise] to alt.hold and then back.  Yet google earth has many more changes than that.

Thanks for the input from everyone and again, I get to learn something without any damage.  You'll never get bored with cutting edge technology. (;

 

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service