Is it possible to configure failsafe with a Specktrum DX6i?

I did the binding process with the transmitter set as it would be for RTL mode but when I turn the transmitter off as a test Mission Planner tells me the mode has switched to 'loiter'. I actually tested that by flying my 3DR quad away from me, hovering about a meter off the ground and then turning off the transmitter. The copter just fell to the ground when the motors stopped.

The manual for the TX says that the AR6200 receiver I'm using includes their 'Smart Safe fail safe system' which establishes low-throttle fail safe if the RF signal is lost. Is this the issue? Am I correct in thinking that their are two conditions required to trip failsafe in the APM, low throttle and no signal? If so and the receiver automatically goes to low-throttle then wouldn't that mean that my receiver can not create the conditions required for the APM to initiate failsafe? If so, I guess that changing the receiver would be the way to go right?

I have a new AR6210 here as well but haven't read the doco for it yet.

TIA for help with this.

Cheers from DownUnder and Happy Holidays to you all.

Views: 5357

Replies to This Discussion

I have a Spektrum DX7s with AR8000 receiver, so my knowledge applies to this pair - and should hopefully apply to yours. 

Out of the box, my TX had a lower limit of around 1100 PWM - as confirmed in the APM Planner. One of the RX/TX failesafe modes is to set the throttle to specific PWM on loss of signal. Obviously, you do not want that during normal operation (see my first posting), so this value should be outside of your normal throttle range. I set up my failsafe as follows:

  1. Programmed the TX and changed the lower limit to a PWM of 900, in the Throttle Curve sub-menu
  2. I enabled the preset failsafe (on signal loss, all channels are set to their failsafe position):
    1. Insert bind plug and power on RX
    2. Remove the bind plug when the RX LEDs start flashing.
    3. Move throttle to lowest position, leaving everything else centered
    4. Turn on TX while holding the Trainer button - to tell the TX to enter bind mode.
    5. After 15 seconds, they should be bound
  3. Re-programmed the TX to change the lower limit back to 1100, and re-calibrated the Radio in the APM Planner.
  4. Set throttle failsafe to 900 in APM Planner.

Under normal operations - when TX and RX are in range of each other - the APM failsafe should never be kicked in, since the lowest throttle PWM that the APM will receive is 1100. Only when signal is lost, will the RX send a PWM of 900 to the APM, to indicate that it must go into failsafe.

Hope this helps you.

I don't know if the AR6200 and AR8000 failsafe is the same, but the "problem" with the AR8000 is that it will not only set the throttle to a predefined level but also all the other channels. This should of cource be ok, but APM SW 2.8.1 have (in my opinion) an error that permits it to switch mode even if the throttle is below throttle failsafe level. It's reported in this issue. The short story is that throttle failsafe is impossible to use with a Spektrum AR8000 receiver (and maybe also with other Spektrum receivers).

It would be great if a developer would comment on this issue.

Darrel if the AR6200 failsafe is the same as AR8000 you can follow Nicolas guideline, but change "leaving everything else centered" to  "leaving everything else centered, but make sure the mode switch(es) is set to RTL"

Cheers from "UpOver" ;-) and Happy Holidays to all :-)

/Benny

Nicholas, yes thats exactly how it works with the AR8000 but I dont think the 6200 will work except for the throttle.

Writing this to the best of my knowledge since I have AR6200 and AR8000

The AR6200 will not engage any switches as preset, I use a AR8000 for this.  

So to me there is no way to bind the transmitter to RTL mode and im not sure how you saw it change to loiter.

The throttle is the only thing that can be programmed with the AR6200

I have a two AR6200 and one AR8000

If you want to get some type of failsafe in the 6200 you can only get a soft land.  Find where your throttle lands the craft in a somewhat safe manner.  Bind it with the stick in that position and if you ever lost signal it will land where its at.  But none of my AR6200s have ever been able to RTH or RTL because it wont throw the switch.

Hope this helps Ed,

So just as Nicolas mentioned,  you can set the throttle failsafe.

You have to go to the travel adjust menu,  make sure that the throttle is in the the down position , then adjust the throttle travel to 125%,  this gets put back to 100% after binding. 

Now Re-bind to your RX, once that's done , return the throttle travel settings on the TX to normal.

This should now allow you to utilize the throttle failsafe function.

Regards  Chris

Edit.. Also when the RX throttle failsafe activates,  the throttle channel jumps from whatever setting it had to the failsafe setting. 

Guys,

I was able to do the same but I am trying to do this part of the failesafe manual

"Enable the throttle failsafe by setting the FS_THR_ENABLE to "1" (always RTL) or "2" (RTL unless in AUTO mode in which case continue with Mission)"

 

It shows the setting

http://wiki.ardupilot-mega.googlecode.com/git/images/Failsafe/MPFST...

 

But mine as shown below does not have that setting, its is missing.  I need to make sure its set to 2 so it will continue the autoflight plan.

 

I found the THR_FS_ACTION

 

Although its not mentioned in the FaileSafe docs :(

http://code.google.com/p/arducopter/wiki/AC2_Failsafe

 

Here is what I have it set to, does this look correct to have it RTL unless its in Auto mode then I want it to continue on the flightplan.

I really dont see any actual doc on THR_FS_ACTION other than an issue report

I now this is an old thread, but, in hopes someone reads this, I would like to ask about the possiblity of using the Throttle cut buitton on the Dx6i to institute a RTL, as another option to programming the PWM down below the current lowest PWM.   I think this can  be done, but.....I have not done it.  If someon has, I would appreciate a comment.

 

Thanks for All for a great Thread!!!

Well for the record, I was able to drop the PWM on the DXt6i throttle cut to 900 ms which was well below the failsafe PWM ms of 945 and of course well below my lowest PWM throttle setting which was 1080 ms.   

I then set it to go to RTL when failsafe conditions are met and now it goes in to RTL when the Throttle Cut button is pushed.   The next step will be to replace the button with a toggle switch so you don't have to hold the button down to get it to RTL.

The super neat aspect of this, is that you can use the other 5 modes for things like STAB, LOITER, ALT-H, LAND, ACRO......hence, with the RTL on the throttle cut, you now have 6 modes to choose from.    

The only issue I have not resolved is getting it to go in to failsafe mode when the signal is lost.   Not sure why yet, but I am sure that should not be an issue.....It has to be in the adv param somewhere.....maybe the config.h???

When the signal is lost the throttle PWM of course nosedives and that triggers the failsafe. Maybe you have old instructions etc. but all of the failsafe stuff is explained in detail in the "new" Wiki at http://copter.ardupilot.com/wiki/failsafe/.

Oliver,

I am using MP 1.2.73 and copter 3.0.1

I did have an older version of the failsafe info printed out and I appreciate seeing some new things in the link.  

I am seeing some weird voltage readouts in my HUD that are right at 4.0 v.  even thought my lipo is around 12.2v.    It is like it is displaying a reading of the average of each cell.   And if I want to use a low volt trigger for failsafe I think I need to figure out how to get this to read (and display overall batter voltage.  

I thought at first my UBEC was failing but I tested it and it is delivering 5.25v to the board....

Any suggestions would be appreciated.   

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service