3D radio No heatbeat packets received

Hi Everyone, I'm a newbie with megapirateng... 

Issue: no heartbeat packets received when trying to connect via 3D Radio..

Boad rate on both the usb tel. and the remote at at 57.. Im able to load the info on missionplanner and they communicate its just when i try to connect it for data flight.. so far i only have GPS and telemetry plugged in board is being powered by ESC. 

Info about quad copter:

X frame

AIO Crius (http://hobbyking.com/hobbyking/store/__31138__Multiwii_and_Megapira...)

GPS - (http://hobbyking.com/hobbyking/store/__31135__NEO_6M_GPS_Module.html)

Telemetry - (F03016 Dual TTL 3DRobotics 3DR Radio Telemetry Kit 915Mhz for APM APM2)

I connected the gps and telemtry to S1-S3   

gps works fine when I connect via USB..

MissionPlanner version 1.2.87

I am able to see the two green lights solid and abe to bring up the settings under Config/Tunning then 3d radio..i double check connections and they match everthing looks good.

I have a read a few forums and they dont give a solid fix.. I tried a few things un installing MP and going with older versions.. and no luck. 

Please help sorry if im all over on this post but Im trying to give as much info as possible.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have same problem on my 3 computers

    I am able to see the two green lights solid and able to bring up the settings under Config/Tunning then 3d radio..i double check connections and they match everything looks good.

    Please help!!!

  • I am having a similar problem but only on my new(ish) laptop.

    I have mission planner 1.2.87 installed on my desktop and can connect to the ardupilot through USB or the 3DR radios.

    As soon as I plug the radio into my laptop I can no longer connect via the radios (but can through USB). I have tried loads of things to try and fix it, but to no avail. I have two sets of 3DR radios so I have even been able to try changing that. It only doesn't work on my laptop, which is annoying as I can't take my desktop into the field! :(

    I have tried: reinstalling the drivers for the com ports

    different versions of mission planner

    reassigning the com port number

    using older drivers for the com port

    changing the baud rate

    changing the baud rate in the com properties

    To make matters even more frustrating I did a fresh install on my old brick laptop and it all worked straight away! If only it was lighter and didn't need to be plugged in all the time!

    The problem must lie with my laptop somewhere, I just can't find it! The only thing I have noticed was that when I installed the radio on my old laptop it installed 2 drivers (COM and Serial..... I think), on my new one only 1 (the com driver). My new laptop worked last month and I can't see how it has changed.....

    Any help much appreciated!

  • Admin

    @victor,

    Are you trying to use the 3DR telemetry radios with the AIO Crius? If so then maybe you should be posting your issue on the RCG site: AIO Crius

    Regards,

    TCIII ArduRover2 Developer

This reply was deleted.

Activity

DIY Robocars via Twitter
Sunday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…