Hi,

I recently purchased a pair of 433mhz telemetry units and they do not seem to be working.
The radios pair with each other, and I can configure them (including the remote one) with the 3DR config tool.
The ATI5 command over putty reveals the following on both radios:
S0: FORMAT=25
S1: SERIAL_SPEED=57
S2: AIR_SPEED=64
S3: NETID=25
S4: TXPOWER=8
S5: ECC=1
S6: MAVLINK=1
S7: OPPRESEND=1
S8: MIN_FREQ=433000
S9: MAX_FREQ=434700
S10: NUM_CHANNELS=10
S11: DUTY_CYCLE=100
S12: LBT_RSSI=0
S13: MANCHESTER=0
S14: RTSCTS=0
The problem I am facing is that when connecting to my Arducopter with Mission planner 1.1.99 I receive a no heartbeats error.
Another possible symptom is that the ground unit's red light (whichever I choose that to be) blinks much more faintly than the air unit although it is in sync (about once a second)
Any help would me much appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi guys, 

    I have the same issue - how / where do I send my board for relacement (bought on jdrones.com from france)

    Alex

    jD-main
  • This may be silly question but did you make sure you plugged it into the correct port on your APM? My board (2.5) has two ports that are the same and I plugged my radio into the wrong port and had the same error.
  • Hello,

    I have the same issue. My radio does not want to communicate,

     

    When pressing Crtl A and click load settings it pics up but when trying to connect nothing.

     

    3692482422?profile=original

     

    This is my setting on the APM

     

    3692482288?profile=original

    And this is on the computer

     

    3692482431?profile=original

     

    and this is when loading the settings.

    It all was working this morning on a previous version, I just updated and now this.

     

    Any help please.

     

    Kind regrads

    Christiaan

    MWSnap006.jpg

    MWSnap007.jpg

    MWSnap008.jpg

    https://storage.ning.com/topology/rest/1.0/file/get/3692482422?profile=original
  • Same issue here...

    Was working perfectly, unplugged both units to work on another project, plugged back into the same computer 10 minutes later and I can not connect any longer.

    I can connect and see both the local and remote under Configuration..

    k.. Now same setup as before, could connect to the Configuration, but now wont do that, says "failed to enter command mode"...

    Any thoughts guys/gals?

     

  • Hah, silly me, the serial 3 baud rate was set incorrectly. All working fine now.

  • When I watch the com port in putty on the ground side, the link is receiving the floowing data:

    æÿîsBNľCJ¨èÄ88ø½Öàüàààüüààüàüàüààüüàüààüààààüàààüüààüüüààüüüüüüàüàààààààààààüàüàààüààààààüüààüüüüüüàüüüüüüüüüàüüüüàüàüàüàüüüàüüüüüüüüüüàüüüüàààüüààüàüüüüüüüüüàüüüàüàüàüàüüààüüüüüüüüüüàüüüààüüàüààààüüüàüüüàüüààààààüüàüààààüüààüààüüüüüüüüüüüàüüüààüàüààüüüààüüüüüüüüüüàüüüüüààüààààüüüàüüüüüüüüüüüàüüüüüàüüàààüüàüàüüüüüüüüüüàüüüààààüààüàüàüàààüüàààüüààüààààààüüàüàüüüüüüüüüüüàüüüààüàààüüüàüüüàüüààààààüüüààüüààüàüüüüüüüüüàüüüàüàààüüàüààüüààüàüàüàüüüàüàüàüàüààààààüàààüüüàààüààüüüàüàüàüüüüüüüüüàüüüüààüàüüüüüàüüüüüüüüüüàüüüààüàààüüààüàüàüüüüüüüüüàüüüüàààüààüüüàààüààüààààààààààààààüàüüàààüàààààààüàüàüààüüàààààààààüüààààüàüüàààààüüàüàààüüàààààüüà

    This is on startup of the quad, and then it repeats the ààüüàààààüüà bit once every second or so.

  • I am on Arducopter 2.6 but connecting with USB works. When connecting with the 3DR radio the USB is not connected.

  • Hi,

    I have almost the same problem with ArduCopter_2.7 release, but 2.6 works fine to me. (MP_1.1.99 and MP_1.2 perform the same result)

    With AP_2.7 MissionPlanner connects with my APM1 normally, but FlightData window doesn't get any new data and stay "freezed".

    What version of ArduCopter do you use?

    Michael.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
yesterday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
yesterday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
yesterday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31, 2021
More…