Hi,

I recently purchased a pair of 433mhz telemetry units and they do not seem to be working.
The radios pair with each other, and I can configure them (including the remote one) with the 3DR config tool.
The ATI5 command over putty reveals the following on both radios:
S0: FORMAT=25
S1: SERIAL_SPEED=57
S2: AIR_SPEED=64
S3: NETID=25
S4: TXPOWER=8
S5: ECC=1
S6: MAVLINK=1
S7: OPPRESEND=1
S8: MIN_FREQ=433000
S9: MAX_FREQ=434700
S10: NUM_CHANNELS=10
S11: DUTY_CYCLE=100
S12: LBT_RSSI=0
S13: MANCHESTER=0
S14: RTSCTS=0
The problem I am facing is that when connecting to my Arducopter with Mission planner 1.1.99 I receive a no heartbeats error.
Another possible symptom is that the ground unit's red light (whichever I choose that to be) blinks much more faintly than the air unit although it is in sync (about once a second)
Any help would me much appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi guys, 

    I have the same issue - how / where do I send my board for relacement (bought on jdrones.com from france)

    Alex

    jD-main
  • This may be silly question but did you make sure you plugged it into the correct port on your APM? My board (2.5) has two ports that are the same and I plugged my radio into the wrong port and had the same error.
  • Hello,

    I have the same issue. My radio does not want to communicate,

     

    When pressing Crtl A and click load settings it pics up but when trying to connect nothing.

     

    3692482422?profile=original

     

    This is my setting on the APM

     

    3692482288?profile=original

    And this is on the computer

     

    3692482431?profile=original

     

    and this is when loading the settings.

    It all was working this morning on a previous version, I just updated and now this.

     

    Any help please.

     

    Kind regrads

    Christiaan

    MWSnap006.jpg

    MWSnap007.jpg

    MWSnap008.jpg

    https://storage.ning.com/topology/rest/1.0/file/get/3692482422?profile=original
  • Same issue here...

    Was working perfectly, unplugged both units to work on another project, plugged back into the same computer 10 minutes later and I can not connect any longer.

    I can connect and see both the local and remote under Configuration..

    k.. Now same setup as before, could connect to the Configuration, but now wont do that, says "failed to enter command mode"...

    Any thoughts guys/gals?

     

  • Hah, silly me, the serial 3 baud rate was set incorrectly. All working fine now.

  • When I watch the com port in putty on the ground side, the link is receiving the floowing data:

    æÿîsBNľCJ¨èÄ88ø½Öàüàààüüààüàüàüààüüàüààüààààüàààüüààüüüààüüüüüüàüàààààààààààüàüàààüààààààüüààüüüüüüàüüüüüüüüüàüüüüàüàüàüàüüüàüüüüüüüüüüàüüüüàààüüààüàüüüüüüüüüàüüüàüàüàüàüüààüüüüüüüüüüàüüüààüüàüààààüüüàüüüàüüààààààüüàüààààüüààüààüüüüüüüüüüüàüüüààüàüààüüüààüüüüüüüüüüàüüüüüààüààààüüüàüüüüüüüüüüüàüüüüüàüüàààüüàüàüüüüüüüüüüàüüüààààüààüàüàüàààüüàààüüààüààààààüüàüàüüüüüüüüüüüàüüüààüàààüüüàüüüàüüààààààüüüààüüààüàüüüüüüüüüàüüüàüàààüüàüààüüààüàüàüàüüüàüàüàüàüààààààüàààüüüàààüààüüüàüàüàüüüüüüüüüàüüüüààüàüüüüüàüüüüüüüüüüàüüüààüàààüüààüàüàüüüüüüüüüàüüüüàààüààüüüàààüààüààààààààààààààüàüüàààüàààààààüàüàüààüüàààààààààüüààààüàüüàààààüüàüàààüüàààààüüà

    This is on startup of the quad, and then it repeats the ààüüàààààüüà bit once every second or so.

  • I am on Arducopter 2.6 but connecting with USB works. When connecting with the 3DR radio the USB is not connected.

  • Hi,

    I have almost the same problem with ArduCopter_2.7 release, but 2.6 works fine to me. (MP_1.1.99 and MP_1.2 perform the same result)

    With AP_2.7 MissionPlanner connects with my APM1 normally, but FlightData window doesn't get any new data and stay "freezed".

    What version of ArduCopter do you use?

    Michael.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13, 2022
More…