Replies

        • Developer

          Hi Brandon,

          Thanks for your help on this! While it always sucks when someone crashes. Your help has meant that a whole heap of people won't crash for the same reason.

          https://github.com/diydrones/ardupilot/pull/1684

        • I have been having bad luck with my GPS and that was actually a brand new unit in order to prevent any issues.

          Apologies if I missed it... are you running FPV, and by chance is it 1.2/1.3GHz?

    • Developer

      Hi Brandon,

      Looks like you had a GPS fail safe event and it went into auto land.

      Sorry to hear about your crash!!! Hope you didn't do any major damage!!

      • Hi

        After I looked at the logs it seems that All of the sudden I got massive vibrations causing the alt to be off from what it is. This alt controller is in serious need of a redesign something as easy as if vibes past limit only use gps and baro alt. It seems so primitive to rely on the accels So much when we have so much more info. 

        Now I am just wondering what caused the vibes all of the sudden, I think the gps failsafe happened after as I was in alt hold during autotune...in gps failsafe would it still auto land even though not in a gps mode

        • Developer

          Brandon, first up, I don't see the massive vibration you are talking about. Secondly suggesting that the work of the devs needs to be thrown out and done again without any explanation of how it could be improved or even why it is bad is not a way to motivate people to help you.

          I think the vibrations you see are where it hits the house.

          I am trying to work out why it went to maximum throttle though. I will get back to you.

          Again, sorry for the crash.

          • Hi Leonard,

            I may have been mistaken, but was there a vibrations on the Z accel? on the line 33? I compared IMU1 Z accel to my Current, I will double check this later tonight.

            I am not saying the work of the devs needs to be throw own, I did mention a fix (a check of the vibrations and if the IMU is experiencing +- 30g then It should be thrown out of the equation, Even if this crash wasn't caused by vibes I did have issues with them before where my quad would go straight up and I think having an If statement to check if there is to many G forces to not use the accels as this (normally?) doesn't happen, on a regular flight(?) would be a good idea.

            It is possible that the vibrations is when it hit the house, I will take another look and try to remember the time line. I do know it throttled up before It hit anything so if I compare current to the Z chart that should help..

            Thanks for the help, sorry if I came across rude but I did think it was a valid point? I don't have any experience in designing the FC calculations but please point out any issues with the idea I had(I guess CPU payload?) 

            • Developer

              Hi Brandon,

              No problem mate. We already do that and in the latest EKF it is the most robust way we possibly can do it. The EKF will reject impulses like that amazingly well. We also compare two imu's sampled at different rates to remove high offsets or spikes from noise or vibration aliasing.

              I will get back to you on the throttle thing when I get to the bottom of it. 

  • hello randy,

    does autotune work on the apm 2.5 and 2.6 or is it only for pixhawk?

    many thanks

  • George, Are you in both autotune AND alt hold? I have each function set up on a different switch. So I'll switch into alt hold first on the 3 position switch, leave it there, and then switch to autotune on a 2 position switch. Hope that helps!
  • Can't get autotune to start!

    My quadcopter flies but I want to try autotune now.  I have a 3 position switch that should be able to swtich from stabilize to alt-hold to autotune but autotune never starts.  Instead I tried having ch7 enable autotune and I checked in "radio calibration" that the PWM goes over 1800 (about 1850) but again - no autotune mode.  Should the log show it in the mode display?  The log shows text for "stabilize" mode and "alt-hold" mode but never shows any other mode.  The log definitely shows nothing with the ATUN tag.

    I have apm2.6.  And firmware 3.1.5.  I have reduced vibrations quite a bit - I think all 3 axes are under 1 in the graph from top to bottom in the noise (with no props it's about .5 from top to bottom for the noise).  I don't think it's the noise - would that not allow it to go into calibration?

    When copter is on USB only mode should I be able to get it to go into "autotune" in the GUI?  It shows stabilize mode and "armed" but never autotune.  I assumed the motors actually needed to be turning but if not I could maybe debug this without even turning on the motors?

    What should I try next?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: @a1k0n @diyrobocars @circuitlaunch And here's the final showdown! Video courtesy of @chr1sa I think I was a little faste…
8 hours ago
DIY Robocars via Twitter
RT @DanielChiaJH: @a1k0n @armand_dpl @SmallpixelCar @diyrobocars @circuitlaunch I use @foxglovedev Foxglove Studio for my visualization nee…
8 hours ago
DIY Robocars via Twitter
8 hours ago
DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
Monday
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
Sunday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
Saturday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Saturday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
More…