AC3.3 TradHeli Release Discussion

WARNING to TradHeli users:

Do not attempt to fly AC3.3 until you hear otherwise from me.  I have not even bench tested it yet, let alone test flown it.  There are quite a lot of changes that have gone in that could be crash-o-matic for helicopters.

AC3.3 release for Tradheli is likely to be delayed.

This post will serve as the official release progress thread for TradHeli.

Warning: DO NOT FLY RC6!  It has a critical bug that will likely end in a crash.

Warning for RC5:

RATE_YAW_FILT_HZ param will change defaults from 5Hz to 20Hz to be more suitable for helicopters.  If you have never changed this parameter from 5 before, then it will automatically update the value to 20 without warning.  This much faster filter will probably require reduction in your P and D terms, and the yaw may oscillate badly.  Be prepared to retune these.  As a safety measure, probably cut them in half for your first take-off.

Warning #2 for RC5:

I accidentally broke the Landing Detector.  It will probably never trigger.  You should land in Stabilize mode, or be prepared to shut down the motor as soon as it touches the ground in Alt_Hold, Loiter, Auto, etc.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Salut David,

        I remember quite awhile back also feeling a bit lost starting to use an APM on a TRex500. There was quite a lot to learn, and the documentation was not always up to date or completely explanatory. Try starting here

        http://copter.ardupilot.com/wiki/introduction/

        and see how it goes. I think this is the latest information available, correct me if I'm wrong. Rob's new video, when ready, should be a great help. I'm now setting up a 600 using a PixHawk and all that I've learned from my 2 years getting the 500 flying right. (I'm a slow worker!)

      • Hi David

        If you new to the pixhawk and you are not willing  going through the pages of the manual and the info on this forum you have to wait for Robert Lefebvre,s release of the next video he has promised will coming soon.

        The first setup video is here:    https://www.youtube.com/watch?v=rAbsZl5hanE

  • Hi guys, finally got round to flying AC3.3.3-rc1 after having many issues with low quality parts (KDS). It is flying beautifully now, almost as well as the DDVP trex did!

    Nice to see no tail kick when autoing now - it kicked on AC3.2.1, but not any more.

    Thanks Rob for your work on tradheli, it is very greatly appreciated!

    Many cool features to be found in this release! I did have to re-tune my rate gains however it is really worth it for a the extra stuff we get. Good to see the H_CYC_MAX in there plus piro comp as an option ;)

    Any ideas what is RATE_PIT_I_L_MIN? Looks interesting!

    • Never mind about the RATE_PIT_I_L_MIN question, I used my eyes and read the description a few pages back :)
  • Rob, I installed the newest beta version for traditional helicopter and i am getting really bad tail wag. I dont believe that it has anything to do with the firmware but more of a PID setting. I have had the hardest time trying to get rid of it and I am hoping that you can point me in the correct direction to get it fixed.

    I have attache a copy of the log and here is a video of it.

    https://www.youtube.com/watch?v=URFhOGp6B7Y&feature=youtu.be 

    Link to Log file

    https://www.dropbox.com/sh/9c1aouacbh93ktq/AAAyHYuAWa7iRLeZEiC0urph...

    Any thoughts or guidance in this would be appreciated.

    Thanks Joe

    YouTube
    • Hey Joe, zhangpengsir is having the same issue by the looks of his recent replies. I do not have this problem so far on 3.3.3-rc1. Can you post your param file?
      • I just connected the Helicopter and downloaded the param file. I still believe that this is a tuning issue since it had this in the previous version, just not as bad. 

        Thanks for the help.

        Joe

        Trex 450L 01-2016.param

        • HS4_MAX,1700
          HS4_MIN,1300
          HS4_TRIM,1500

          if these are really your limits, than this indicates you are using only half of the usual servo resolution. You should set up the tail servo to use something like +/- 400 instead of the +/-200. In other words your servo arm seems to be too long.

          You could try a faster RC_SPEED as well. Find the max. speed of swash and tail servo and use the smaller one (i.e. if swash servo limit is 200Hz and tail servo limit is 333Hz use RC_SPEED = 200 or less).

          Your tail wag doesn't look like a typical PID induced tail wag to me. Check for mechanical problems like servo arm length and loose parts or too much friction.

          How to solve PID problems depends a lot on your skills. 'P' or 'D' too high will lead to fast violent oscillations (P and D are "dangerous"). 'I' too high will make slow oscillations. FF passes your stick input to the servos. If you set P=I=D=FF=0 nothing happens at the servo. Either use the default setting or try this:

          D is good for fine tuning, but not needed in the beginning, therefore set D=0.

          FF doesn't oscillate and you need control, therefore set it to get about 75% of the maximum travel.

          Set the I-parameter to the default and set P=0.

          Make the heli light on the skids and check for good tail control, if you got it, lift off and watch for oscillations, then increase I,P and D  as needed. Always remember, better too low than too high !

          • I will take a look. I have looked over everything and i have not noticed anything loose or mechanically broken. Everything is stock from align, servos, push rods, ext.... I had to set the min and max this way to prevent over traveling. I will look at moving in on the servo arm to see what that does.

            Thanks for the input.

            Joe 

            • Joe have you tried changing RATE_YAW_I_L_MIN? I have mine set to 4500 because I dont like the idea of having any leak on the tail. Should make it more similar to older releases where there was no leak on the tail.

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…