Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • Hey Andrew. I was able to move everything into the appropriate spot except the routines you added at the end. It seems that it's not happy with these lines:

      if (x <= 0x00FFFFFF) {
      n = n + 8;
      x = x 8;
      }

      Specifically, x = x 8; . Any hints on what's supposed to be in the middle? 

      EDIT1: I guessed that you meant to have a multiplier in there, so I changed it to x=x*8. After that, though, I got an error on these lines:

      vn[1] = (v[1] s) | (v[0] >> 16 - s);
      vn[0] = v[0] s;

      Again, I'm not sure what v[0] s means. Maybe another multiplier?

    • This is awesome Andrew! and exactly what I've been recently looking for. Do you have your code available in Git that I could get some help me to compile into a release of Minim OSD Extra? I apologize if I'm not using the correct terms. I'm not a programmer. Thanks!

  • What are the preffered sr nr's with a pixhawk, I can imagine that with more process power of the pixhawk we can get more updates from mavlink?

  • Hi Rich,

    I'm replying here because I'm feeling the same difficulty as you show the reply in a order that makes sense :S

    There you have it! :) SR1_EXT_STAT is set to 2

    I guess that's why it is working via telem 1

    Do you have any of the SR2 parameters available via "Full Parameters List"?

    Miguel

    • Hi Miguel,

      Here are all my SR2 settings as is working:

      SR2_EXT_STAT 2

      SR2_EXTRA1 5

      SR2_EXTRA2 2

      SR2_EXTRA3 2

      all other SR2 values are 0.


      It was working well. I say 'was', because I decided to rewire my powersupply options and I think I BLEW UP my minimumOSD!


      I can talk to it via the FTDI USB cable and program it, etc.

      However I get no overlay text on my video any longer. Not even the bootstrap message.

      Now that it was working, I decided to wire it to my FW450.

      I was using the FatShark 12V filter. I had mistakenly thought that this device was a 12V regulator. Unfortunately, it is not a regulator, but it's only a FILTER!  My problem is that I'm using 4S on my FW450. So I sent 16 volts to the minimumOSD to the 12V input. I'm afraid I cooked it as I no longer get video output from it (I get my camera video, but no boot message, nor other video OSD data.

      Does anyone know if these are repairable easily, or should I simply purchase a new one? I was excited to finally fly with an OSD, but now I won't be doing that soon. LOL

      Micheal, I don't know if you saw my other questions about why my callsign was not being displayed, or my other questions, but perhaps we can take it up here. Perhaps we were too deep into the thread and there were no more layers of 'reply' available? LOL :)


      Thanks for your help. Let me know if there are any clues on how to repair my overvoltage issue on the minimumOSD. Or I'll just order a new one.

    • Hi Miguel,

      Sorry for posting here but i didn't know where to post my problem in this thread.

      I have recently upgraded from an APM2.0 to a Pixhawk PX4. Everything works fine
      except i cannot get any Mavlink data into the Minimosd

      My Setup:

      Mission Planner v1.3.5 build 1.1.5260.33055
      APMPlane FW v3.0.3
      Pixhawk PX4 (3DR)
      Minimosd  (3DR Non-Clone)
      NO 3DR RADIO USED

      3702497480?profile=original

      The Minimosd Boots up fine, but then i get "No MAV DATA!".
      The Minimosd has both power jumpers soldered and is powered just from the PX4.

      I have spent a couple of days on this now and tried all the setting i can find regarding the SR1 parameters,
      but nothing works.
      I have also tried using Minimosd v2.0 and even swapping the rx/tx wires.

      Iam currently using (Plane):

      CT Tool for MinimOSD Extra 2.4.0.1 Pre Release r788

      MinimOSD_Extra_Plane_Pre_release_Beta_R780.hex

      MinimOSD_2.4.0.1.mcm

      Does anyone know of a solution for getting this to work?

      James

      • Ok - after many hours of playing around with MinimOSD and MinimOSD Extra versions and

        trying every conceivable combination/settings of the SR1 parameters

        I have been able to get Mavlink data from the Serial1 port to my PX4 and it works!

        My simple solution - downgrade APM Plane from v3.0.3 to v3.0.1

        It would seem to me that there is a major bug in v3.0.3

        • I am new to APM and having the same issue.  How do you downgrade to v3.0.1?  Download the hex and flash from a local file?

          • Hi Adrian,

            In Mission Planner there is a Download Previous versions (or something like that).

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…