AltHold Mode ossilating/jerking

I have the rate gains tuned, tuned in stabilize mode (default stabilize gains).  Started to move on to AltHold but when I switched into AltHold it aggressively jerked up and down several inches without a noticeable overall change in altitude.  I started backing down the throttle gains until I hit the minimums and basically was unable to stop the oscillation/jerking although it seemed lower the frequency of the oscillations when the gains were bottomed out.  I'm at a total loss here, the only thing left to try is increasing the gains from default which logically thinking makes no sense.

  Please send some advise.

Setup:

Trex 500 TT DFC

Pixhawk mounted 90* roll

Arducopter 3.2.1

head speed 2350rpm

symmetrical blades

6s 4000mah battery

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.

Replies

  • Hi,

    maybe this helps:

    RSC = headspeed

    'Throttle' = collective pitch

    'Extended Tuning' Throttle Accel P = 'Full Parameter List/Tree' THR_ACCEL_P or ACCEL_Z_P

    After setting RATE tuning parameters you should switch to AltHold and do the ACCEL_Z_xx tuning, on all my helis I had to lower the ACCEL_Z_P from 0.5 to 0.3 to 0.4 (collective pitch +/- 12°). Too high P and D makes fast oscillations, I makes slow oscillations.

    Check for smooth operation of the servos, i.e. do they follow collective pitch input continuously or do the jump. If they follow in steps lower the RATE_xx_D.

    If this doesn't help check for vertical play. I have Pixhawk mounted 90° / 270° without problems using the provided foam.

    Be VERY careful using MP 'Extended Tuning' as it wants to set limits which are for copters and not for helis - I prefer 'Full Parameter List/Tree'.

    • My mount is just like:
      http://www.nextfpv.com.au/products/apm-pixhawk-anti-vibration-mount
      • Hi,

        I think the APM-Pixhawk-anti-vibration-mount is good when mounted horizontal on a gasser heli, according to the vibration logs I never needed one with an electric motor. In case you mounted the Pixhawk using the provided 3DR-foam on the anti-vibration-mount you could try to fix the top plate of the anti-vibration-mount to the bottom plate of the anti-vibration-mount (=disable the anti-vibration-mount) and compare the results in AltHold and vibration logs.

        • I tested with EKF enable and got the same results.  I then as a last ditch effort reduced the two throttle P gain settings to almost zero, was warned the values were below the minimum limit. The oscilations went away but the heli sank in altitude.  I then incremented them both up by 0.5 and althold worked as expected.  Still need to continue tuning but atleast it is now working without jerking up and down.  I want to give a BIG thanks for all the help.  The documentation is in serious need of updating, HAHA.  Also the views in MP are very misleading for a traditional heli. 

          Thanks again!

    • Thanks for the info, I'll give that a go and let you know how it turns out.

      • Well, I went out and ran some test flights.  I could not find an Accel_Z_P but did find Pilot_Accel_Z and WayNav_Accel_Z.  Setting limits were 50-300 or close there about.  I ended up setting those as well as the throttle accels all to minimum values by the time I was done and still did not get rid of the oscillation in the Z when switching from stabilize to althold.  The behavior was that the heli would ascend and descend as well as hold altitude when commanded but the whole time it would oscillate almost violently.  I did notice that in stabilize the collective had to be one mark beyond mid stick to maintain altitude in hover.  At mid stick it would fall at what I am estimating to be 1 MPS.  Could the mid stick setting cause this oscillation?  Should I increase the PWM setting at mid to have it hold altitude?

         

         

        Thanks for the previous response and further help will be GREATLY appreciated.

         

        Trey

        • Hi,

          I could not find an Accel_Z_P...

          On the 'Extended Tuning' screen in the box marked 'Throttle Accel' there is 'P' (default 0.5). This is the same as 'THR_ACCEL_P' (3.2.1 version) in 'Full Parameter List/Tree'. In 3.3 this is renamed to 'ACCEL_Z_P' that's why you cannot find it in 3.2.1 (therefore I wrote THR_ACCEL_P or ACCEL_Z_P).

          On my helis I did the rate tuning and experienced the vertical oscillations using the default setting. Changing THR_ACCEL_P from 0.5 to 0.3 - 0.4  was enough to cure the Z-oscillations in AltHold. I mounted the Pixhawk(s) with the provided foam on a sheet of PVC or aluminum glued/bolted to the frame. I think your mounting location is good, but I am not sure about your vibration damping mount. Please check/post your vibration logs. Too soft is as bad as too stiff, as the Pixhawk could 'overshoot'.

        • 3702797171?profile=originalConducted more testing, increased collective mid, throttle mid, reduced throttle accels, etc... nothing stopped the oscillations while in althold.  This is really discouraging.  Started thinking it is the pixhawk location causing prop wash to alter baro readings.  The mounting location is on the side of the frame similar to others so I thought I should be good (pic attached).  I'm now looking to AHRS_EKF_USE and EKF_ALT_NOISE.  AHRS_EKF_USE was disabled so I hope I am not headed in the wrong direction.  Any experienced advice will be greatly appreciated.

          Trey

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…