Replies

  • For some reason I can't edit my previous post. I meant to say "move all MODELS from"
  • Paul, thanks for your quick response, your words makes sense. I received an Horus last week and I really like the hardware. I am on OpenTx 2.2 pre release since I am not a fan of FrSky OS and was able to move all my modems from my Taranis Plus but I do miss the telemetry screens from this project!!
  • Zeek said:

    I'm wondering if this amazing work will ever see OpenTX 2.2 and will be adapted for the new FrSky Horus radio color didplay.
    Zeek, I would love for this also. I think its safe to say that I am probably the only remaining active contributor to the Clooney82 repo just now, but I only joined this project to make some tweeks to the code to fix bugs, and I don't consider myself to have sufficient skills to write a complete new branch which would work with the Horus. It would be great if other coders got involved to make this happen - the project guys really do appreciate fresh blood coming into the fold to get involved. I'm not even sure I will make the move to the Horus myself either as its a little out of my budget when I have a perfectly working Taranis Plus.
    On another point - there was talk of implementing some changes in OpenTx which would allow a telemetry sensor type to be included which would contain pureley raw data. I haven't been keeping up with the progress of this, but in essence this would allow code in the flight controller (pixhawk) to send a raw data stream  (containing completely custom defined telemetry info) out of a serial port into FrSky smartport - packaged up inside this special sensor type, and OpenTx allowing access to this raw sensor data in LUA, which would be coded to make sense of it and display it in formatted screens on the FrSky radio. Like I say, I'm not sure if this idea has reached fruition yet or where its at but sounds promising!
     
  • Don said:

    Question

    I want to be able to monitor 2 x 3S lipos instaed of a 6S lipo. Am i right in assuming that i would just have to change a few things such as...

    Don, Are you using the Clooney82 version of the teensy code? Or some other version? I am involved in the Clooney82 code. You don't mention what you are using for LipPo cell monitoring. I presume though by your mention of editing the code and scaling the values etc, that you have built the single cell LiPo monitor resistor/voltage divider board, and have this connected to the teensy (or Pro mini possibly)? If that's the case, I'm sorry, I can't be much help as I haven't been involved in that area of the code and personally, I do not use this for LiPo cell monitoring. Instead I use the FrSky FLVSS sensors - I have 2 of them installed on my big hexacopter, monitoring 2 x 4s LiPos (wired in parallel). I updated the Wiki recently to describe how this should be configured, and you can find this info here: https://github.com/Clooney82/MavLink_FrSkySPort/wiki/1.-Setup#combi...

    You should note, that the project does not support the use of the code on the Pro mini unfortunately. I know some other varients of the code do though, so possibly you are using one of those?

    Clooney82/MavLink_FrSkySPort
    This MavLink_FrSkySPort repository is discontinued! The development is moved to athertop/MavLink_FrSkySPort. Please do not use this repo, and follow…
  • I'm wondering if this amazing work will ever see OpenTX 2.2 and will be adapted for the new FrSky Horus radio color didplay.
  • DougB said:

    I found the problem. If I set the Taranis telemetry screen units to "m/s" as the Wiki shows its changing the ASpd value by some factor that is lowering the value of ASpd. If I set units to meters "m" the value of ASpd is passed to the Lua script correctly.

    Doug, Sorry its taken me a while to look at this. I just checked it out and it seems the issue is caused by incorrect scaling on the part of OpenTx. If you look at the raw data coming into the ASpd sensor (on model telemetry page, with units set to -), you can see this correctly displaying the values in m/s, but by changing the units to m/s, it scales this incorrectly.

    I'm guessing that if we were to connect a real-life FrSky smartport Airspeed sensor instead of the teensy (which just emulates those sensors using code) this would likely send the airspeed values through in knots (possibly?) so by choosing units of m/s it converts what it thinks is knots to m/s, thinking its being helpful. Of course, from Ardupilot, the Airspeed is sent in m/s natively (not knots), so we don't want the telemetry sensor config in OpenTx scaling this value at all - as our LUA script is expecting m/s. So in your switching the units to M as you did, OpenTx does not apply any scaling using this value for units, and the data correctly displays in the m/s scale (, and this value is then scaled in the LUA script to display KM/h on the LUA page) . The same would be true if you just set the units to '-'.

    I have amended the Wiki to suggest that once discovered the user should edit the ASpd sensor and change units this way to correct this issue. 

  • I have been following this for a while and while I have a working version on a pro mini, I want all the other options that a teensy has to offer.

    Question

    I want to be able to monitor 2 x 3S lipos instaed of a 6S lipo. Am i right in assuming that i would just have to change a few things such as:

    in MavLink_FrSkyPort.ino

    #define MAXCELLS 6

    in LSCM.ino

    double _LIPOCELL_1TO8[13] =
    {
    1913.528953519,
    933.688035297,
    622.955076603,
    1913.528953519,
    933.688035297,
    622.955076603,

    0.0, // diverders 7-12 not defined because my network includes only 6 voltage dividers
    0.0,
    0.0,
    0.0,
    0.0,
    0.0
    };

    then use the same r values for cells 1-3 on cells 4-6 for the voltage divider?

    i already stupidly fried my first teensy (jack and electronics dont mix :) ) and dont really feel like replacing it again....

  • Hi Paul;

    I found the problem. If I set the Taranis telemetry screen units to "m/s" as the Wiki shows its changing the ASpd value by some factor that is lowering the value of ASpd. If I set units to meters "m" the value of ASpd is passed to the Lua script correctly. If you confirm that the Wiki should probably be changed. Aslo, I have the plane Lua modded to display Imperial Units. But, that means if your setting any alarms in the Taranis they have to be set in metric. For my own needs I'm going to change the Tennsy code to make the change in the values before the values are sent to the Taranis so I can set the alarms in Imperial units. I've looked at the code and it is a fairly easy change.

    Paul Atherton said:



    DougB said:

    I'm having a problem with Airspeed (ASpd)

    I have Mission planner set to Metric, if I blow a constant speed of air into the pitot tube missionplanner shows around 17m/s. Taranis is showing only around 7m/s in the lua script and if I look at the raw data on the telemetry setup screen it also shows around 7m/s.

    What am I missing?

    Thanks

    Doug, I only added airspeed recently to the code so its fairly experimental. (assuming you're referring to the Clooney82 branch of the code?) My plane is out of action just now (broken LRS system) so no telemetry until I manage to fix it. I'll take a look then and let you know the outcome. Cheers, Paul



  • DougB said:

    I'm having a problem with Airspeed (ASpd)

    I have Mission planner set to Metric, if I blow a constant speed of air into the pitot tube missionplanner shows around 17m/s. Taranis is showing only around 7m/s in the lua script and if I look at the raw data on the telemetry setup screen it also shows around 7m/s.

    What am I missing?

    Thanks

    Doug, I only added airspeed recently to the code so its fairly experimental. (assuming you're referring to the Clooney82 branch of the code?) My plane is out of action just now (broken LRS system) so no telemetry until I manage to fix it. I'll take a look then and let you know the outcome. Cheers, Paul

  • I'm having a problem with Airspeed (ASpd)

    I have Mission planner set to Metric, if I blow a constant speed of air into the pitot tube missionplanner shows around 17m/s. Taranis is showing only around 7m/s in the lua script and if I look at the raw data on the telemetry setup screen it also shows around 7m/s.

    What am I missing?

    Thanks

This reply was deleted.

Activity

DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
RT @_JonMyer: 🏎 We need your help in naming my #AWS DeepRacer Underground Track 🏎 @davidfsmith's track is going to be referred to as 𝗔𝗪𝗦 𝗗…
Thursday
DIY Robocars via Twitter
RT @gclue_akira: 仕事もおわったし、電脳化にとらい #マリオカートハック https://t.co/4IU90hCLgm
Thursday
DIY Robocars via Twitter
This is the hashtag to follow all the people in Japan who are hacking the new Nintendo Mario Kart with the real AR… https://twitter.com/i/web/status/1319281354664677376
Thursday
DIY Robocars via Twitter
RT @gclue_akira: @chr1sa @diyrobocars jupyter mario https://t.co/P0oHdjlCRq
Thursday
DIY Robocars via Twitter
RT @_JonMyer: 🚨Our 1st AWS DeepRacer Community Race is Underway on http://twitch.tv/aws 🚨 Join us to find out which member of your commu…
Oct 20
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
RT @BackyardRobotcs: After an admittedly long wait, the new Tinymovr R3.3 motor controller is now available https://tinymovr.com 🥳
Oct 19
DIY Robocars via Twitter
RT @_JonMyer: 🏎 1 hr left before the #AWS #DeepRacer Community 🏎 Top 5 Race tomorrow LIVE on Twitch 1st Place = $50 Amazon GC or AWS Credit…
Oct 19
DIY Robocars via Twitter
Oct 16
DIY Robocars via Twitter
Oct 15
DIY Robocars via Twitter
Oct 14
DIY Robocars via Twitter
RT @davidfsmith: Race virtually with The AWS DeepRacer Community Race and then join us on the track to see how your times compare on the ph…
Oct 14
DIY Robocars via Twitter
Oct 14
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Robocars via Twitter
RT @breadcentric: It's now!
Oct 13
More…