APM 2.5 No dataflash Compass init error

Hey everyone, I just received a Arducopter kit w/ full electronics, assembled it, everything is connected, installed MP, loaded driver, loaded 2.8.1 firmware. Problem I am getting is I cannot get Mission Planner to recognize the compass, doesnt work in Flight Data. Also the console reads No dataflash inserted  Compass Init Error. Attached are two screenshot I hope helps troubleshoot this. I hope the board isnt DOA.. The APM 2.5 came assembled in the case, but was missing 3 of 4 screws and the rubber reset button, bit surprised with this... Anyways, looking forward to any and all suggestions on getting this up and running. I am stationed in Japan and would like to see about troubleshooting this before sending it back to the vendor. Long mail times :P Thanks!

3690981099?profile=original

3690981014?profile=original

Jake

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am having a lot of the issues listed here with my apm 2.5 board.  I can't connect in MP with the latest Arducopter V3.0.1.  I was able to load 2.9.1b and connect, however I couldn't run any radio calibrations.  The bars just stay empty no matter what I do, nothing records.  After reading a lot of these posts, I thought I would check the 3.3V regulator and this is what I get.  Any thoughts or help??

    Inline image 1

  • hey guys I have the 2.5 board, that will not connect to mp.  i check and i'm getting 4.7 volts out of my chip.  I assume this is bad....

  • I'm having the same issues w/ compass & data flash that def2att described Dec 2012. Any solution?

  • Having the same problem! Happened just now. I've checked output voltage as Al suggested, mine reads 5.02 V input - 0 V output...  :( 

    Contacted jDrones for support.. 

    Just wanted to share this info w/ You guys - looks like that voltage regulator is not best of the quality :/

    PS

    APM 2.5.2 here.

    PS2

    Thanks Al Lowrie ! ^^

  • My board gave me this 'No dataflash COMPASS INIT' error, must've happened mid-flight. My board is slightly different though, ver2.5.1. Any idea what to check ?3692664515?profile=original

    But more importantly, anyone got any clue as to why this happened ? I am using the power module to power the board which still works.

  • Are these wires suppose to be soldered together on the micro usb plug?

    3692648271?profile=original

    I am unable to get My APM 2.5 working. 

    I am also getting no response from GPS or movement during flight Data, Gps does work in terminal test.  It worked until I plugged in my CSRC-RX3000 Spektrum DSM2 Compatible 2.4Ghz 6-Ch Receiver.

    I would like to use My Plane APM for Way-points fun after I get it to work properly. 

    I also bought the air speed sensor, the standard 3dr GPS. I am have no need for a portable base station. I do not have telemetry. Do I need It?

    I get a blue on the gps and the board. I continue to get a disabled GPS, accelerometer, and failed to connect to  MPU6000 5 times problem.

    The first time I plugged in the APM 2.5 after loading arduplane 2.7 and "COM5"connecting @115200  it seemed to work fine. I could see my location on the map and the horizon display move.

    Any help or pictures to compare my plug soldering to. Thanks

    Thanks for everyones help, I am unsure what I need to do.

  • Is there a full hardware test that can be run on APM 2.5 from the CLI? I'd like to run a test on my new APM instead of finding issues the hard way.
  • Well i've just fix my board on 3:00 a.m. (Hong Kong time). i've find that the 3.3V power supply ic damaged, when i use a external dc supply (by agilent) instead, the board working again. so that tells me i should change the ic TPS79133 near socket GPS and socket ATx-U2. it's a small ic with 5pins ( SOT23-5 ) and it costs about 0.5$/pcs in china.

  • Tried again to troubleshoot today and no luck.. I was able to get the quad to throttle up and down but cant figure out how to fix the compass or dataflash.. Will call 3dr when they open and see what they have to say. Thanks.

This reply was deleted.

Activity

DIY Robocars via Twitter
Sunday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…