Hy all DIY UAV Builders ,

I would need your Help about APM2.0.18 / FW AC3.1.5

( First of all : I searched all around the forums to get the REAL response , and not only the same boring answer like :" look at the documentation " but allways fall on useless answer ( useless because I tested them and this doesn't works at all ) , I know the documentation as well because it's my Bible , so if you plan to answer like this you can go sleeping you won't be usefull for the comunity and obviousely for me :) )

Ref :
- APM 2.6 Board + NEO6M + POWER Cable.
- Mission Planner 1.3.31 ( just upgraded )
- APM Planner 2 ( 2.0.18 Just Upgraded )
- Arducopter 3.1.5 Firmware

What is the Problem :

I build my 3rd QuadCopter ,and get back my APM 2.6 to mount on => OK
Flew One Lipo => OK
Wanted to Download the logs for analyze after the flight ,I went immediately into APM 2.0.18 , and ... No Log at all ...
As I 'm a little paranoid , I decided to upgrade and use Mission Planner 1.3.31 , from the log tabs , clic on DL via Mavlink => KO , error messages "error while getting log list" ... no way I decided to open the CLI then Download logs ... and tadaaaa logs are here ... I donload them , and can analize ...

What is changed between my old Quadcopter and this one :

Only the frame !!! all electronic worked perfectly on previous build ... and APM from 2.0.17 to 2.0.18 (LINUX AND WINDOWS ) and Mission planner from 1.3.? ( don't remember ) to 1.3.31 ... allways working with AC 3.1.5 FW .

Questions :

1/ Why do I use the CLI to Download the Logs , while it is writtent to use MAVLink to do this instead ???
2/ Why do I use Mission Planner to do this , instead of APM2 ( cannot I only works on Linux and it worked as well before ... )
3/ Why This doesn't works with APM2 ??? ( Know ALL Bitmask and done at least 100 test
=> Setup the bitmask ,write to the board, refresh the list (OK ), disconnect the APM , PowerCycle it , fly indoor for 1 minute, power down the Quad and plug it to the computer => NO LOGS in APM2.0.18 , but in Mission Planner 1.3.31 only in the CLI ...

Anybody have some clues to fix this ( F.....G ) behaviour ???
Is there a simple checkup to know if my board is fried ?
Any thought , tip will helps My brand new Quad to works as he worked before ???

Best regards , and thanx to ALL Arducopter Team for their great Works :)

====================================
( sorry but now I'm boring and little hungry because every update of FW , or GUI makes too much problems I can't handle , I choose APM because this worked fine under Linux , like no other FC ( I only know APM ) , and just want to fly ( Video plateform essentialy ) I like electronic , Arduino , but for this project I can't spent time in debugging , cutting PCB track to fix somthing etc etc ... My goal when I purchased APM more than one year ago was to get the most reliable OPEN SOURCE FC)

APM_2.0.18-KO_1.png

Mission-planner.1.3.31-KO_1.png

Mission-planner.1.3.31-OK_1.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    upgrade your autopilot version, dataflash download over mavlink is a newer feature.

    • I just forget one detail , I tried 3.2.1 , but had too much problems with all GPS guided operations . And decided to downgrade to the last FW the Quad Flew .
      I remember that this feature worrked as well , before up then donwgraded the FW , I intialized the EEPROM , with the Arduino IDE , did the job fine .
      I managed to fly this afternoon , issue with Autotune ( didn't start ).and always the logs are accessable only via CLI .
      It sounds like : backup parameters , test upgrade to the 3.2.x release , make the mandatory setup and try ... I will see if I still have same old GPS positioning defaults .

      • 3702714064?profile=original[SOLVED] Today is the day I solved this issue .
        I follow your advise Michael , and upgrade to the 3.2.1 FW , I wish I won't have GPS issue with this FW as I had ...
        I just kept all parameters from previous Compass / Radio / FS / Switches setup and will give a try this afternoon , and will come bcak to close this thread with results :)
        Thanx .

    • Thanx mate :)
      But I did it , and tried all AC from 3 to 3.1.5 , but still have this behaviour :
      I cannot access to the logs , with APM 2.0.18 , I didn't downgrade the GUI to 2.0.17 ( the rev I used for some times and wich worked fine ).
      I looked at the source code , tried to recompile the app ( under Linux ), but no changes ... this is why I posted here , I'm autonomous , I learn all by my self , I managed many many issues before .. but for now , I don't understand what could causes this behaviour ... and more and more I suspect the hardware ... it would be sad to "burn" a board while you get it back from a Quad to put it on another ... I never had this issue before ... I take care ( antistatic link to the ground of my desk etc etc )...
      So if someone can tell me what I can test on the board to confirm it is defectuous , he's Welcome :)
      For now I'm no confident enough to fly with my Quad ...

This reply was deleted.

Activity

DIY Robocars via Twitter
Sunday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…