I'm using the a Pixhawk loaded with APM:Rover 2.5 and using APM Planner v2 as my GCS. I am attempting to drive a traxxas slash but I'm running into trouble getting connected. My pixhawk is connected over UDP and Planner can communicate with the Pixhawk no problem. I see pitch/altitude/direction/etc.

APM Planner can also see my usb gamepad in the Joystick menu however it does not seem to detect it in the 'Radio Calibration' menu. When I hit "calibrate" I just get "Radio Control is not active or turned on".

I'm trying to just get steering/throttle output working with a usb controller over udp at a basic level.  I've tried MAVProxy but the setup radio prompt spits back gibberish. I would eventuall also like to test this USB connection with apm:copter.

I'm running Ubuntu 14.04. Any advice?

Views: 809

Reply to This

Replies to This Discussion

The radio calibration needs an RC Control. You have to manually set the RC limits

So with:

  • Rover in Manual mode
  • APM Planner connected via udp
  • RCX_MIN/MAX/TRIM set to 1000/2000/1500 respectively
  • USB controller detected in the joystick widget on APM planner

I should be good to go? I'll give that a try next but I haven't had any luck getting a motor to spin. Even "rc 1 1800" in MAVProxy isn't getting anything to move.  I"m also wondering if the lack of GPS is an issue. I'm doing this indoors at this point. The main blue LED on the pixhawk is solid, no blinking. But when I connect via dronekit I still get 'false' from the vehicle.is_armable() command. 

Thanks for the quick reply.

Try turning of the ARMING_CHECKS paramter

But my advice would be to look at the Rover code and see what it's checking. 

APM Planner won't calibrate the RC has it doesn't see any raw RC channel input values since you are only using a Joystick

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service