Recently purchased a QuadCopter from uDrones and been having fun putting it together and getting things to work.  uDrones has been very helpful in answering all my silly and stupid questions and I'm grateful for the support.  Just before the 4th of July while trying to calibrate my ESC I could not communicate via USB with my APM2.  I sent uDrone an e-mail, but have not heard back.  My guess is maybe they are vacation for the holiday.  So I figured I'd post a request here and see if anyone might be able to help.


Here's what I've done so far in trying to fix this.

I've uninstalled everything and reinstalled, I've even tried another computer.  When I plug in the USB cable it sees the APM2 in Device Manager and when I try to connect at 115200 baud rate it just times out.  I can see blue lights flashing on the board, but no communication. I get the message no heartbeat found.

I even went so far as to install "arduino.exe" and download a small bit of code that flashes the board to test if I can communicate via USB and it worked.  Yet when I try to run APM Planner and connect I just get a timeout. 

I then tried to flash the Atmega32U2 (PPM encoder) through USB by following these instructions (http://code.google.com/p/ardupilot-mega/wiki/APM2Encoder).  But it failed at step 5, it gave me an error message "AlLIBUsbDfu.dll not found." 

I went to Atmel web site the makers of the FLIP program that allows you to flash the Atega32U2.  There was post, that said I needed to install their USB driver to make FLIP work.  Their USB drivers were located in the FLIP program folder inside the USB folder.  After a couple attempts I managed to successfully install their driver and then I had a bit of a problem getting the HEX file downloaded.  I tried all the files located here (http://code.google.com/p/ardupilot-mega/source/browse/#git%2FTools%...).  I must not be downloading them right, because none of them worked.  I ended up using the HEX file from here (http://code.google.com/p/ardupilot-mega/downloads/detail?name=ArduP...).  Not sure if the version v2.2.65 is the correct file to use.  The long and short of it, I was able to flash PPM encoder successfully. 

Unfortunately this did not fix my problem.  I tired uninstalling and reinstalling the APM Planner again, but I still can't communicate with my APM2 via the APM Planner.

Does anybody have any ideas on how I can fix this?

Thanks

Richard

Views: 10260

Reply to This

Replies to This Discussion

What a timely post. I am sitting here with the same issue. Please let me know the resolution. Thanks

I had what looked like a similar problem but I haven't found a solution.

I did find that I could get it to work on another computer though and it started working again on my original computer.

I got the feeling that if I powered the board externally or disconnecting the receiver and ESC's, I didn't have the problem. So it may be a problem with the USB power supply limit. If I continue to have this problem off and on I will try purchasing a USB hub with an external power supply.

Stupidity Warning: I still have a couple of deep cuts on my fingers where the quad started up while downloading some log files. So I don't recommend doing this through a ESC (yes obvious and silly thing to do).

I had the same problem yesterday.  Turned out that I needed to set the COM port to COM6.  Look under ports in the device manager window to see which CPM port your APM is listed.

Sorry to hear you got hurt.

I've actually pulled my APM2 off my QuadCopter and removed externally power or ESC from the equation.  I've also tried accessing my APM2 connected with my Lio battery.  I also change my com port to a different com port number and I've turned on xon/xoff flow control.  I've also used another real PC Computer, no VMware or Macintosh and still no go. 

I'm coming to believe what's wrong in not PC related, but APM2 related, or more importantly something within a code, since I was able to communicate with the APM2 with 2 other USB related programs.  Yet, my APM Planner software still times out.  I'm going to reach out to uDrone again and see if they have any options that might help me get past this problem.  I really bums me out to think that I've never even gotten my QuadCopter into the air.

Thanks for the feedback and I've update if I hear anything.  One way or another.

Richard

Richard: Have you loaded the ArduCopter firmware onto the board? Needless to say, you can't communicate via the Mission Planner until there's some software running on APM.

Have you tried pressing the "Reset" button on the APM?

I reloaded the driver http://www.ftdichip.com/Drivers/VCP.htm followed their instructions for it and everything communicates like it should. I think I yelled Eureka when COM4 showed up in APM. Good Luck!

I originally was communicating with the APM, was trying to calibrate, when it stopped communicating. I would love to just clear everything and start fresh if possible.
I did press the reset button, but it had no affect.
I am communicating via the USB, I'm just not able to talk to the APM from the APM Planner, it times out. When I plug in my APM into my USB port, COM4 appears and when I tell APM Planner to connect I get lights flashing on the APM, but it times out and tells me no heartbeats. Very frustrating.

Richard: I'll ask again: did you load firmware from the MP first? You can't connect until you do that. 

Thank you

Can I say I feel stupid.

I had downloaded the firmware before and did not think I'd needed to download again.

Guess I was wrong.  Normally I don't make mistakes, I thought I did once, but I was mistaken. LOL.


Thank you again.

Richard

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service