ArduCopter 2.6 released!

Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!


Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.


The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.


Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]


Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]


PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).


Happy flying!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I found some Bug with the Okto V firmware. The roll Gyro have to be reversed. Can somebody check this? With the normal Okto all ok.

  • someone can tell me about the apm when no red led. today went out to fly and not a moment's rekindled, still flew well but did not fix the tail. Later I now turn my apm and the red LED turned on. I need to know that did not light the red LED that is what happens?

  • Question. If I activate an AP mission in MP to the APM and say one of the way points is outside the range of both the Radio TX and Telemetry, will it still maintain the mission until completion?  I take it the mission is written to the APM board so assume it can fly the mission without the TX? 

  • I got to do some flying tonight with 2.6 on my Hexcopter.  It was flying fine and yaw control worked fine, but after a 5 minute flight, all of my clockwise motors were very hot to the touch.  The counter-clockwise motors were nice and cool.    I didn't do any fancy flying, stayed in stableized mode and, except for a few passes, mostly just hovered.  I don't know what else it could be other than an uneven distribution of motor power to fly.


    Any thoughts?  Code issue?


    Thank you.

  • Noticing some intermittent mag spikes in logs. Other than that readings seem to be fine.  All wires twisted.  Using non-ferrous metal screws on frame.  Any thoughts?3692450911?profile=original

  • i don't get the battery reading setup on this software. It suggests to subtract 0.3v from the power supply. I have a 5v switching regulator to power the APM1 board and it measures 5v output so Ive set field 1 to 4.7 as advised.  I measured the battery just before connecting it and it reads 11.87v on the multimeter, yet on the main screen on MP it shows a reading of 10.63v . I hovered around in my lounge room until the battery was reading 9.61v. Now when I plugged this battery into my charger its reading 11.23v and no where near flat.  I'm using the system that connects to the batteries balancing plug that's wired into the APM1. Do I really need to still subtract eh 0.3v using this? Why am I not getting a more accurate reading?  

  • Compass noise solution (dji style):


    Here the results:

    • With compass attached to APM1:3692450757?profile=original
    • With compass attached to dji mount:3692450821?profile=original

    Noise is gone! (But I still have yaw problems, it doesn't hold its position, I suppose I need more PID adjusting).

    I've used shielded cable (shield connected to GND only on APM1 end).

  • I'm using Planner 1.1.93 mav 1.0 and with the new config screens I'm not sure about my loiter or yaw settings. First I noticed in section ArduCopter Config that my loiter P=0, I=0 and IMAX 30 but when I go to other section ArduCopter Pids I see other settings for loiter which are 2.4 | .08 | .4 | IMAX 30.

    And regarding YAW, for the first time I tried to take off in ACRO mode to try and tune that and it quickly does a fast yaw even though it is very good in stable mode. SO I checked my Rate Yaw and it's .13 | .0 | .002 | IMAX 50

    and in stabilize Yaw it is 8 | .01 | IMAX 8

    Is this right or is my acro spin caused by something else? I would like to tune acro but the YAW is out of control causing the quad to spin CW. In stable it is ok and YAW is solid so I'm thinking some PID is wrong but the only settings I've changed is stable mode PIDs.

  • I have quite a bit more successful flights with my heavy hexa using V2.6.  Stabilize is awesome.   However, I am still getting some wobbles on faster descents.  Anyone having success tuning that out?  I know it's a difficult issue due to descending in your own prop wash.

    My thought is that it's more of a stab_P/D parameter adjustment since it's trying to hold it's level while descending.  Though I am sure it's a combo of rate and stab parameters.  It's curious to me that v2.6 stock PIDs no longer have any stab_D component, when we used to have .15 or .12. 

  • Hello

    I always have the latest firmware V 2.6 Arducopter Octa V
    on the APM two charged and has repeatedly version V 2.6 octa X.
    All engines have been tested individually, it is the version octa X.

    Doing something wrong or is there a software / programming error?

    Big thanks for quick help

    Klaus -Germany-

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21