During set up and bench test I have successfully set Flight Modes and Throttle Failsafe and all checked out in MP.  I then connected  the flight pack for a motor on test.  With GPS locked the mode set to manual half  throttle was set and RTL mode switched in.  The mode changed on MP but the throttle cut immediately. I then switched back to manual and the throttle came back up.  I then tried the failsafe function by switching off the TX with the throttle at half.  The MP showed circle as it should but the throttle cut again.  Obviously this would be a disaster during a real flight especially  as I plan to use this plane for FPV.  Am i missing a setting somewhere and if so where?

Views: 1390

Reply to This

Replies to This Discussion

I'm having a similar problem, but mine works fine on the bench. It's only once I take it out on the field that the throttle cuts. Are you using an airspeed sensor? I've read other discussions about that causing problems in 2.7x. Try disabling that? It didn't work for me and I'm still stuck, so let me know if you figure something out!
Patrick

I think it's because of Aprduplane's safety feature - the auto pilot will not start up the motor if the plane has not moved (i.e. flying). This is to prevent carnage on the bench if one accidentally switch modes..

Patrick I am not using an airspeed sensor.

Hein It may be so but unlike arducopter you dont have to arm the FLIGHT Controller and I can run the motor on the bench in manual mode.  I guess the only way to test it is to fly it.

Hein is right.
RTL, Circle, Loiter, and Auto won't run the motor unless the aircraft is more than 10m away from the point it turned on, or undergoing TKOFF_THR_MINACC m/s of acceleration.

OK that makes sense, just the same in Arducopter when I think about it.I guess its a test flight for me then.  On a different subject: can you point me towards the pre configured wicki files and how to load them?

https://code.google.com/p/ardupilot-mega/wiki/ConfigFiles

Go into configuration/tuning, Arduplane PIDs, and load parameters. Then choose the file you downloaded

Thanks.  Just found this nugget so I will need to check this in my settings

Long failsafe action (ArduPlane:FS_LONG_ACTN)

 regardless of the FS_LONG_ACTN setting. If FS_LONG_ACTN is set to 2 then instead of using RTL it will enter a FBWA glide with zero throttle.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service