ArduPlane won't arm engine

Hi all,

I am new to the ArduPlane. Until now I just had experience with the ArduCopter.

I got myself an Easystar 2, installed APM 1 with the current version 2.30 and configured it. That worked fine, even the stabilize mode & movements on the ground also works good. But I am unable to get the ESC initialized, so the motor won't power up.The APM has corretly being initialized and I connected it wirelessly. I can control my servos via my RC.

I have just one ESC which is directly connected to the APM. When I then additionally connect APM via USB then the ESC finishes the initialization procedure.

Do you have any idea what I am doing wrong here? Do I need an additional power source?

Thank you for a small hint,

Oliver

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Same Problem here :(

    resetting the APM works but sucks.. i tried setting the throttle to above 0 and only moving it down after start up but doesn't work, i was thinking of connecting a UBEC to the USB cable can any 1 tell me how i could accomplish this as it would then make it possible to put the cable in close the plane up ,put the battery in, remove USB cable and voila :D

    Thanks
    W

  • i have similar problem. motor dont arm.. but only when board is powered through USB. interestingly, what i have noticed is that motor will arm when i disconnect gps. any solutions, thanks??

  • Hi, I had same issue time ago with my octo with HiModel Professional 40A ESCs.

    The problem is not APM software related but the ESCs initializing before the APM board ends booting up so no valid signal are going out the ESC signal pins of the APM. Some ESC seem sensitive and other not.

    All I have to do to avoid this misbehaviour is unplug the ESC outputs from the APM then connect the batteries, wait while the APM board boots up and then plug the ESC again.

    Its important to say that I only have to disconnect the signal cables of the ESCs which I've integrated in a single connector.

    For my setup I have done a ESC distribution board where the ESCs connect and get power and signal. The power came straight from the BEC and signal cables are connected from this board to the APM board with a single 8x1 connector making very easy the work.

    3692525879?profile=originalIt's very important not to have the props fitted while performing this procedure if the ESCs are connected to battery  because they could spin and wound somebody.

  • mine also have this problem

    everytime first boot ESC cannot arm. i have to pull out the ess signal/bec power several times and then i hear the arming melody (motor  can start)


    my arduplane 2.65

  • hi everybody

    i am also new to ardupilot .

    i have a arudupilot 2.5 , like many others in my quad frame all worked well.

    but now in my easystar the only way to get the motor to arm is to plug the usb in to laptop

    at the and have flight pack connected at the same time .

    i cant remember the make of my esc as its buried in the fuz..

    any ideas ?

    cheers

  • Do we know exactly WHY these ESCs aren't arming right?

    These are very common ESCs, I'd certainly be willing to put some effort into fixing the issue with them.

  • I'm running into the same problem here.  Turnigy 40A Plush.

    Unfortunately, my reset button does not appear to work either.  If I leave the battery plugged in and unplug and replug the signal cable, it starts up correctly.

  • Hi,

    got the exact same behaviour with a very cheap suppo esc (hobbywing compatible) and my apm2 (last batch). First comes the 3 sounds, then nothing. Interesting is that after 2 resets with the resetbutton on the apm2 the rest of the init routine follows, 3 tones (for the 3s battery) and the readytone. Tested 5 times or more everytime the same behaviour. When i first powered the apm2 over usb and connect then the battery the esc starts right through normal. If i powered it first with the battery i got the behaviour described above.

    As long as it takes only 2 resets to get it running its not so frustrating, but it would be fine if it starts normal ;)

  • Does anyone still have this problem.

    When the USB cable is connected the esc arms fine.

    Without the USB connected only get initial 3 beeps.

    It does not complete the initialization sequence without the USB connected first.

  • Hello Oliver, i have the same problem, is exactly what you described.

    I have the APM 1.4 with the 2.33 code.

    I tried several different receivers and ESC , and the problem persists.

    In the end you could fix it?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Tuesday
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Tuesday
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…