T3

Compassmot issues using CLI and MP

My setup:
TBS Disco with a Pixhawk
3DR GPS/compass combo
3DR Power Module running a 4S system
V1 3DR Air telemetry module connected to Telem1
Teensy 3.1 connected to Telem2 going to FrSky X8R for telemetry to Taranis
Running DJI 920kV motors and 30A OPTO ESCs
Pixhawk is running 3.1.5
Mission Planner is 1.3.7

I followed the compassmot instructions in the manual and connected the battery after I turned on the transmitter, then connected via USB to the laptop. On Mission Planner, I chose the correct COM port, clicked Terminal, set to Pixhawk, hit Connect, and it won't connect upon reboot. It just spits out jumbled characters. If I arm, then it'll show that text and then continue on with garbled text.
I found online that there is a way to do compassmot via the GUI so I tried that method and couldn't get any data to show there either. I would be connected via USB at 115200, made sure the 3DR power module was set properly, and when I would click start on the Motor/Compass tab under Initial Setup, it wouldn't show anything until I armed. Once armed, it would show the barometer was calibrated but nothing else. I could throttle up with the props on and it wouldn't show a thing.
I have the props rotated and flipped, the quad taped down, USB cable taped down, and took all precautions as well.

I'm completely stumped now. Any ideas on what the problem could be? I've been battling this and AutoTune but have another idea for AutoTune when I get a chance to go fly again.

I just want to get this initial setup all taken care of and then move on to flying since everything else is set!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • T3

    Okay, I gave this a try again today. This time, I made sure Telem 1 and 2 were both disconnected and I couldn't connect to Mission Planner period! I assume this was some other Windows issues so I rebooted the computer and then tried to connect and I was able to get it running via CLI. I couldn't do it via the normal GUI planner but it didn't matter. Only 2% interference it looks like so I was happy to see that!

This reply was deleted.

Activity

DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
RT @_JonMyer: 🏎 We need your help in naming my #AWS DeepRacer Underground Track 🏎 @davidfsmith's track is going to be referred to as 𝗔π—ͺ𝗦 𝗗…
Thursday
DIY Robocars via Twitter
RT @gclue_akira: δ»•δΊ‹γ‚‚γŠγ‚γ£γŸγ—γ€ι›»θ„³εŒ–γ«γ¨γ‚‰γ„γ€€#γƒžγƒͺγ‚ͺγ‚«γƒΌγƒˆγƒγƒƒγ‚― https://t.co/4IU90hCLgm
Thursday
DIY Robocars via Twitter
This is the hashtag to follow all the people in Japan who are hacking the new Nintendo Mario Kart with the real AR… https://twitter.com/i/web/status/1319281354664677376
Thursday
DIY Robocars via Twitter
RT @gclue_akira: @chr1sa @diyrobocars jupyter mario https://t.co/P0oHdjlCRq
Thursday
DIY Robocars via Twitter
RT @_JonMyer: 🚨Our 1st AWS DeepRacer Community Race is Underway on http://twitch.tv/aws 🚨 Join us to find out which member of your commu…
Oct 20
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
RT @BackyardRobotcs: After an admittedly long wait, the new Tinymovr R3.3 motor controller is now available https://tinymovr.com πŸ₯³
Oct 19
DIY Robocars via Twitter
RT @_JonMyer: 🏎 1 hr left before the #AWS #DeepRacer Community 🏎 Top 5 Race tomorrow LIVE on Twitch 1st Place = $50 Amazon GC or AWS Credit…
Oct 19
DIY Robocars via Twitter
Oct 16
DIY Robocars via Twitter
Oct 15
DIY Robocars via Twitter
Oct 14
DIY Robocars via Twitter
RT @davidfsmith: Race virtually with The AWS DeepRacer Community Race and then join us on the track to see how your times compare on the ph…
Oct 14
DIY Robocars via Twitter
Oct 14
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Robocars via Twitter
RT @breadcentric: It's now!
Oct 13
More…