Replies

  • hey i tried that but it did not work

    Tarot gimbal setup with the APM 2.6

    So guys i have been trying to setup the tarot gimbal with my APM 2.6 but it dose not work.  have been doing what some of the people have said but it still did work. If you guys could help me out that would be nice. Anything would help pictures and other things. Thanks 
  • Hey all,

    I'm having an issue with my Tarot T-2D (firmware v1.5) and connecting it with my APM 2.5 (firmware 3.1.2) where I am able to "successfully" connect the gimbal (blue light blinks as if successfully connected to APM), but I have no tilt control over channel 6. I can see that the signal from the pot on my TX is coming in correctly, but nothing happens. 

    I've followed the wiki and the suggestions on this post. Matheiu, have you had any luck with this issue?

    • Update:

      I've been playing around with the connections between the APM and the gimbal and it looks like the APM is sending the gimbal some strange signals.

      Right now, the gimbal will twitch and tilt on its own. As a test, I switched the signal wire connection from the T signal pin to the R signal pin. Oddly enough, the gimbal still twitches, but to the roll axis. I've updated the APM to firmware version 3.1.5 with no change in enabling manual control.

      On a side note, has anyone run into issues where the APM will reboot itself when the gimbal is detected? My quad seems to go through the ESC check and APM boot beeps twice.

      • Update to the update:

        Got it working in CH10 and configuring using the Windows Mission Planner application. I also checked the Reverse box so the min position of the Pot keeps it at 0 degrees.

        • Ryan,

          Did you figure out what caused the twitching? Was CH10 configured as something else, causing APM to send strange signals the gimbal?

          • Hey Nick,


            I believe it was just something feeding into the original CH11 connection. It's also possible that there's something wrong with my board. There's no reason why it wouldn't have worked in CH11 over CH10. I did find that I blew a regulator during the process of trying to get the gimbal working which may have caused some of the issues. You may want to check yours out to see if you may be running into the same.

            https://www.youtube.com/watch?v=1q6jjha5rgU

  • Hi Patrick, Scott, Raph, Mitchell,

    I guess I'm facing the same issue Patrick was...

    But I'm less smart, so I could'nt figure out how to control the tilt with the gimbal wired to the Pixhawk (in my case, but I'm pretty sure the wiring must be similar to the APM).

    Here is my cry for help I recently posted without any luck to get a solution:

    http://diydrones.com/forum/topics/tarot-2d-gimbal-and-pixhawk-tilt-...

    Any help would be tremendously appreciated,

    Cheers,

    Mathieu

    • Hi Mathieu,

      I feel your pain. I have not wired this up for Pixhawk yet, so I can only speculate. It sounds like your gimbal is working (good), but not receiving the signal from the pixhawk.

      You should only need 2 wires (ground and signal) that go from Pixhawk to the Gimbal board. Check and double check these connections...break out a digital multimeter and make sure the wires are conducting properly. Once you're 100% the wires are connected properly...I'd double check your settings in the software and make sure they have been updated on the vehicle, not just on your computer. Make sure you are using the right knob (should be clear in the radio calibration screen which one is channel 6). Run a radio calibration, turn the knob to both extremes.

      From there I would play with the order in which you power things on. I'd turn the RC controller on first, then power on your vehicle and see what happens. If the gimbal initializes but the pitch control doesn't work, then its not getting a signal. If it starts freaking or doing something erratic, it is getting a signal, but the wrong one.

      Hope that helps...

      cheers

      -patrick

      • Hi Patrick,

        Thank you so much for taking the time to answer.

        I double checked in the tarot firmware update tool and made sure that it is on "stick position" mode (the option just above the "open com port" button).

        Now if don't wire the gimbal to the Pixhawk, it stabilizes as itshould, and the news is that when I connect the 2 cables (ground + signal), the camera now faces down, but no reponse when I turn the knob on the RC.

        I'm thinking there might be something wrong in the mixer setting in the RC.

        Or I'm wondering if there's any extra step that I'm missing on the Gimbal configuration page in mission planner: I change all the parameters as required on the copter wiki (channels,...) but there's no "update Pixhawk" or firmware button.

        I'm connected through the telemetry link.

        Any idea how I can be sure that the new settings are taken into account by the pixhawk?

        Thanks again for your kind help.

        Cheers,

        Mathieu

        • Try connecting via USB instead of telemetry link to write the parameters to Pixhawk. I don't think this is it, but I remember with APM 2.6 there were some parameters that had to be updated via USB.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13, 2022
More…