Developer

Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Developer

        Hi Fnoop,

        Your roll axis is oscillating. I would suggest going back to stock defaults for your pids then starting again from there.

        • Hey Leonard

          Turns out the problem was that I changed mounting the pixhawk to the hobbyking orange foam suggested on the wiki vibration page.  The altitude control and roll oscillation was linked to the rate P - there was a tiny narrow window of rate P where the copter was stable, and despite many attempts I could only get the odd single twitch out of autotune.  I changed back to the gimbal-rubber-ball-type mounting:

           http://www.banggood.com/APM2_5-2_6-KK-MWC-Glass-Fiber-Shock-Absorbe...

          Then it was more stable and autotune completed first time on all three axes on a single battery, and I have a much wider window of rate P where it's stable.

          The orange foam is very 'squishy', it moves around a lot, whereas the ball plates are a lot less forgiving.  Guess for my setup it just works better.  Tarot 650 quad with arms extended to 800, 14" cheapie CF props.

          Quite a big quad now but handles like it's on rails, 3.3-rc11 is awesome, great work guys.

  • Just loaded 3.3-rc11 on Iris+ with HK Pixhawk. Now my radio controller only partly works? Everything else works fine, I mean, telemetry over the USB radio hooked into MacBook gives back sensible data, and GPS, compasses, accelerometers working in APM.

    I did try changing the MavLink ID at one point, but I changed it back.

    When I turn on the RC, the Pixhawk gives the sad double beep, followed by the happy double beep. Flicking any of the channel switches causes a small beep, and I'm able to arm and disarm, but I get no data on my controller.

    • Developer

      Dale,

      Can you confirm which of the sounds you're hearing?  Is it the "Start up Failed" message?  Perhaps it's the "New IO board firmware found" but with two sad tones at the end?  If that's the case then the I/O board's firmware (the Pixhawk has two CPUs) hasn't been loaded for some reason.  If you have a safety switch you can try to force it to load by holding down the safety switch as the board is powered on.

      • The sound was like the "Failed To Arm" sound, followed by something like "New IO board firmware loaded successfully", except with only two notes, and in a major key.

        It's a moot point now though, because even though I've downgraded to 3.2.1, I'm still unable to connect completely. I can't connect over MacLink with the little USB transceiver, and get telemetry in APM, but my FrSky DJT radio only turns the receiver light green. If I'm in APM on Calibrate Radio, and I turn my transmitter on, all the calibration items clear, and none of them respond when I fiddle with the sticks or switches. Tried rebinding and all that of course.

        I wonder what the heck I did to make that happen?

      • When the transmitter was turned on, it was the same sound as when you're trying to arm but the safety switch hasn't been pushed, followed by two higher tones going up when the transmitter completes its startup.

        However, its worse now. I tried rebinding the receiver and transmitter, and now I get almost nothing. This is an Iris+ with FS-TH9X transmitter and a D4R-II receiver. I took it through rebinding, got the red and green lights going on the D4R-II first, then on the FS-TH9X, then powered down both and restarted. Now the receiver gets a green light when the transmitter is turned on, but the transmitter stays with red and green. There's no connection to the transmitter when I try the radio calibration screen in APM. However, when I turn on the Iris+, the transmitter makes a little beep.

        So there's some connection going on, but it's minimal. It's late now, tomorrow I'll try moving it back to 3.2.1 and see if that fixes things. For all I know it could be unrelated to 3.3. Connections from APM work fine, both through USB and through MavLink.

  • Hi all,

    Trying to load Rc11 (and RC10 for that matter) with APM Planner onto my pixhawk (non 3DR version) I haven't had any issues loading firmware in the past but now I can't get past the status showing "Requesting CoA" ...It won't load stable also. I tried QGroundControl and I was able to load firmware on using that. Unfortunately I had to download the source then do a custom load. I have Has anyone had any issues with this? Tips/advice?

    Cheers,

    Jeremy

  • Does anyone knows if the receiver failsafe option will be back on AC 3.3 version?

    • What specifically are you referring to regarding receiver failsafe? I have personally tested RC failsafe on 3.3 rc 10 by turning off the tx, resulting in a correct RTL. Simply assumes the tx/rx failsafe is configured for no pulses, then that the failsafe throttle setting is somewhere in between the normal idle and the absolute minimum when the tx is turned off.

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Thursday
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…