Developer

Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • That's mean if the copter decides to Land for failsafe and you switch to another mode the copter abort land and fly in that mode?

        • Developer

          Cala,

          Yes, that's right.  It pretty much never ignores the pilot's requests to change the flight mode unless it's impossible to enter that flight mode due to poor GPS.

          • the copter responds to switching to stabilize in overriding the Landing sequence now if i use the flight mode switch on taranis. but when i use a toggle switch which i programmed to override the ch5 pwm, it does not work.. no switching from landing to stabilize. at least now i can confirm that the overriding still works 

          • Thank's

  • I was doing some test flying the other day to check out the Do_mount_ command.  It flew very well both in Auto and Loiter.  I landed and switched out the battery.  On restart I got the dreaded 'Inconsistent compasses" message.  Restarted several times with no change.

    What could have caused this?  This is the first time time in over a year of flying this setup that I have seen this.

    Do I recalibrate  and move on hoping it doesn't repeat?  Any field fix?

    • So this is supposed to only happen when the compasses disagree by a large margin. This happens to me when both compasses get uneven interference - either because MOTCT is inappropriately applied (because my power module gives bogus readings on USB power) or when I mount my battery with the lead "exit" end close to the compass (which surprisingly generates large amounts of interference). Not sure if either of these is your problem, but I'll throw it out there anyway :)

      • I have the same issue with the incorrect PM reading when USB is connected.  It does not affect the in flight reading as long as calibration is done after arming the safety switch but I think this may be causing some users problems since they may not be aware of the issue and calibrate using USB in the preferably disarmed state.  I have seen several reports not of this other than my own so I think this is a consistent issue.  Will put in bug report.

      • The compass will definitely be affected by a main battery power lead passing close to it.  This will generate a magnetic field whenever there is current and the close proximity will affect the field around the compass.  Small differences in placement of the wires could cause varied magnetic disturbances which the compass MOT calibration for current effects would not be able to account for.  The magnetic field variation versus current needs to be a fixed curve and the varying placement of the wire in close proximity to the compass would probably produce a different effect each time you put a battery on.

      • Randy and Andy,

        I have launched form this site many times with no previous issue and none on the first flight.

        Thanks for the replies.  I did try both moving and rotating with no change after disconnecting and reconnecting the battery several times.

        The battery mounting has not changed in the year I have been flying this build.

        I guess I will try a re-calibration and then the disable internal if that doesn't work. 

        Would still like to understand why the change in a 10 minute period at the same site with no other changes.

    • Developer

      Greg,

      The interference could be because of some interference at the launch site (like a metal pipe in the ground) so you could try moving the copter or rotating it a bit.  Another alternative is to disable the internal compass by setting COMPASS_USE2 to "0".  That turns off the consistency check.

This reply was deleted.

Activity

Mike Whitney liked Mike Whitney's profile
Jul 19
DIY Robocars via Twitter
Jul 2
DIY Robocars via Twitter
Jun 26
Abdulatif Tlaib liked Ryan's profile
Jun 24
DIY Robocars via Twitter
RT @SmallpixelCar: First time at @wsraceways. After tuning @HokuyoUsa lidar signal and camera sensor on @NVIDIAEmbedded, my car was able to…
Jun 20
DIY Robocars via Twitter
RT @breadcentric: The handy bit about racing with self-driving cars is that one can type while the car is racing. Report from #AWSDeepRacer…
Jun 18
DIY Robocars via Twitter
RT @chr1sa: Our Bay Area @DIYRobocars meetup is now at 2,700 members. Next in-person events (in Oakland) are training day on July 17 and…
Jun 18
DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
Jun 10
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
More…