Developer

Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

        • I think Randy mentioned that if you had a 3 position switch, middlepoint was some sort

          of auto, but what it do i have no clue. Havent tried yet

  • Hi

    ublox GPS is not detected when i tried 3.3 rc5 on px4fmu+px4io. Works ok on ac3.2.1 though.

    used 3dr GPS + compass and quanum GPS + compass both not detected on 3.3 rc5 but detected on version 3.2.1

  • Yesterday I flashed the V3.3-rc5 to my PixHawk hexacopter, but now I can't get to download the log anymore.

    In the MissionPlanners (latest version 1.3.28) CLI it only gives "mumbo jumbo".

    In the beginning it says:

    Waiting for reboot

    Opened com port

    3Initialising APM...5? (NO mention of Arducopter 3.3-rc5)

    Then the mumbo jumbo starts.....

    What am i doing wrong?

    btw Arducopter V3.2.1 gave no problems. 

    • Paul,

      Download the Log via Mission Planner Terminal does not work anymoe from 3.2 and upwards.

      In Mission Planner go to FLIGHT DATA and sellect "DataFlash Logs" under the HUD screen.

      Than click "Download DataFlash Log Via Mavlink".

      Hope this helps.

      • Geert is correct but I didn't understand how Paul said " Arducopter V3.2.1 gave no problems"!..

        The last release version that used the terminal to download the logs were 3.1.5. Terminal removed after that.

        AC 3.2.1 should be same as AC 3.3 rc5 as far as the log download is concern.

  • anyone tried out storm32 and tower at same time ?

    my tower goes crazy ...

    https://youtu.be/KzHd5ndXE84

    • It's probably because tower is picking up all the mavlink messages from the storm32 and not filtering them out.  If tower has an option for specifying a particular system id and component id then try setting them to 1 and 1, if not then it probably needs a bug/issue filed against it.

      I had the same problem with teensy telemetry and had to recode it to only listen to mavlink messages from a specific system/component id.

  • In the full parameters list the options for setting serial 4 protocol and baud are missing even though the second GPS parameters are included. When will the serial 4/5 parameters be added back to enable secondary GPS module use? Or is there another way to enable this that I am unaware of?

    A second GPS is critical for UAV Outback Challenge operations, especially on small copter frames where RF separation is difficult.

    Regards

    JB

  • Autotune 3.3 rc5: frame x8 motor U5  propellers 16"+17" weight 9 kg (4 autotune, 4 different results)3702016681?profile=original

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…