Has any one installed an external magnetometer to an APM 2.5 and if so, how do you disable the on board magnetometer?

Views: 831

Reply to This

Replies to This Discussion

I figured it out and wrote up a brief how-to in the last post in this thread:


Let me know i you have any questions.

Lloyd: That was a brilliant tutorial! I've added it to the manual here

You're great at explanations. Would you like to join the Documentation Team? I'd be happy to give you wiki edit access. Please just PM me and we can set it up. 

Many thanks!

Thank you Lloyd, You have been very helpfull. I have done most of what you explained but the cutting of the jumper trace. This jumper trace already comes cut as default or are my eyes getting weaker? I actually thought that this trace would have to be connected by a blob of solder??

Frank - you have to cut the trace.  I received the picture and hint at what do from 3DR customer service.

Cutting the trace cuts the SDA line, which means the magnetometer cannot be selected.  So you have to cut it.  I know its hard to see, but I just bore down on the knife while cutting to penetrate the board a little.

Chris - I see that you edited my text a bit.  Nice job.  And nice job loading it onto the wiki.  You must be a wiki editing animal.  I'll PM you.  You know, its much easier to describe things in forum threads.  In the Arducopter document, it has to be very close to accurate .....just kidding..   I'll help where I can.

Hi Lloyd,

I've installed an external magnetometer on my quadcopter using your manual, but I'm not entirely sure if it's working like it should.

The manual states that it's required to cut a small jumper trace on my APM 2.5 main board. I tried to do this, but am not sure if applied enough force. Is there a way to use the MP software to establish if I rendered the onboard compass inert?

Best regards,

Jan Willem

The Netherlands

Hi Jan,

I know of three tests.

First - take an ohmmeter reading between the two pads that you cut the trace between.  If you cut the trace, you will see an ohm reading of much more than 0 ohms - like many thousand or even millions of ohms.  You will see 0 ( or a few ohms depending on your ohmmeter calibration) if the trace is still intact.  If you don't have a volt-ohmmeter, I would by one.  They are very handy and can be very low cost.

Second, I would check if the on-board compass is still working without an external compass connected.  So with the external compass disconnected, go into the CLI and type "test" and then "compass".  Rotate the APM 2.5 and if the first number, which is the compass reading, changes with APM direction, then the trace is still connected. Take a magnifying glass and look real carefully at the trace.    If the number does not change as you change the APM's direction, then it must be cut.

The final test is to connect the external compass to the APM 2.5, go into the CLI and  re-run t"test" and then "compass".  The first number is the magnetic direction.  It should correspond to the direction the external compass is pointing.  0 for north, 90 for west, 180 for south and 270 for west.   If the reading corresponds to those numbers, then it it working.  I suppose if the readings sort-of, kind-of reads the right direction, or the reading doesn't change, then you might still have the trace intact (you're getting readings from both compasses).

Let me know what you find out. 

Hi Lloyd,

The test result is somewhat unexpected.

First I checked with my multimeter. There is an infinite resistance over the pads. So in theory that means the trace is cut.

Second I checked in CLI with the on-board compass. This gave back a nice heading. Looking in the flight data screen the compass behaved like it should.

So what can we learn from this? I put my APM board along two sides of a book, so I got an angle of exactly 90 degrees. This is the difference in angle the board returned.

I guess I have to cut deeper. Is there a risk of damaging something underneath the line or is the PCB only one layer thick at this spot?

Best regards,

Jan Willem

ummm.  I would NOT cut the trace deeper - who knows what damage you could do.  Especially if the ohmmeter shows lots more than 0 ohms.  Let me think about it and get back to you.

Perhaps someone else has an Idea.  I wonder if you cut the right trace between two jumper pads?


I do not understand what you mean by putting the APM board along two sides of a book. 

If you point the APM board (input pins forward) toward North, do you see 0 (or thereabouts) on the CLI?  If you then point the APM west, do you see 270?  and 180 when point south and 90 when pointed east?

Hi Lloyd,

I did what you asked. I pointed my APM board North, started the CLI and tested my compass. The CLI returns the message 'not healthy'. I repeated this a couple of times.

Then I checked the Flight Data screen. There the yaw and heading both return values around 0 degrees. When turning the board east they return values around 90 degrees. Exactly what I would expect.

What I don't understand is that the CLI returns 'not healthy' and the Flight Data screen returns the right values.

Could you do a test for me? What does your board return when you disconnect your external compass?

Attached to this message is a picture of my APM 2.5 board. The red circle indicates the place I tried to cut a trace on the board.

Furthermore I'm running the 2.9.1 firmware and have my compass checked in the hardware setting.

Best regards,

Jan Willem

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service